[solved] buttons misfiring

  • so recently i've been having an issue with buttons misfiring on mlr 2.51 on osx 10.7 on my 256. a button press on a row will trigger 2 or 3 spaces from the one intended. also when scrolling through presets the octave button gets pressed as well. i've been rewiring through ableton, and i took ableton out and played through the soundcard on mlr and it's still the same problem

    i hope it's not a hardware issue; i've changed out usb cables and they're still giving me the same problem. i tried the same setup with a greyscale 128 and it worked ok.

    i have a show in 2 weeks :( gotta get this taken care of.

  • D: i hope this not the case. is there anything that's not to arduous that i could attempt by myself?

  • you could open it up and check the ribbon cables haven't come a little bit unseated. this seemed to be an issue with odd press behavior for me for a while after doing the bus power upgrade. reseating them fixed it.

    remember to check where they are before refitting the screws on the back as to not pierce through them.

  • it's clear we had a bad batch of keypads at some point. i'm getting a new replacement batch made which should be available in january.

    i'm not sure what your tolerance for arduous is, but a fix will definitely require a take apart. e-mail info at monome if you want to arrange something.

  • i took it apart today. it looks like it was a loose ribbon. jammed out for about half an hour and no problems.

  • :) excellent. all solved?

  • it's all solved!

    also, as an additional question, what are the specs of the the ribbon cables and would it be wise to invest in ones that are slightly longer to make connecting them easier?

  • you could, but there shouldn't be any trouble if you get it back together soundly. nothing should move once assembled.