/mlrv2.3/ dev feedback

  • EDIT: thanks folks -- we've got our final release candidate prepared and just doing some final testing. thanks to all for your feedback — we think we've fixed all of the issues you've raised!

    official release should be up in a day or two tops!


    hey folks:

    please only download if you want to help us test it and give feedback
    it's not ready for mass consumption
    will release the official version this evening (7 hours and counting)

    please post all feedback / bug reports / errors / max6 experience reports / desperate feature requests here:

    happy solstice

    EDIT: serialosc1.2a required

  • Monomes recognised and connected but not getting any sounds or led response on either my Walnut 64 (connected to iMac Core2Duo) or GS128 (connected to MacBook Pro (June2012)) - both machines have the latest Serialosc(d) 1.2 installed... (both also running Mountain Lion)
    I have tried running this in MaxMSP 5 and Max 6 (all needed externals installed asfik)
    Not sure what is going on, sorry Trent.

  • can you try re-selcting your serialosc device? i know that's been a little strange for me...

  • OK, thanks - getting a response now, re-selecting worked. I got a tapout~: sampling rate does not match tapin~
    message in the Max Window before I did that however (when I first loaded the app) not sure what that means.
    Am I right to assume you still run MLRV preferably in Max5 or have you got it working OK in 6?
    P.S. when I try and select 6 groups, I only ever see 4 in the interface?
    Cheers and thanks!

  • the tapout~ error is new to me. what sample rate are you running in max? also, does this only occur in max6, or in max5 as well? this would have originated in the delay and/or sampler section, so shouldn't stop the central program from running.

    regarding 6 groups - is this just for max6 or m5 as well? it's working fine on my system.

    regarding max5 versus 6 — the program has always (and is still) principally developed in max5 to ensure maximum openness (ie. people that haven't bought max6 can still edit it). i have been testing in max6 and it's been pretty painless for me though — just a few GUI issues that need to be ironed out. i'm hoping this update will be compatible with both max5, and max6.

    in spite of the above, does the software work as expected generally? are you able to load your old presets?

  • The tapout~ error occurred in 5, as did the not seeing 6 groups thing...

    Just trying it out in Max 6 and I haven't seen the tapout error again, perhaps it was a one-off from something I inadvertently did. In answer to the sample rate, checking it on reloading the program in Max 6, it was set at 96000, which I rarely have it set in...
    In Max 6 I am still not seeing 6 groups however.
    Also loading a preset doesn't bring the sample waveforms up in their respective slots, I can still access them from the drop-down list however.
    Once I load the samples into their slots, the program behaves as I would expect however.

  • Its a shame I don't live in Hawthorn anymore, otherwise I'd invite you over and show you exactly what it was doing on my machine over a cuppa...
    The Dandenongs is probably too far away for you at the moment!

  • hey, the 2.3 update is much appreciated! I just took a quick peek to see whats new... What's the Vinyl tab for? It appears blank/empty. Also, the groups won't change to 6, gui doesn't update. (max 5 and 6)

    there are some things mentioned in the changelog i don't see anywhere in the patch- Alt. Interfaces, +Mixer, +Dynamic, Pointcloud, INSERTS + TOP-ROW, unquantised pattern recorders, 64f.
    are these features still tbd?

    edit- the changelog also says the pattern recorders use a double-tap for clearing a pattern, but they seem to function just like in 2.2 (hold to clear) "press-release" doesn't seem to work too. my one desperate feature request would be a classic pattern recorder mode. the hold to clear method always felt awkward to me.

  • just found a minor bug- on my 256, when i hit pad 0,2 (first pad, 3rd row) to play a sample, the pad 0,10 lights up(and stays lit) for no apparent reason. i noticed pad 0,11 light up for no reason once too, but not sure what caused it.

  • unquantised pattern recorders???!!??!?!

    um not getting lights or sound
    but i successfully loaded a sample

    i should probably not jump in on this beta cause i know nothing about computers
    anyway max 6
    greyscale 64 over here

  • yeah, i just found the unquantised pattern records, but i can't get them to work at all. press once to start recording, then press again to set length and begin playback, right? when i press the second time nothing happens...

  • @gli - I had a similar issue, try refreshing devices & connecting your monome again - when it is properly connected you'll see a rotation option in the connection box as well. Then LEDs & sounds should work.

  • gonna try again in a minute

  • ahhhh -- forget to mention >> you need to have serialosc1.2 running in order to communicate to the patch.

    if you don't want to upgrade to an alpha driver i understand! — just please wait for the finished version

    ALSO NOTE: the changelog file is the design file from the whole mlrv evolution. the current changes and additions start 3/4 of the way down under "change log 2.3" in giant text... everything else is left for historical reasons.

  • when starting up ...
    first its in conflict with my audio driver i have to kill mlrv by pressing dac
    and its quite difficult, buggy makes me nervous. After connection with
    rewire it works good then ...
    little timing problem my loops have not perfect loop BUT
    i think i found it i have to refresh button 44100 then it work oke for me ...
    midi recording in ableton still not working , it records midi notes but No output
    i am used to do it in two diffrent midi ch Mlrv in and Mlrv out simply drag from one into the other track after recording session ...
    i am using midi yoke and set it's ch TOO 15 like recommended

    In Rewire mode i can't change line output or not all the time don't understand
    maybe totally wrong ...Really need version that i can load with pages



  • seems to be working fine so far with me.
    only real problem i encountered was getting my monome recognised, but a few tries at reselecting/refreshing solved that.

    also is the delay up and running yet? doesn't seem to be working for me.

    sample rate is 44100 and CPU is at 12%

    have yet to try to rewire it into ableton though

    looks great trent, can't wait to explore it more.

  • re: delay & reverb

    there's a new method to using the sends now, to accomodate multiple blended effects. instead of mapping to the 'send' button in the 'A' return channel (this is now another 'mute'), you map the 'delay on' button in the tab itself.

    also make sure you try changing the delay time as i think there's an issue with the initial preset where it's set to 0ms to start with (?!)

    i've added the 'old' zeroconf version of serialosc as a setup-pane option, so that should solve these having-to-refresh issues

  • Bump/can't wait to get back to my Monome to test this!

  • loading in samples ok, no lights or sound though. Not running serialosc 1.2 though so will wait for finished version. Added features look awesome! Midi recorder...mmm

    CPU running at 17%

  • Galapagoose,

    I've re-downloaded the mlrv2.3 from the link above and I don't see the zeroconf option in the setup pane. I was wanting to try this new option with Pages 2. Is there another download link?

    Also, I've been really enjoying using mlrv2.3 as a sort of VST through Ableton. The only issue is mlrv doesn't stop playing when ableton stops. Is it possible to send a stop signal from ableton?


  • mlrv2 worked fine with pic2osc (arduinome with pic version of serial) but havent been able to get any response with v3. samples load ok though.

    will this only work with serialosc?


  • hey trent,

    rewiring into ableton was fine for me. no problems encountered (i'm running Live 8.1)

    that reverb/delay problem was pretty weird. it wouldn't work at all for me when tempo synced and delay time was initially set to 0.00
    also the delay would stop working if i changed the sync from say 2 to 4, but worked again if i messed around with the delay time afterwards.

    hope this makes sense :/

    also, if it helps you to know, i am running serialosc 1.2 currently

  • so far my experience is pretty solid but i am having an odd issue where i have to rotate it to 270 then back to 0 or it will set rotation to 90 on load.. (still reports 0)

    i hope that makes sense.

    otherwise it has been pretty solid in max6.1 ... i have not tried rewire yet where is where i had all of my crashes in 2.2. i hope to have some time tonight so i can edit my post.

  • thanks folks -- we've got our final release candidate prepared and just doing some final testing. thanks to all for your feedback — we think we've fixed all of the issues you've raised!

    official release should be up in a day or two tops!

  • *faints*

  • ohohohoho great!

  • been checking this out every hour ....
    hopefully it's gonna work with pages ...
    thanx in advance

  • LOL. I'm subscribed to the RSS of this thread and your post got me excited. HA!

  • Where is it located for download?

    or is it not public yet or something?

  • The original thread had a link to download the initial 2.3 candidate, but goose edited it recently.

  • ahh. waiting to be reposted. people are probably like thinking my activity is his in excitement. haha sorry..

    no more onions?

  • NoOnions

  • apologies for the delay. we've just been ironing out the last few kinks. realised i forgot half the backend of the arc tab...

  • Hi galapagoose,

    Will mlrv 2.3 support 48 kHz sample rates ?

  • may i ask what's the status of mlrv 2.3?
    It's nowhere to be found!

  • mlrv 2.3. so polished, it will blind you. ;)

  • I'm so tired of these stupid eyes!

  • Hi I'm having a small problem with 2.3, I guess you may have fixed that when you release properly but thought I'd mention it anyway.
    Its changing my sample rate to 64,000 whenever I open it up, and if I try to alter that max crashes. Going into mlr 2.8 and changing it back only works until i next start up mlrV.

    I didnt notice this before because it seems to work fine at this rate when just coming straight to my soundcard, so I only noticed when I tried to send the audio through Ableton, which doesnt like it at all...

  • can anyone tell my when the new release will be released ?
    or where 2 find it ...

  • when - pretty soon as i heard
    where - http://parallelogram.cc/mlrv/ (you have to scroll all the way down there you find the different versions starting from 2.0 ...)

    in the download included are the ~xsample Max external files. there is a .txt file which says where to put these little friends. supa dupa easy.
    have fun.

  • My guess is it'll be announced on this thread.

  • //Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump//Bump

    Any updates?


    must i wait for the next mayan apocalypse?

  • Been wondering where this disappeared to and wondering like many others...

  • +1 for being stoked on the 2.3 release!

  • would it be possible for mlr to support midi files? send midi to ableton and chop it up with the monome? (consider it a feature request for mlrv 3.0)

  • @elquinto you'd have to use some kind of audio piping software (soundflower / jack etc) select this as the output from ableton and the input to mlrv / other monome app.

  • hey elquinto -- afraid we're all turned off for feature requests. final version coming before i head back to australia tomorrow!

  • would be a cool feature for 3.0 though! audio and midi clips in mlr...

  • Sweet! Can't wait.

  • @elquinto I'm not following you. I think mlrV2.3 does, in fact, do this.