mlrv 2.2 + Launchpad Insta-crash Problem

  • I've tried searching around for some info on this, but nothing I've found seems to address the issue I'm having, so any help would be very much appreciated. In a nutshell, my goal is to use mlrv with my Launchpad, but I can't seem to even launch mlrv to get things started. Mlrv will load to the splash screen (the page with all the names and credits and whatnot), but within a couple seconds, Max totally crashes before I have a chance to do anything at all. As far as I can tell, I've followed the setup instructions. Before crashing to the desktop, the error messages in Max say something about "as_asio no samplerates work for us." Is that familiar to anyone? Seems like it could be an audio driver issue maybe? Since I can't access any driver settings in mlrv due to the crashing it's tough to troubleshoot this. Here's what I've got:

    mlrv 2.2
    Max 5.1.9 runtime
    Windows XP SP3 32 bit
    As far as audio drivers, I use either ASIO4ALL or the Mackie driver for my firewire interface

  • how do you go loading other audio based max patches?

    make sure you start with a fresh unzip of mlrv, and make certain you have restarted max freshly and haven't opened anything before. the audio driver will start off when max loads and if you have a new unzip of mlrv it should not turn on the audio driver at all so this situation shouldn't occur.

    edit: is there any provision for setting alternate sample rates on your audio hardware? perhaps asio4all has some bogus sample rate setting?

    you could also try loading max without your audio interface plugged in to start

  • I'm still pretty new to Max, outside of Max for Live. I'm at work at the moment, but when I get home I'll re-download mlrv and try it again. Maybe I did something the first time without realizing it. Regarding the audio driver, now that I think about it, neither asio4all nor the interface's driver are default, I don't think; I would set them in the preferences of whatever audio application I'm using. So I'll look into settings, try some things out, and report back. Thanks.

  • Success! I don't know what I screwed up the first time around, but I re-downloaded a fresh copy of mlrv and now everything works like a charm. I dropped in some loops and an hour flew by before I knew it. Awesome!

    Next step is rewiring into Ableton, and I have a question related to that, as I noticed that mlrv pretty much "takes over" the Launchpad. Is there a way to be able to switch back and forth between the Launchpad's normal functions in Live (such as clip launching and such) and the way it functions with mlrv? For instance, having the Launchpad only control mlrv when it is on the "user 2" page?

    Thanks and cheers

  • that is a question i have as well.

    an other one is : after some minutes, launchpad's lights stop responding, and i have to unplug it and then replug it to continue my session.

    btw cant wait for the 2.3 version!

  • to be brief:

    1. no you can't use the launchpad's ableton oriented controls - mlrv2 is designed to take control of the whole launchpad. if you wish to use the traditional launchpad services, try 'nonome' or 'monomeemu'.

    2. the light's issue is caused by some strange buffer overload where pressing the pads is somehow unresolved and eventually blocks outward traffic. i have been unable to tie down why the launchpad reacts this way, but it is a fault of the launchpad firmware.

  • Having used monomeemu before, I figured there was a way to make it work, but I thought there might be a better way. Thanks goose. I'm really loving mlrv.

  • thanx galapagoose !

  • Dang it, it seems I'm back to square one. After working fine the last time I used it, I'm back to being unable to open mlrv as a standalone app. It crashes immediately after the credits screen, just as before. Nothing should have changed, but I tried re-downloading mlrv once again to see if it would magically start working like last time, and no such luck. Same error messages from Max: "ad_asio no samplerates work for us!"

    What's very strange, though, is that I have no problem opening it when Live is running. As long as I open Live first, then mlrv, it doesn't crash. This would be fine, since using it with Live is what I'm going for anyway, except that with Live running I can't get the Launchpad to control mlrv. I've tried to work around this using Nonome and Monomeemu, but I can't get either of the emulators and mlrv to talk to each other.