serialosc 1.2

  • visinin - lubuntu 12.04, thanks!

  • have you looked through the linux setup guide?

    http://docs.monome.org/doku.php?id=setup:linux

    in particular, just section 2.

  • ah, got it. thanks. i didn't realize 1.2a was already on github. i've had the previous version installed for a while.

    just installed as per section 2, and now when i plug in my monome (gs 128, 2011), i only get

    ''serialosc: symbol lookup error: serialosc: undefined symbol: monome_mode''

    no "connected, server running.." anymore. any ideas?

  • you need to update both libmonome and serialosc at the same time.

  • hm, i did.. both installs said successful too.

  • that error means that libmonome is newer than serialosc. maybe try deleting your checkout and re-cloning it?

  • cool, good to know at least what the problem is.

    forgive me - i know nothing of git (and preliminary googlin' didn't help), what do you mean by deleting my checkout?

    i deleted my /git directory and re-did all of step 2 on the page you linked (after dependencies), same result.

  • the "checkout" or "repo" is the directory that git makes when you run a "git clone".

    it sounds like you may have an old version of serialosc laying around, then! could you run

    > which serialosc

    and tell me what that reports?

  • thanks! i had a feeling..the checkout man page looked way out of bounds. "which" gives me

    ''/usr/local/bin/serialosc''

  • hm, no, that's where it should be. can you run serialoscd from the git checkout directory? after you do all this stuff:

    > ./waf configure
    > ./waf

    try:

    > ./build/src/serialoscd

    does that work?

  • haha sorry for the delay, i was waiting for something to happen and didn't realize i should actually plug my monome in.

    i get ''serialosc [(null)]: disconnected, exiting'' with the monome
    * plugged in before running
    * unplugged/plugged back in while it's running
    * plugged in for the first time after it starts running

    whew. fun bonus, it completely worked!! once, with the monome plugged in before, but i haven't been able to repeat that.

    edit: i gotta go but i'll be back tomorrow. thanks for your help with all this.

  • not sure where to post this. Serialosc no longer seems to work with Max 6.1. It doesn't see any devices at all on the USB buss. Anyone else experiencing this?

  • apologies.
    I switched back to 32bit and all was well..... which asks the question, is somebody cleverer than I working on a 64bit version?

  • wrong again.

    doesn't work max 6.1 32 bit either

  • as far as i can tell max 6.0.8 is the most recent. where did you get 6.1?

  • 6.1 is the most recent beta version, which you need to use with the beta of ableton 9. don't think it's available unless you're on the live 9 beta.

    it can run in 64-bit, but all external objects need to be recompiled to work when it's running 64-bit and there is as yet no sdk.

    which would rule out any zeroconf apps working in 64-bit.

    however, my serialosc patches are all working fine in 64-bit and 32-bit with max 6.1.

    tehn and galapagoose's most recent serialosc patches which don't use zeroconf should work fine as well.

  • @visinin

    hey hey. if it helps anything, i get the same null, disconnected error running sudo serialosc__d__.

    edit: sudo serialoscd works! rebooted and it worked right away.

    observations:
    *disconnecting / reconnecting in the same session gives me that null, disconnected and error 9904, cannot find free port.
    *connecting after starting gives me null, disconnected
    *qutting and restarting serialoscd very quickly gives me null, disconnected. waiting about a minute seems like enough.

  • @95
    null disconnected means that serialosc doesn't think something you've got plugged in is actually a monome. do you have any other arduino devices, FTDI usb->serial converters, anything like that plugged in?

    did you do anything to make serialoscd run in the background? gernerally 9904 means there are several instances of the main process running.

  • @visinin
    nothing else plugged in, nothing to make it run in the background.

  • ah, but i never get a "disconnected" message when i actually disconnect the device. up until i plug it back in, it still says "connected, server running." so when i'm plugging back in, maybe there's no free port because serialoscd still thinks it's connected to my 128 from the last time?

  • your system sounds weird. something's up.

    please paste me the output of ./waf configure in both libmonome and serialosc.

  • sorry my post was so vague.

    I'd be more than happy to be more specific if you let me know what info you would like. I can happily load serialosc and see my monomes and arc in earlier versions of Max, which I have been doing, but the 6.1 beta version does not show any devices available. This is repeatable and consistent . If you need me to open up Terminal or Console to give you the info you need , I'm happy to do so. Just need to know what to look for. And yes, I got 6.1 through Live beta programme.

  • @visinin
    all right weird! here's libmonome, then serialosc

    ''$ ./waf configure
    Setting top to : /home/me/git/libmonome
    Setting out to : /home/me/git/libmonome/build

    Checking for 'gcc' (c compiler) : /usr/bin/gcc
    Checking for endianness : little

    Checking for working poll() : yes
    Checking for library dl : yes
    Checking for libudev : yes
    Checking for liblo : yes

    'configure' finished successfully (1.879s)
    ''

    * * *

    ''$ ./waf configure
    Setting top to : /home/me/git/serialosc
    Setting out to : /home/me/git/serialosc/build

    Checking for 'gcc' (c compiler) : /usr/bin/gcc

    Checking for working poll() : yes
    Checking for libudev : yes
    Checking for libmonome : yes
    Checking for liblo : yes
    Checking for libconfuse : yes
    Checking for header dns_sd.h : yes
    Checking for library dl : yes

    'configure' finished successfully (1.291s)''

  • @richarde

    Interesting... could you try opening this "SerialOSC Example.maxpat" and see if your monome devices are being detected. Worked with mine running 64bit Max 6.1.

    It's a work in progress patch but if your devices are appearing in the drop down that'd be a start for working out why it's not working for you.

  • MAC OS X 10.6.8 - all seems fine, dropped the new serialosc patch into some old apps (mlr, flin, polygome etc) and they seem to work fine.

    quick noob question to app devs - are you using the monome size from the connection message i.e i get

    /serialosc/device m128-481 monome 128 17902

    or sending a /sys/info message?

  • you need to send a /sys/info message

  • gotcha - cheers

    good work visinin & tehn much appreciated.

  • trent and i are reworking the serialosc.maxpat heavily. should have a new version by early next week that is more predictable.

  • new serialosc device managing app here:
    http://post.monome.org/comments.php?DiscussionID=15814

    collects all the device information available from serialosc for all currently connected devices and displays it all, also allowing you to change all of the editable settings i.e host, port, prefix, rotation, tilt.

    also wanted to start a discussion about routing/spanning apps and a protocol. text from the other thread posted below as this may be a better place to have the discussion.

    --

    my next plan was to further develop and finish a routing, spanning, setup preset app. however, building this got me thinking.

    the way the current serialosc.maxpat patches work they effectively totally take over control of the selected device, stopping it from talking to any other apps by randomly changing the port and setting the prefix.

    when zeroconf looked like an option for all systems this was workable as routing/spanning apps could announce themselves and be picked up by other apps in the serialosc.maxpat drop down menu.

    with the serialosc device api over osc only physical devices show up (which is awesome!) so we need a new way of allowing intermediary applications to be selected and focused on.

    i think there needs to be a discussion on how these intermediary applications should talk and how they can be picked up in a serialosc.maxpat and used as if they were physical devices.

    i don't think it would be good to have lots of different serialosc.maxpat versions, some which just connect to devices, some which connect to someone's personal router software, some that work with spanning etc, and having to keep track of which one was in which version of the application. could end up like a bit of a headache, which was how some m4l app development was getting when there was the "auto-config", "auto-focus" and "standard connection" to incorporate into every app.

    good idea?

  • @visinin
    it's not urgent, but when you have a chance, could you look at my post from 1/31 and tell me if have any thoughts? thanks!

  • I've just made some massive updates to the Ubuntu PPA:
    https://launchpad.net/~artfwo/+archive/monome

    serialosc 1.2 is now there for all the Ubuntu versions down to 11.10 (Oneiric Ocelot). Enjoy!

  • Thanks for fixing the Linux install.. was able to actually build and install the latest version from git today, haven't had a chance to functionally test but my prediction is it'll be fine.

  • i just had serialosc at 100% cpu in activity monitor. i've had this happen a few times in the last month. i'm on serialosc 1.2. any fix?

    osx 10.8.2

  • hi all, I'm having a few troubles with setting this up... after installing serialosc, everything seems to go to plan. Myr, your Monome Home patch picks up my arduinome and registers test presses/map tests as it should.

    BUT when I'm trying to open up any other patches (MLRV2, stretta's M4L suite etc) they don't register a connected device at all. When I run check-monome.command I get this:

    FTDI installed: ok
    FTDI running: ok
    SERIALOSC installed: NOT OK -- install serialosc.
    SERIALOSC running: ok
    MAXPAT installed: ok
    logout

    But in activity monitor there are three instances of serialosc running and it all seems to be installed.

    Any clues? I just moved over to mac from PC so I feel like a total chump when trying to set up anything slightly technical.

    I'm on osx 10.8

  • @elquinto: restart serialosc. http://monome.org/docs/_media/setup:monome-commands.zip will help.

    @doug: does monome-test work? and clearly there's some sort of problem with the check-monome script if it's not seeing serialosc. can you open a terminal and type: which serialosc

  • hey thanks @tehn for a seriously prompt reply! monome-test doesn't pick up on there being a connected device (whereas Myr's Monome Home does oddly enough). I tried the terminal command, I am probably doing something wrong but typing in which serialosc doesn't seem to give me a result, it just starts a fresh line.

    OH crap, does serialOSC even support arduinome? Is that the problem that's been staring me in the face?

    Sorry I can't explain my situation any further, I feel like my limited mac literacy means I'm totally stabbing in the dark. So yeah, big thanks for taking the time to reply and trying to help me out even though my problem is probably something obvious/most people could probably figure this out themselves!

  • Hi,
    I'm also experiencing problems with my monomes not connecting, even though the apps show them as connected. The test app works perfectly, but when i run monome commands i get the same results as Dougw.
    How do irestart serialosc?
    Thanks!

  • I turned off and then restarted serialosc, but still the same.
    I wonder if i should uninstall and reinstall it? Not sure how though...

  • which OS?

    open a terminal and type

    which serialosc

  • 10.8.2 i think, the newest mountain lion anyway.

    I tried that, but nothing happened it's been a long time since i've used terminal, do i need any other commands or to enter any other characters?

    activity monitor showed four or five instances of serialosc running if that matters.

  • can you take a screenshot of the terminal when nothing happened?

    four or five? how many devices plugged in?

  • Hi, screenshots here. four serialoscs.

  • two devices.

  • thanks. the terminal results are confusing but it seems to be running.

    are you testing with monome_test? max errors? post a screenshot?

  • Yes, monome test works fine. I'll post screen shots tonight.

  • oh, that's good. what isn't working then?

  • ah, remember that the executable is `serialoscd` now, not `serialosc`.

  • aha yes!

  • none of the apps other than the test app work. they show my monomes as being connected, but they're not, no leds light up and i can't work the software.

    i'll try which serialoscd then?

  • honestly i think it's a serialosc.maxpat issue. let me know which apps specifically and i'll test them with the new serialosc.maxpat.