mlrv 2.4

  • "exciting final version! over 100 tweaks and updates!"

    please enjoy.

  • Oh my goodness! Thanks for all the hard work guys!

  • Thanks dudes, for a fun Saturday night!

  • ok so I have tried the latest mlrv and all is good but I can not connect to this version. sorry if i am missing something and wasting time but I just cant seem to get it going?

  • thanks for the update guys!

  • @parallelogram

    hey, row count setting doesn't seem to be working. the interface is stuck on 7 rows.

  • and that +vinyl tab sounds sweet, but its not in the dropdown. is this the right place to report bugs?

  • please note, this patch requires:
    – serialosc 1.2a (
    – serialosc.maxpat installed per the setup guide (see point 4:

    max5 is still recommended for better stability and lower CPU usage.

    @elquinto looking at it right now

    +VINYL tab will only be displayed as an option if you have the mspinky max externals installed. see:

  • thank you. all works now! However i am with elquinto although i have the rowcount at 15 (after setting it to a 256) in the settings but the actual working "drop your samples here" only shows a row count of 7?

  • @nice-icles -- did you download the above link i just posted?

  • i'm downloading it now. getting pretty bad speeds though. 5 kb/s

  • ok, i'm getting 15 rows now, thanks trent.

  • @galapagoose

    i'm looking to get the classic on/off pattern recorder behavior. can u give me a tip on what i need to edit in the pttrn.maxpat? i did this mod in 2.2 but it no longer works in 2.3.

  • afraid that one's in your hands. i rebuilt a good deal of the code that runs the pattern recorders — they quantize the button presses before they enter the recorder, also the re-entry is now linked to the quantize tick so they should stay in time when re-engaged now.

    if you want to modify it for the old functionality, look at the 'states' gate on the right. you'll want to take the 4th outlet and trigger a 'clear' and reset back to state1.

  • thanks for the tip. i just spent a good hour with 2.3 and thought i should post some feedback. most everything feels very solid. I really love that built-in reverb. just a couple problems so far. tapping in a beat with slices sounds perfect in non-quantized mode, but when i was using 16n the slices always sound too short or too long. tap a pad in slice mode on 16n as fast as possible and it always sounds different. second problem is i could never get the unquantized pattern recorders to work. press once, input pattern, press again to set length right? when i switched back to 16n the pattern recorders there were unresponsive. had to reboot mlrv. also, is there an option to record group stops to patterns? i thought there was in 2.2.

  • slice mode quantize:
    both presses and releases are quantized, so if you press & release before the quantize tick comes around you'll get a little blip. if you press before the tick, then release after the tick, the slice will be 1 quantize tick long. it's very much a feel and practice thing to get it sitting right.

    unquantized pattern recorders:
    while i believe they're working properly, to be honest i'd far recommend using the new +MPATTERN tab which is a much more well thought out recorder approach. this is the section that properly sets the length of a recording and adds a 'clear' button for more logical interaction.
    the whole pattern recorder concept of setting the length before playing it really doesn't make sense in unquantized mode without some kind of metronome.

    group stops:
    these have been merged into the 'record automation' parameter in the setup page.

  • ok, maybe I'm doing something completely stupid, but I couldn't find a solution to this! So here I am. Got a monome64 walnut, MaxRT 5.1.9, serial-osc 1.2a, xsample files installed (win7 64bit) and I have uninstall the zeroconf externals.

    MlrV 2.3 (and 2.3002 version) load smoothly, I can load samples and all, but how do I connect my monome? From the setup I choose monome 64, but device input/output (both say :none) right under the device, are deactivated (clicking on them doesn't do anything).

    What could be wrong?
    I'm guessing the abscence of zeroconf extrernals is NOT the issue here (it's explicitl in the bugfixes that zeroconf is no longer necessary with serial-osc 1.2a)

    Any pointers? Can't wait to get my hands dirty!

  • @galapagoose

    interesting. i didn't know the endpoints of the slices were being quantized. i'll have to experiment with the timing. and thanks for pointing out the mpattern tab. unquantized patterns are working great with that. being able to set the length of the patterns on the fly is really cool. reminds me of sevenup. its going to take some getting used to the clear button i think.

  • serialosc.maxpat was missing! I fetched a copy and it works!!! :)

  • @fozzy
    don't worry about the device in/out being 'none' and grayed out. mine looks the same. i think thats for launchpad/livid/apc users

  • another question since i haven't been using mrlV for years... can I record live audio? (for example from a soundcard input and/or from my DAW) I tried the recording but it generates a file called "Untitled" with no file extension, and I really don't know whether it's audio or not. Tried a few players but it wasn't playable.

  • updated release now posted to:

    • added +MPATTERN tab for dynamic length audio / event pattern recording
    • fixed row-count issue where wouldn't respond to any number other than 7
    • fixed issue where the alt(option)-m shortcut for mapping would overwrite the last added mapping

  • just noticed, when resuming a paused pattern it re-engages one press late. (for ex. if u record kick, snare, kick, snare, it resumes on the snare)
    in +mpattern the variable recorders don't have this problem (it would always resume with the first press/ kick)

    edit- seems like it resumes 1/16th late on the fixed pattern recorders if quantization is set to 16n.

  • probably a bug- when u record a pattern of slices (quantized) with +mpattern recorders the release time of the slices is off when it plays back. doesn't sound anything like the original pattern.

    the fixed pattern recorders don't do this.

  • nice!.
    just realized, when using with _pages no extapp-connection appears in dropdown menu.

  • hey all,

    re: pages support, pages does need zeroconf to setup a virtual monome, there's just no other way to do it with the new zeroconf-less detection mechanism. serialosc 1.2a does support zerconf though so there is no need to mess with that. it's really just 2 additional steps:

    to get pages to work you need a zeroconf-enabled serialosc.maxpat, replace step 4 of the setup guide with that. i just grabbed a copy from the file on this page:

    you will also need to install the zeroconf externals as per usual.

    that's it though, it appears to work fine now. i haven't actually tried pages yet but it is detecting my monome via zeroconf so i don't see why it wouldn't work.

    i'm also adding this info to the wiki.

    edit: tried it, works great! info added to wiki under pages app entry.

  • @phortran is right — if you want to use pages, you'll need to use the old zeroconf version of serialosc.maxpat. you should still place it in your max/patches folder just for contiguity with the workflow.

    i know something a bit funky is going on with the way the quantize of the MPATTERN works -- it's a pretty complicated arrangement and only recently included in the patch. any help in ironing out these bugs is much appreciated as i don't use the pattern recorders a lot myself and it's not a top priority for me.

    i'm going to wait for any further bug reports for a couple days then i'll try and push those final edits out all together so we can all call it done and be happy and move on to making music again after a long hiatus...

  • it would be better if the release times on presses were not quantized (also in variable and fixed pattern recorders), whether or not global quantization is on. thats my point of view, though i'm sure theres some reasoning behind it i'm not understanding.

  • it was a decision we made a long time ago, but the reasoning has since left me. as i understand though, that's the way it's been since mlrv2, and nobody has complained (to me at least) in the >2 years it's been out. i appreciate that for some playing styles it might not be as well suited, but it should be a pretty simple modification to change (look in 'output.maxpat' towards the top, and filter out '0's which are releases).

    that being said - i understand the MPATTERN quantized releases aren't working quite properly (they always seem too long) and i'll endeavour to fix that.

  • I'm having a couple issues using version 2.3 with a Launchpad, although I'm not sure if they are LP-related or not.

    1. Firstly, this new version seems to have cured the problem I was having with version 2.2 where Max would crash immediately upon opening mlrv (fingers crossed that it stays that way). I'm getting crashes in other situations now, however. The two I've found so far are when I try to load a preset and when I attempt to change the audio driver. It doesn't happen every single time, maybe about 50% of the time I try to do either.

    2. I'm getting a lot of clicks and pops when audio is playing, particularly when altering the playback of a loop or launching a new loop. Sometimes it even just "freezes" and makes a buzzing sound for a second or two before resuming playback. I've tried changing around the I/O settings in the setup area as well as increasing the buffer on my sound card (and trying different drivers), but it doesn't seem to make any difference.

    3. This problem may be related to the previous one. Sometimes loops get out of sync with each other after a minute or two. The LEDs still appear to be tracking fine, like when playing two loops of the same length, the lights on the LP will be moving exactly together, but the audio becomes noticeably out of sync (and not by a quantized amount like a 16th or 8th note off).

  • sounds like you're having sample rate issues, and/or audio driver issues.

    how does other software function on your system? what about the original mlr(not v)2?

    are you running in max5 or max6 — max5 is recommended for lower CPU usage (and probably less clicks and pops).

  • apologies in advance for stupid question-
    Arc is connecting properly and I can see it changing levels or lfo rates in the tab. So what's the next step? Is it porting to another max patch that I now need to open, or can the arc be assigned to control regular mapping stuff i.e. reverb time, delay feedback, etc. Ima confused

    update. added an arc 4 tab next to the mappings tab, mapped 3rd wheel to reverb size. this works, except turning wheel causes major audio glitching? help?

  • you need to increase your audio vector sizes in the setup tab (try 256).

  • cool, thank you

  • re: galapagoose

    Other audio software runs fine. Most of the time I don't need my audio buffer above its lowest possible setting, unless I'm cranking a big project in a DAW with a ton of tracks and effects. It should be more than enough to handle mlrv. Increasing the buffer size isn't having any effect in this particular instance though. The CPU is around 10-15%, and I'm using Max 5.1.9. I did try the original mlr at one point, and there was some weird latency, but otherwise no clicking/popping. Does mlrv by any chance run at a sample rate other than 44.1?

  • mlrv runs at 44.1k by default -- i've noticed some strange behaviour where entering rewire would change the sample rate to 96k (in the host as well?!), but if you're running standalone it shouldn't be an issue. there is a parameter in the setup page to view/change SR.

    re: 'buffer size'
    are you talking about some external settings pane that sets buffer size independent of max? i'm specifically referring to the 'vector' sizes inside the setup pane within mlrv. if you have 2 settings, perhaps you could make sure they're set to the same setting? at this stage i'm just guessing though.

    the vector sizes refer to the size of the audio chunks that max processes in one scheduler cycle. as such it makes sense to have your audio interface communicate in identically sized chunks to avoid sync issues. on the mac this functionality is handled natively and not exposed to the user, so i'm flying blind on how this is handled in windows (been almost a decade since i've owned a PC!).

    regarding the crashes, try and turn off the DAC between changing audio drivers (click the far bottom right 'dac' button in the mixer). also, make certain the "DAC AUTO-ARM" option is turned OFF before saving your file. beyond that i'm not sure what to suggest.

    try using this DSP monitor if you're on runtime (otherwise hit >Options>DSP Options) and take a screenshot of your setup page & this options section.

  • I am working with windows 7 , max 5.1.9 , and seems missing something in my installation while loading in max runtime
    fifo unkown mode and bpatcher :error loading patcher EMPTY
    what am i doing wrong
    Thanx for all the great work greetings

  • Hey guys, just want to thank you for all your work. It won't go unnoticed. Respect to all!

  • @galapagoose

    re: unquantized release for slices

    ableton has a clip launch mode called 'gate' (which is similar to slices in mlrv) and the release times are unquantized even if quantization is on. i think this works best, and i'd definitely like for mlrv to have this behavior (even if i have to mod it myself)
    I'm looking at the output.maxpat right now. filter out '0's? what do you mean by that? i'm really scared of screwing this up. i hope this isn't too much to ask, but can u possibly post a screenshot of the changes i need to make or add a comment in the patch to make it easier?

    i also had a look at the pattrn.maxpat to get on/off pattern buttons, but i'm having trouble figuring out how to "trigger a 'clear' and reset back to state1." i'm a total noob at this. i'll keep at it, but surely this will go a lot faster if i can get a bit more info. again, a screenshot of the edit i can compare to the original would be much appreciated.

  • @elquinto:
    i just had a look at the patch again briefly, and re-discovered why we opted for a quantized 'release'. turns out, if you don't quantize the release, and you tap the button really quickly (ie press and release before the quantize tick) then the unquantized stop would happen BEFORE the press, and your supposed 'slice' would end up just playing through.

    i appreciate that ableton might do it this way, but the mode of performance in mlrv (fast and syncopated) is quite different to that of triggering clips in ableton (slow and usually on the beat). i'm sorry to say that my thought of filtering '0's isn't going to work.

    re pattern recorders, i'm sorry but you're on your own for now. i just don't have the few hours it would take to relearn how the switching mechanism in that patch. but please don't be afraid to break the software! you can re-download the zip file as many times as you like!

    just double-checked and those errors are just me forgetting to clean up after myself (i can be a real slob) — the app should still work in spite of these errors though. if you're seeing the delay tab when you hit load the missing "EMPTY" bpatcher is nothing to worry about and the other is just a floating object i've forgotten somewhere...

  • i got the classic pattern recorder mod to work, but i just want to double-check with u to see if what i did is ok. attached a screenshot of my edit. i just bypassed (t 1 4) and made a connection to (t 0 1)

  • while working on this mod i noticed a bug with the pattern recorders (non-modded- it affects the mod too though). this is super hard to explain but here it goes. i'll record a pattern (ex. kick, snare, kick, snare), let it play back, then stop and clear the pattern. then if the next pad i hit is in time with the first kick (every 4 steps) it either won't register or it will re-trigger whatever the first press of the pattern was.

    edit- just to clarify- when this was occurring i was in loop mode and 16n.

  • @galapagoose

    PM'ed u a video of the problem

  • @galapagoose
    When I was speaking about buffer size in my last post, I was indeed talking about the buffer setting in my sound card's control panel, in response to your question about how my other audio software works. In regards to this situation, though, I've realized that I had a mental lapse and forgot that I've been working in rewire mode (which I'm sure is pertinent bad). As standalone it seems to be fine now that I've had a chance to work a bit more with it. Rewire mode is where the problems arise. I had tried tweaking the vector settings inside mlrv, but they weren't making a difference that I could tell. So were you saying that the sound card's buffer and the vector settings should be the same? Or do you mean that the two vector values should be the same regardless of the buffer? Or does rewire mode change everything with regards to these settings? Right now, I have my sound card buffer set to 128 samples, and both vector options set to 128 (screen shot attached).

    Good news, though: I think I figured out this is in a roundabout way related to my crashing problem with presets, when I realized today that the selection of audio driver must be saved along with the other preset settings. A preset that I created while running mlrv as a standalone won't load in rewire mode. If I try to load such a preset, I think it tries to switch drivers from ad-rewire to my sound card's driver (which I used when creating the preset), and when Max sees the driver is already in use by the rewire host this conflict causes it to crash. This isn't too big of a problem, just something I have to remember in the future when I'm saving presets.

    982 x 613 - 157K
  • with 16n quant., there seems to be a problem when setting the length of a +mpattern recorder. there is a stutter, most noticeable when working with a drum loop. it sounds like an extra 'click' happens when i hit the button to set the length, then when the pattern repeats, the click is gone.

  • @bridog
    everything you've said makes sense to my ears. the rewire issue is definitely a big point. max can't really handle driver changes while the rewire audio engine is running. you'll want to match the vector sizes in mlrv to the buffer size your DAW host is using. in this instance mlrv is communicating directly to your host application, and not your soundcard so it's settings are secondary (though perhaps the same?).

    no need for vector sizes to be the same as each other, though they typically are. if you hover over the params in the setup page they all have tooltips describing the effect of turning them up/down.

    also, your preset issue is probably fixable if the DAC is turned OFF when loading / unloading a patch (make sure you have DAC Auto-Arm turned OFF). the rewire crash is generally avoidable if the audio engine is not running. finally, rewire adds a large overhead to both softwares. when i rewire into ableton, it adds an extra ~35% CPU in ableton (but not mlrv).

    i will try and investigate the recorders for you by the weekend. your mod for classic pattern recorders seems to make sense (i can probably add that to the setup panel seeing as it's such a simple edit).

    the 'quantize_queue' thing you mentioned is probably also correct — i think it has to do with a right-to-left ordering thing with the zl queue object. this is how i was dealing with recording multiple quantized events that happen within the same tick.

  • no connection with pages can anyone help me with this ...

  • from above in this thread:

    february 25
    hey all,

    re: pages support, pages does need zeroconf to setup a virtual monome, there's just no other way to do it with the new zeroconf-less detection mechanism. serialosc 1.2a does support zerconf though so there is no need to mess with that. it's really just 2 additional steps:

    to get pages to work you need a zeroconf-enabled serialosc.maxpat, replace step 4 of the setup guide with that. i just grabbed a copy from the file on this page:

    you will also need to install the zeroconf externals as per usual.

    that's it though, it appears to work fine now. i haven't actually tried pages yet but it is detecting my monome via zeroconf so i don't see why it wouldn't work.

    i'm also adding this info to the wiki.

    edit: tried it, works great! info added to wiki under pages app entry.

  • Hi galapagoose...

    First of all, thanx for your (hard) work, and for your music too!
    Really excited to try this new version, but it seems i can't load it right...

    Macbookpro OS 10.5.8 Max Runtime 5.1.3 & Walnut 128
    I was last version of mlrv 2 with Monomeserial (osc bridge) and never had any problem!
    I downloaded and installed serialosc 1.2
    Downloaded serialosc maxpat and dropped it into the right (i think) folder, and i also paste the 3 xsample files into their flder too

    When i load mlrv 3, it stops at the "congrat" page and stay bugged on it
    Max windows shows a lot of red :-), but mainly says:
    Object fpic Message doesn't understand "alpha"

    I'm really not an expert..
    Can you see where i'm wrong??

    I try to find on other topics...maybe something with zeroconf.maxpat ??
    If you (or someone else:-) can help...Because, the problem is that, for sure, no patch work anymore:-)

    Thanx a lot!

  • @reno khart
    this is definitely a max problem — you'll need to update to Max 5.1.9

  • I can't wait to use the new mlrv but must admit I am a little concerned about reconfiguring my system from its current state as last time I installed new serialosc it all went wrong and nothing worked. I am not a techie AT ALL so wonder if I jus follow the steps in set up page will the new serial osc just overwrite the old one on my Mac?