SevenUp 2.0.5d (UPDATE posted 08/02/2012)

  • anyone? I have tried everything I could find and dont know where to go next really

  • @freedux
    Sorry, haven't been around much.

    Your log looks ok so a bit stumped but the description of it working when you edit is strange. It almost seems like java debugging is setup OR the max lookup path points to a different distro of 7up.

    Can you paste your file? It's in Cycling '74/java folder.

    Why is your MAX install names MaxForLive? Did you rename it or is there a new MaxForLive specific distro for MAX?

    I just got the Live 9 beta so I hope to get some time to look into some recent problem reports with 7up in latest max and live versions.

  • no worries, thanks

    thats my bad, I didnt really know the difference between max and m4l at the time and I just couldnt be bothered to change it

    here is the config file
    ; This is the config used by Max when instantiating the JVM ;
    ; Comments are enclosed within 2 semicolons ;

    ; The file format is relatively fragile so pay attention ;
    ; when editing this file !! ;

    ; some example options one may use ;

    ; add all jars in /Users/topher/java/lib to the system classpath i.e. immutable classpath ;
    ; max.system.jar.dir /Users/topher/java/lib;

    ; add /Users/topher/foo to the system classpath i.e. immutable classpath ;
    ; max.system.class.dir /Users/topher/foo ;

    ; these next 2 are typically what you would want to use if you want additional directories ;
    ; added to your classpath for max ;

    ; add /Users/topher/myclasses to the dynamic classpath of MXJClassLoader ;
    ; max.dynamic.class.dir /Users/topher/myclasses ;

    ; add all jars in /Users/topher/myjars to the dynamic classpath of MXJClassLoader ;
    ;max.dynamic.jar.dir /Users/topher/myjars ;

    ; specify some jvm options ;
    max.jvm.option -Xincgc
    max.jvm.option -Xms64m
    max.jvm.option -Xmx256m

    ; uncomment these options(i.e. remove surrounding semi colons ;
    ; to cause the JVM to be created ;
    ; in debug mode and listening for remote debugger connections ;
    ; on port 8074. This would enable you to interactively debug ;
    ; your mxj code using JDB or some other debugger which supports ;
    ; the JDI wire protocol ;

    ; max.jvm.option -Xdebug ;
    ; max.jvm.option -Xnoagent ;
    ; max.jvm.option -Xrunjdwp:transport=dt_socket\,address=8074\,server=y\,suspend=n ;
    ; max.jvm.option -XX:-UseSharedSpaces ;

  • if thats any help I have the same problem with m4l versions of obo/polygome/etc (not discovering my devices and therefore unable to connect)

  • If the dropdown doesn't show you monome then it's a problem with either the zeroconf externals or serialosc.

    I did see a log entry saying it was some cassiel modified version of the libraries. They did seem to load however.

    search in this thread for "serialosc tester", it should verify just the zeroconf->serialosc connection.

  • I have problems with seven up.If i click anywhere on my Live set, seven up stop working.It,s something related with ableton, because if i don,t touch nothing i can work with seven up.The moment i touch a track head, seven up disappears.

  • I can confirm the same as Bite, happened to me in Ableton 9 beta and release versions.

  • its the component files, the ones in the template are faulty for some reason if you use the files located in the components folder instead it works just fine.

  • @slawww
    woau Thanks, this must be put in a release notes, because i quit using seven live only because these troubles

  • I don't own max... would runtime be fine? Sad, if not... I don't have money for max :(

  • is there any way to directly record the midi information from the melodizer to a clip in session view? i see when a device is armed and a blank slot is pressed within clip it begins recording but nothing shows up. I've been stumped on how to fix this, if its even possible. thanks!

  • Hi bar|none

    I've made an updated README file, which cover all step I've done before can using all Seven Up stuff, you could find it here ->

    hope this help someone

    Thanks for all your work on SenvenUp apps

  • love the app man. use it all the time in my writing process. I do have a slight issue, nothing major but a little confusing. Top row LED 2 is always blinking. Using ableton 9 Max 6 Windows XP. Serial OSC.

    let me reiderate it does not make the program malfunction at all, just the visual feedback is off on that one led

  • The export button under "manage project" is no longer in Live 9. How did you guys install the devices to the max library without this?

  • I was having the same issue for a minute.

    All i did was click the "Add Folder" button and added the 7up folder. then drag the components in as you need them.

  • Ok, apologies if I'm overlooking something stupid but I'm having a problem with SevenUp. When I boot up my computer and open a blank Ableton session I have no problem getting Stepper to work properly (just using the initial setup you're walked through in the installation instructions, nothing fancy). The minute I try to do the same thing in the session file I have my current live set in, though, it ceases to work. I'm getting the lit-up seven, but on Stepper it appears that there's no MIDI coming through. I can press the buttons on my 64 and they appear as though they're working (staying illuminated, blinking in time etc) but they're not triggering the samples on the kit. After I've opened my live set, if I try to open a new, blank session the same problem occurs. It only begins to work properly again after I reboot my computer.

    I took a look at the Max page for both Core and Stepper both before opening the session that caused it to crash and after. The only difference I found was on the Stepper, at the very bottom of the page it says, next to zeroc... "service published: /7up 10108"

    I'm not new to Ableton but pretty new to monome and computer programming in general.
    Any idea how I go about fixing this?

  • Hi everyone,
    nannod, it seems that if you put the pack in the user library (under Packs), you will have access to the presets and device (works for me).

    However, SevenUpCore does not list my monome, even though it is plugged and works when I test with other apps. Did anyone had the same problem (I am under SerialOSC)?

  • sevenup requires you to have the zeroconf externals installed. im pretty sure that's your issue.

  • Thanks elquinto, you are right I missed the line where they say I need zeroconf.
    However it still does not recognise my monome.
    I just have to paste the 4 files in Max right?
    I am not sure what to do with serialosc.maxpat. I launch it, and I can connect my monome, however SevenUpCore still does not see it.
    Any more good ideas?

  • don't worry about the serialosc.maxpat. sevenup has that embedded in the patch. the instructions say to put the 4 files here- /Applications/Max5/Cycling '74/max-externals/ but Live 9 uses Max 6 so keep that in mind. u need to install to the Max 6 directory. could that be why its not working?

  • I changed my computer recently so I don't have Max 5 installed.
    So I installed it in Max 6.1 folder.
    My monome lights up when I connect it, so the problem should not be from serialOSC I guess.
    Is there a way I can test if zeroconf is working? But I double checked, the filed are installed.

  • u said u opened the zeroconf serialosc.maxpat and could connect your monome, so zeroconf appears to be working. Your monome doesn't show up in sevenup core at all? i think i'm out of ideas...

  • Yes, it is working in zeroconf but not in Sevenup core.
    Ha, I miss the monomeserial area when everything was working (I changed my computer and reinstalled everything).
    Thank for the help though !

  • Maybe try editing sevenup core to use the standard (non-zeroconf) serialosc.maxpat. Just replace the existing one. Should be pretty easy.

  • @cha

    hope this works for you. it is modified, so no longer requires zeroconf

    edit- nope, doesn't work. not so easy i'm afraid. (removed link).

  • it seems 7up uses a highly modified serialosc bpatcher, so swapping it out with the standard one didn't work.

  • Thanks for trying elquinto.
    On my side, I will try to reinstall everything one more time, but I already did it some times so I'm not sure if the outcome will be different...

  • one other thing u can try- load sevenup core, hit the edit button on the device and once Max opens, check the Max window for errors (command-m on Mac). That can give a clue as to why it's not working.

    Btw- are u on Mac or pc?

  • This is the error file.
    I'm on a mac. It seems the problem come from a wrong architecture with zeroconf ?!
    To install zeroconf I just have to copy the 4 .mxo files in /Applications/Max 6.1/Cycling '74/max-externals/ and change the serialosc.maxpat, right?

    Thank you for the help elquinto!

  • u don't need to change the serialosc.maxpat for sevenup (m4l apps have the serialosc.maxpat embedded). that's only really necessary if u want to use max apps with pages. looking at that screenshot, I have a couple ideas... are u running Live in 64bit? i stick to 32bit and it works for me. u may want to try that. if I remember correctly, I think I read once the zeroconf externals are not 64bit compatible.

  • elquinto, you are awesome, it is now working!
    Such a great software.
    The problem was the 64bit Live. Changing to 32bit resolved everything.

  • sweeeeeet. i edited the wiki so hopefully nobody else has that problem in the future.

  • @elquinto I've been trying to get this for awhile and cannot. Not getting a zeroconf error. I'm getting a live.path (invalid path) error. Also, I can't get this work with my 128. It just doubles everything like its a 64.

    I'm running 32bit mode. Not sure why I can't make this work.

    Any ideas? Pretty confused about this.

  • idk, i don't get that error. if it doubles your 128 into two 64's it sounds like it's working though. its 4 64's on my 256. I'm just a casual sevenup user, so my best advice would be to re-read install instructions and manual.

  • I was having problems getting seven-up to recognize my 40h. i tried it on a 32bit version of Live 9 and that seemed to fix the issue. i haven't tried to actually use it yet, i'll post those results later.

    now i have to decide if i want to go back to 32bit just for SevenUp. Has anyone looked into how hard it would be to make SevenUp work in 64bit? or does anyone know of a clip launcher device for monome that does work in 64bit?

  • Hi, I just installed SevenUp Live today. I'm trying out the Looper, but am having an issue with the loops not looping. The loop encoders are responding ok, but the loops just play once then tail off. I'm running Looper in the default Slave mode, and the Core has Looper configured with the default of all loops looping. My track is running at 140bpm and I'm using the samples that came with the template in 2.0.5d zip. Any ideas? Thanks.

    ..I'm running Live 9.1.6
    Manually clicking the loop button on each Simpler resolves the looping issue. I wonder if the Loop option is a device preset which I've overwritten somehow?

  • Hey panoramica,
    I think there was a change in Live that influences 7up.

    My case: the drum sequencer plays each sound once, when playback starts.
    After that - silence. But triggering it manually still works...

    There seems to be a connection...

  • Very inexperienced Max user here. I am seeing this in the log when I attempt to connect to the manta. I follow the order of events as previously outlined, but the LEDs do not light when I attempt to connect. Any ideas as to what the problem might be?

  • @eugenb @panoramica

    I have exactly the same issue as you, and I would like to solve this quickly without digging the internet for old versions of software. I will try to see whats wrong and will keep you updated. Anyone who finds it out, please share.

  • the manta is vari-bright?

    If yes:
    no idea if that helps you but when using 7up with my launchpad&emulation i had to choose vaibright/multicolor (something like that) in sevenup.
    Unfortunately i didn't have that option shown in 7up's dropdown untill i de-installed java, installed the latest java6 and then on top of that java 7.

  • Me again:

    It looks like newer Live/M4l-Versions mess up with MIDI-messages,
    as mentioned in

    There is somehow no NoteOff-Message in the sequencing anymore.

    Could somebody please look into it?