mlrv 2.4

  • nvm...a cable orientation thing it seems

    Cable up on a 128 should in my head be 270 but that's what caused it, setting it to 0 seems to work.

    ...and i guess the can't find buffer thing is normal...

  • One more thing... In the sampler tab, fiddling around with the monitor button and banks sometimes the inputs stop working. Can't get any sound in from input 3 and randomly input 2 stops working, input 1 fine so far.

    I verified in a different max window that sound is coming in to max, so i guess problem is inside mlrv....just thought i'd share...

  • hey galapagoose,
    were u ever able to reproduce the bug in p pattern queue? i tried desperately to fix myself, but not having luck. if you have some tips on how to resolve that'd be great. or if there's a way to just delete the object and go back to 2.2's way of doing things, thats what i'm working on now.

  • yo, finally got myself to upgrade... thanks a million for this!

    here's one important find. i'm running max6 runtime and there seems to be no way to access max' audio setup. in mlrv i can change driver, but i can't change what interface i like to use. i think you need to add adstatus or something like that, but i don't really have i clue.

    either way, my workaround is to open audio status from tml.

  • another neat solution is to not run max 6 runtime...

  • how do you guys deal with the volume in mlrv or with the samples used in mlrv?
    my problem is that i have some samples which are too loud and some which are too quiet..
    do you a have a kind of allround-solution which makes things easier for me?

    would be great! : )


  • @birdster:
    every row has a little horizontal gain slider giving +/- 12dB per sample. that should get you pretty close...

  • ahh, the next time i think twice before i ask such question :D
    of course you are right @galapagoose!

    but please let me phrase it differently:
    i haven't prepared sets yet, so every time when i'm fooling around a little bit i have my "crate" open and drag the loops into mlrv spontaneously.. so it's hard to estimate the volume without cue-listening, although there's a visual matrix.... i wondered if there's a way to keep the samples on the same level, without being shocked when you trigger e.g. the second row and it's loud as hell :D hope you know what i try to explain ;D

    i guess, it is more a question of correct rendering from ableton as a question of mlrv...!
    sorry, if this is the wrong thread..

    maybe i just start to build some sets^^

    thanks guys! ^__^

  • yeah i think you need to prep your samples first in a daw to ensure they're not too quiet / loud. however, when you drop the sample into a channel in mlrv the size of the waveform should give you some indication as to it's volume.

  • So I just got a monome! :D

    Problem is, mlrv doesn't work with it. I've gotten mlrv working before with my launchpad and nonome, and i've also gotten other programs working with my shiny new monome (using monomebridge) but it doesn't seem to work with mlrv.

    Can someone point me in the right direction?

    EDIT: I even got mlr 2.51+ working, but other mlrs aren't for some reason. So very confused.

    EDIT2: So I discovered that mlrv (along with any program) works only when the max that you have to trial is used. Now whenever I load a clip and start playing it, it doesn't actually play the audio and is stuck on the first square.

  • Hey guys. One thing I've noticed with the pattern record weirdness when using rewire. When rewired by clicking the Rewire Mode on/off button i find that the patterns play back out of sync. However, if I choose rewire from the driver drop down and go and manually choose separate rewire outputs on each of the 4 channels, it seems to work fine. Not sure if this gives you something to work with.

  • Actually nevermind, that worked for about 20 minutes and now im getting audio disabled. I'm using Live 9.0.4, serialosc 1.2a, and latest versions of max 5 and max 6. Both Live 9 and max 6 are 32 bit. I should point out that previously I had both 64 bit versions of Live and Max installed but have uninstalled following the respective procedures. It works fine in standalone. Any suggestions?

  • I cant use v3, timing issues. I can play my set fine in v2 but when opened in v3 the timing goes to shit. I cant work out why and no one else seems to have this issue.

    sad face

  • @vfierro I have found that I can't use my old .json files with the newest version. I have good results just starting new files. Saving a .json is still really tricky, though. You need to read the instructions earlier in this thread and do some experimenting as well. Find what works.

    I also had weird timing issues. I started new "sessions" made in the newest version and because I use rewire though ableton, I went into my midi prefs and had to set the output going to mlrv to -[total latency from audio tab]. I then went into ableton launched the metronome and adjusted until it was perfect. I've had to do this with all midi hardware, too. It seems pretty standard. Does this help you?

  • hey, what's the little number above the larger tempo number in the mlrv gui?

  • I'm pretty sure that's the button quantization. Im not looking at the GUI right now though.

  • @james
    that let's you set the tempo to be recalled with the preset. it's a little clunky, but there's a pref in the setup page where you can make it automatically update to that stored tempo when you trigger a new preset.

  • cool, thanks galapagoose

  • @flcon cheers Ill give it try later. I also use it rewired to ableton Ill see if that helps.
    thanks man.

    is there a way to edit the patch to change the default ports?

  • Hey guys, so I found that by rolling back to 2.2 that it works fine with rewire. I'll just chill with this version for now.

  • after flcon advice I started a new set and it was working great.
    after an hour or two of playing the timing issues with rewire came back and this is after I d painstakingly recreated my set by taking a photo of each preset while in 2.2 and then searching the files through finder and re setting up the songs in 2.3.

    so I guess I'll also stick with 2.2

    @Vfierro were your issues only related to pattern recorders or did you have slightly off timing
    with normal samples?
    for me it kind of feels like using the samples in 32n quantization mode.

  • fixed:

    everything works fine if you dont use the rewire yellow button, just select from the drop down menu and manually set the outs for the tracks.

    then dont click the yellow rewire tempo button but in the clock source tab select rewire.

  • @pekopeko
    sorry about that — was trying to improve timing using max's dedicated rewire clocksync object but it seems to have made things worse (and the timing is worse too!)

  • alright so iv'e got the lastest version of mlrv communicating with my monome, but it seems to have a mind of its own. in other words, tracks start and stop on there own. i can stop one, or all of the tracks and a few seconds (or minutes) later one or all starts back up again w/o me touching anything. i'm pretty sure this isn't normal, but maybe it is.

    also when i drag clips in the tempo is never right so i adjust speed to 1.000. this fixes the tempo, but then the master tempo no longer controls any of the individual tracks. thanks in advance for you responses!

  • Hello! Managed to get Live 9 and mlrv 2.3004 work in Rewire mode after a little struggle...

    I still have a problem though: both groups 1 and 2 send out audio only on left channel 1. The other groups work fine.

    In the mlrv interface the group meters work as expected, stereo audio on all groups.

    I'm running Max Runtime 6.1.2 (6a3e522) and Live 9.0.4, both in 32bit.

  • @galapagoose
    no worries, took me a while but im glad i found a work around.
    I know your work is finished with the latest version and its final but it might be worth
    making a thread of "instructions" to some of the issues people have had issues.
    i.e how to rewire
    old json files wont work etc

    Or I guess theyre listed in this thread already.

    I played a show yesterday with 2.3004 and everything went smoothly.

    One question; When setting the outputs manually at home I managed to have mlrv rewired to live but still be able to use the + mpattern recorders. this was awesome but I havent been able to replicate it since. I kind of flukily tricked it into working. When i try to set up the same way mlrv crashes or the +mpattern tab shows as unavailable in rewire mode.

    is there a way to have access to the +mpattern recorders while in rewire?


  • anyone know how the on-the-fly audio input/recording works? the tutorial video is two years out of date, so the input side panel doesn't seem to exist anymore. i just want to record some live piano/synths/acoustics & mash it all up, without setting tempo/bars in advance if possible. (i'd use mash2, but i couldn't get that to work, either, and it's not as good for prerecorded samples.)

    also, anyone else notice that the latest versions of mlrv 2.4 seem to be kinda...slow? i'm on a new 2012 mac mini -- 8gb ram, 2.3ghz quadcore cpu, and a fast SSD -- yet mlrv just barely chugs along sometimes. often enough the gui lags the monome response, or vice versa. nothing else is running on a pretty fresh install of 10.8.3, so i'm not sure what's causing the slowdown. the app's cpu meter only shows 5-7% load.

  • @ioflow - on the slowness - it's not quantisation giving the impression of slowness, is it? Often I'm thinking "Urgh, slow" and then realise that quantisation is on.

    It's running fast enough for me (although it's always had a very long load time) on my 1.4GHz Core Duo Macbook Air.

  • @declutter that was my first thought, but even after turning off quant, no change. it's especially noticeable when wading through submenus and even resizing the mlrv window, though it also happens when playing with just one or two samples loaded.

    of greater concern than the occasional lag is the lack of instructions, or maybe capability, for recording external sound sources. maybe that feature has been removed in recent versions?

  • hey ioflow, i haven't experienced the slowness you described, maybe try messing with the dsp settings. recording is indeed still there (+Sample tab). this screenshot should help.

  • anyone else have problems with tracks starting and stoping on their own? i can't seem to figure this one out, or find anything in the forum mentioning it. when this happens the program will start running through my presets randomly too, and firing sample rows :/. i'm on a 256 2012 running serialosc 1.2a, mlrv 2.4, MacBook Pro 2012 osx 10.8.

  • i figured out the sample input issue, but in the process uncovered a bug:

    after recording an instrument into any input, its playback speed is ALWAYS set to 0.5. everything starts at half speed...why is that? it's annoying to have to go to the keyboard and mouse to change it back to 1.0. which reminds me: is there a way to setup a button to toggle between halfspeed and fullspeed? and, occasionally, whenever i have set the octave correctly to 1 (instead of 0), the whole thing is repitched up a major third. every sample i record is repitched...transpose and octave/speed are unchanged, but nothing plays correctly.

  • Sorry if this has been addressed somewhere else--is there documentation for the extra tabs (mpattern, msample, etc). I'm brand new at this and am a bit confused, at least with the mpattern tab... :/

  • they are more of a 'play around with it and figure it out' thing.

    mpattern lets you record presses & audio simultaneously.

  • Ah, yes, sorry. I didn't realize there were buttons to be mapped! Is the "settings" button supposed to do anything? Also, is there a way it can be set so that it starts recording from the first button press (like the pattern recorders up top?) At the moment it's recording any fraction of space before my first press, making it difficult to sync with the other loops--but that could also be because I'm attempting it unquantized...

  • it should wait until the first press, but is also triggered by audio threshold, so perhaps the solution is turning down (or up?) the threshold for recording?? (it's been a while)

  • ah, that was it--the threshold! thanks :) are the mpattern recorder buttons quantized (when quantize is set to none)? I figure not, but it seems that the loop often starts a bit late on most of the time, though not always. Just in testing, a straight quarter note seems difficult to loop unquantized, even when i'm sure my hits are tighter than what's gets played back. Again, it's probably my lack of understanding--sorry for that :/

  • no quantize, but the tightness of the response is controlled by the audio vector size in the setup panel. the patch is pretty huge so the responsiveness of the recorder is not exactly ideal.

    still if you use 64 sample vector you get ~1.5ms discrepancy.
    256 gives ~6ms
    512 ~12ms

    this is because every event that occurs within that 512 sample timeslice is recorded as happening at the end of that slice. of course lowering it will cause increased CPU and potentially dropouts.

    in addition - a lot of the way mlrv works is about practice and some kind of feeling. you need to play with the software for a while before it starts to make sense and feel natural, but when you do it becomes something much more elegant and organic / easy to use.

  • hm, I'm running it at 64 samples, but it often felt more like a 20-50ms delay. I definitely understand the need to practice on the patch, though--so practice I will do :) Thanks much for the help!

  • it might seem counter-intuitive but you could try increasing the buffer if your CPU is at a substantial level when on 64. my reasoning is that at the lower vector size the audio engine takes precedence over timing commands so perhaps the presses are getting deferred due to higher sample playback demands.

    of course there could be a problem in the patch. i've used it without experiencing great delays though that is only one computer's story...

    also -- if you're using max6, try downloading the old max5 and see if it solves the issue. i've always found max5 to be much more responsive when it comes to timing issues in large patches.

  • That's an interesting point--I'll try higher buffers to test. My cpu isn't pushing hard at 64 samples, but I'm open to try anything. I'll also try installing my old Max 5 software--I wonder if that wouldn't help with some of the other Monome problems I've been experiencing, too. Crossing my fingers!

  • Hm. I just installed my Max 5, and copied the xsample stuff into their proper folders. When I open mrlv in Max 5, it gives me an "open" window without asking me what it's looking for. If I select a file or cancel it, it stays frozen on the splash screen. The Max window has about forty lines of "live.line: no such object", and another thirty lines of "fpic doesn't understand "alpha". lol I swear I have had issues at every step of the way with the Monome. sigh.

  • alas - but this is a max problem not a monome problem. sounds like you've installed an old version of max5 (from before they added the max4live objects). you want to get Max 5.0.8 for best performance with mlrv.

  • Ah, see, this is precisely why I couldn't do this on my own. It seems so obvious in hindsight, too :p Anyway, there's also a 5.1.9 version of Max. Is 5.0.8 the update I should download despite the newer one?

    Thanks for your continued help, it's very much appreciated!

  • hrmm.. 5.1.9 should fine.. just checked and i'm running 5.1.8 so that's definitely confirmed (i developed the software in that version, so it's likely to run without a hitch)

  • Hm... so I've installed the Max5.1.9 update, and now I'm getting a constant stream of "/o123: no such object" and "/o124: no such object". I had to close mlrv to stop getting lines and lines of that.

  • that's just a little console reading out OSC messages. nothing to worry about.

  • Question about saving presets: If I, for example, had a couple of different files saved that each contained 7 or 8 pages of presets, is there a way to either combine all the presets into one file or copy just a few presets from one file to another? I feel like MLRV isn't written to work this way, but I thought I'd ask :)

  • i'm afraid there's no easy way of doing this.

    mlrv is designed for a user to have 1 master set from which they build setlists live using the built-in setlist manager. as there's no fx/processing being loaded, you only get slugged with a small amount of load time up front as everything gets dropped into ram, but after that it should run super smoothly with near instant transitions between presets

  • any tips on getting either pattern recorders to work better with slice option when using quantization?
    i've got the slice working good w/ mpattern and non quantized.
    but w/ any type of quantization, i get lots of missed hits w/ either pattern recorders when they come back around.
    tried different vector settings n some other stuff w/o any real luck.