new app : theremin


    theremin for arc2
    hope you like it.


  • Love the visual look. Looking forward to having a play this evening.

  • Gui polish wow! Wish I had an arc. Does anyone have a video?

  • great ui! excited to try it out.

  • looks lovely @zilaihong i'm getting a stackoverflow message when i move any of the encoders on the arc. when i click on the stack overflow message it opens the meng patch and highlights the inlet

    see attached screenshot, no messages in the max window. arc 2 (old button press version), max 6 os x 10.6.8

    any ideas?

  • Stack overflow here too. On OSX 10.7.5 w/ new Arc2 and Max 6.

  • Sorry for the hassles, but I've just tested this patch, works like a charm under Max5 with new arc2.

    I only have Max5 so maybe someone can explain this...?

  • Hmm, outside of debugging (which im not familiar w/ in max) i'm not sure how to help. I do get the following in the max window. It may provide some clues?

    newobj: rcoll: No such object
    newobj: Fill_Menu_From_ScaleMaster: No such object
    newobj: NoteQuantizeSimple_BP: No such object
    newobj: Fill_Menu_From_ScaleMaster: No such object
    binding to port 17812
    binding to port 12995
    serialosc.maxpat: 2013-may-20

  • @emergencyofstate you need to download and put it in the max searchpath, those are all objects from scale master.

  • i wish i could see that in action!
    can anyone upload a video? : )
    i don't have an arc..
    otherwise i would just download it !

  • can't get anything on it to work with my arc.
    looks like a great idea though.

  • I downloaded the filed and tried, everything works. Have you tried with Max5 / Max5 Runtime?
    I took the software image while playing it, it was running obviously. Maybe I really should shoot a video. ;)

  • where in the max search path do i put the scalemaster files? In max 6 i get the 'stack overload' detailed above and max 5 I can't even connect my arc as the 'connect' box doesn't even show up?

  • @zilaihong
    no, i have max 6. i'm not saying you're lying. im saying it's not working for me.

  • anywhere in max search path for example: \Cycling '74\max-externals

    @fluxsta you havne't installed serialosc in your max5 yet.

    Just found out the bug in it, Max6 misses an abstraction called [SimpleFM~]. Fixed and tested in Max6RT 6.1.2

    Sorry for the hassles, you can download the software and try it out now. ;)

  • Erm yes I have. Serialosc is in max 5 and I put the folder in max externals? Still stack error

  • intriguing... really like to give it a whirl, ( no pun intended ) alas, I don't have a screen with enough vertical resolution to select the arc on the GUI ... any thoughts on a workaround.. max 6.1 ( runtime ) os 10.7.5 -thanks be for sharing this patch.. again looks really cool.

  • Fluxta,

    It doesn't sound like you're using the latest version of serialOSC in your max5 configuration. Does it visually match what you're seeing in the screenshot above?

  • @leaflitter: Agreed the initial UI is pretty huge. Just grab the top of the window and scale it vertically down. Then you can drag the whole window up.

    @zilaihong: I re-downloaded Theremin and still get stack overflow errors. Using Max 6.1.0. How did you address the [SimpleFM~] thing?

  • yep i'm still getting them as well and the simplefm~ object is included.

  • Sorry about the hassles.

    @emergencyofstate I decapsulated the [SimpleFM~] thing in the new verion so no more hassles with it I guess.

    I need some help in debugging this regarding the stack overflow, since it works on my computer in both max5 and max6 runtime so I don't know what the problem exactly is.

  • I'd be happy to help debug in Max 6..but I'm not totally sure how about it. Will look into that tonight.

  • hmmm tried it in the max 5 runtime and get the same stackoverflow message from the if object in meng

  • i'm wondering if this has something to do with arc resolution? i'm using the old arc and i'm guessing the if statement in meng is detecting gestures of some sort?

    maybe not - just an idea.

    is everyone who is getting the stack overflow using the old resolution arc?

  • I have a newer arc and am getting the stack overflow error.

  • Not push button arc but still stack overflow.

  • @emergencyofstate

    thanks, of course... resize from the top... good idea.

  • I get stack overflow in Max 6 runtime, but it works fine with Max 5 runtime (& push button Arc 2)
    Sweet App, thanks!