new app: wolves

  • hey board,

    here is a new patch that will make your sounds howl and growl. the top row triggers chimes, made from sinusoidal peaks of the input signal. the next rows will do the same but also transpose each sinusoid by a harmonic interval.

    try some different things. let me know what you think.

    peace,
    dataplexx

  • OK. this is what it looks like when I open it in max 4.6 on my machine (mbp, snow loepard 10.6.2).

    And no button response.

    911 x 729 - 83K
  • haha! i should have mentioned that the app is the _wolves_ file in the directory. this is a subpatch.

    thank you! and please let me know your what your thoughts are !!

  • Ah, yes.

    Interesting.

    eerie, so far.

  • this app sounds incredibly interesting! can't wait to try it...

  • i'ts also good for granularesque things! try setting the decay to something like 80 ms and tapping really fast.

  • is there a help file at all? I can't seem to get any sound. even a step one two three to make it do anything i'm pretty impatiant when it comes to these things.

  • start by turning the thing on

    turn up the volume

    select input (sample or adc)

    fondle your monome.

  • hi, i might be doing something wrong but every sample i load sounds the same played thru wolves, very chimey :)

  • percussive samples aren't very good. also, try playing with the decay time!

    on another note; maybe i should add a "rapid fire" feature for smaller decay sizes.... so holding a button would make for a type of granular representation of the original signal.

    any other thoughts?

  • in action :: http://vimeo.com/9536346 !!

  • i'm sorry i still don't get it. is there a certain sample i need to use like a wav or mp3? i did as the instructions said and i have no howling. poor little wolvies.

  • max doesn't deal with mp3s. so any wav or aiff works.
    you could also switch to the mic input (a.k.a adc) if anything noisy is going on around you.

    in the video i first loaded hans otte's buch der kl

  • sounds like a great application, tonight I try.
    There is a way to send output to ableton live?
    maybe a M4L version?

  • @dataplex

    thanks for posting that video. i haven't had the chance ot try out the app, but now it's at the top of my to do list for after work! i'll let you know if i have any ideas for improving the app (but i love that the buttons seem to stay lit until the note decays completely!)

    btw, I noticed that you had a life app running in the monway video -- what version were you using? is it the chuck version, or a max/msp version? is it outputting midi?

    M

  • hey papertiger

    i'm glad you're into it!!! id love to get pointers from you - i've only had the monome since late january and haven't realized its full potential yet.

    the monway thing was a simple max patch i put together to trigger oscillators. simple ruleset from conways game of life!!

    it doesnt have a nice gui or anything but i'll gladly post it if you are interested...

  • loveing this app dataplex :)

    i'd love to get my hands on your monway patch! post post post!

  • Hey dataplex, I had a look inside your patch. Am I right in thinking that it doesn't make a difference which column on the monome you press, it just uses the [pitch~] info at that point in time? Also your [coll] files can be replicated by something like the patch below which might be useful for you.

    lh


    ----------begin_max5_patcher----------
    398.3ocwU10aCBBEF9Z7WAgjcWWGHZWc2seGKMKnxZoQAihYcqo+2mf5Z6Rq
    ej13tAjW937dd7Ht2AfBU63EH3Kv2f.vdG.vJYD.MiAnT1tnDVgcYHI+SU3V
    zr5oz7cZqbVtPpaU+PI0Ehu4lYHtywMxxxTgLgqsGDoQLioi1HjqeOmGoqMx
    yAUaARnXSG0yz5V8LbUyVDw1PVYiGCNMjRVpMjnWyErDzwnpJ0sgEaDO33XZ
    lcaoLFhgjV05Pn+JiWmCHzu1cHzf1KMvKMcAztnwhwRCx8iFOAWdUVXJMFEN
    buNNHjEFDrz1Rcm6ecb3+OhiGlHbTWcLDZ3MIznLMjm2YlOChBYx0ii.8dag
    mYiPebWedPGKAbue0CZn.J5iKitvnWrrvd6oueWEFjaAK1CDkHj+8uHVKYzO
    mUEpx7n1zt4NK3QaEyKzBISKTxSVSvYqYiHNlamtkIoh3LUE7Zr.b0EeuMTG
    4O.GYbMYxbj2.czzwHxY4+kcj+j6n9Xj2j5H5.bD4FbT0fCN+DlC4PE
    -----------end_max5_patcher-----------

  • @ lh

    each row transposes differently (justly intonated major scale) but yeah! the columns are all the same. i liked the idea of layering in parallel. can be useful for ambient sounds etc...

    as for the coll solution you posted, BRILLIANT! thanks! i actually typed all that information in hand earlier.

  • monway attached.

    200K
  • ew word doc ;)
    thanks

    edit: i was expecting some noise too...

  • @dataplex

    thanks for the response! as for pointers, I can't imagine that I will be able to give any since I'm very new to the monome community and totally inept when it comes to Max. In fact, thank you for posting the monway "patch," but I honestly have no idea what to do with it...do I need full Max in order to pack it up/save it as a patch I can use as an app?!

    thanks again for sharing wolves -- look forward to seeing what else you come up with.

    M

  • Great Video Dataplex. I NEED to test some of your apps now. Keep up the good work.

  • i got to try this app last night, and, sadly, I had the same experience as herrreinholt, but one step worse: everything i used came out sounding rough and non-chimey. =(

    maybe I'm not understanding exactly how to use the app, but any guidance on what kind of source material I should try would be nice.

    thanks!

    M

  • I have a full copy of max. I copied the monway text, opened the patch (or at least what I think is the patch) from the clipboard, but it doesn't do anything for me.

    Dataplex really has a different way of patching than I think many of us are used to around here :)

    Sweet looking patches though.

  • hey guys!
    the patch itself is really straightforward! uhm... does the max window show any error messages? i made it in max v.4, i havent tried it in v.5.

    loading a sample, turning dsp on, switching the loop on (toggle box) and cranking up the volume makes it work for me... everytime. i don't get any error messages either.

    if you guys could tell me what you do, that doesn't seem to work - i could fix it asap. i really want to make something enjoyable for the community.

  • here's a demonstration of live input :: http://vimeo.com/9598686

  • Is there any way we could get a regular .maxpat version of monway?

    I haven't tried opening it in 4.6 I'll try that tonight.

  • it isn't working? the monway patch doesn't have any sound... its just conways game of life on the monome. i simply assigned some sinewaves to each cell in another patch to make it play music!

    edit: you might have to set your prefix manually for it to work.

  • This is monway looks like to me in max 5: It doesn't respond to button presses. Is the prfix klive like the rest?

    I still need to find my serial and unlock max 4.6 before I can save text as a patch. Otherwise it just opens as a text box for me.

    670 x 540 - 64K
  • I've got two errors from max:

    pitch~: no such object
    sfplay~: no open file

    Any idea what's wrong? I can't get any sound of the wolves...

    Edit: I should note that I get these errors in both Max 5 and 4, and that I'm on WinXP. I think WinXP can't open .mxo externals, which is what pitch~ is. I think it needs a .mxe external instead, but I'm not sure how to "convert" it...

  • Great app! the live feed is awesome!
    Are there any updates expected?

  • hey guys

    yeah i obviously need to do some fixes. @agargara - the pitch~ external loads up fine on my mac if its kept in the same directory as the patch itself. if that doesnt work, put it into your max/msp externals folder.

    no open file means you need to load a sample to play with! press the sample button and look for audio files.

  • I haven't played with it yet but I love the name.

  • no response from the monome, no sound either

  • Hey dataplex, thanks for the support. However, as I mentioned before, the problem is that Windows doesn't recognize .mxo externals--it only recognizes .mxe externals. So putting the .mxo file into my max/msp externals folder doesn't really accomplish anything.

  • oh snap! i had no idea....

    did it work for you to move the externals to the max-external folder?

  • saw these errors




    any thoughts?

    614 x 591 - 91K
  • AdamK, that looks like the same error I get, which is because unfortunately Windows uses a different Max external format than Mac. So unless there's a Windows version of pitch~, we're out of luck...

    Dataplex, as I said before that unfortunately has no effect...thanks for the help though! It looks like a cool little app, I like monome apps that have synthesis built in.

  • here you go guys; http://www.maxobjects.com/?v=objects&id_objet=112&requested=pitch~&operateur=AND&id_plateforme=0&id_format=0

    there is a windows version!

    and the matrix background... it should be set automatically but you can select the right pict manually. otherwise your matrix will look like shit.

  • I see no download button :p



    I feel like an old lady using AOL for the first time...


    ::EDIT::


    AHA!


    http://web.media.mit.edu/~tristan/


    man I feel stupid.

  • Hi,

    new to monome and getting to grips with it. Is this app specific to Mac OS, I am running Windows and it ain't doing anything?? there is no file to open in Max when I 'open' file?? any help please.....thanks

  • You can open _wolves_ by running max runtime, then selecting "open" and changing the file selector to "all files".

    I've got as far as loading a sample and getting the lights to do the right thing (same as the video), I've opened the dsp and selected the driver to use, turned it on etc, but I can't get a peep out of it myself.

    You'll need the pitch~ object and fft dll from the authors website too. I put the dll in the main max folder, it must be in the patch so I figured this would be ok. The external (pitch~) goes in the externals folder I think.

    I only get the matrix image error, but the matrix seems to draw ok. I think there's a chance that it's not compatible with max 5.1 runtime perhaps..

    shame, I'd liked to have tried the live input with a mic.

  • for anyone who cares, heres another rendition of the wolves patch!

    http://vimeo.com/19143871

    im posting version2 soon.
    -klive

  • i never did get this to work! ill try the new patch tomorrow, cheers man.

  • Lovely video! Beautiful instrument as well! Live recording is the perfect feature to add. Looking forward to playing with Ver2!

  • @dataplex

    any progress on wolves 2?

    -or-

    can someone please port this to maxforlive? :)

    i tried once and fucked everything up.

  • Ill try and port tomorrow (hopefully) for you man!

  • so... i really took a liking to how this app sounded when dataplex used it with jonsí, but could never find a way to make it work with my workflow... until last night.

    i updated it to the serialosc protocol (zeroconf version for use with pages) and ported it to maxforlive.

    it works wonderfully, and its nice to be able to quickly switch between different samples and live audio. the only glitch i come across is when changing the bpm in live. if i change the bpm in live when an instance of wolves is already on a track, wolves will glitch out and repeatedly trigger all of the buttons of osc data. my current workaround is to just delete that instance and re-add wolves. perhaps you all know whats going on wrong here. it will also make this glitch when trying to drag in new audio samples to live. perhaps lives api is messing with some osc data?

    http://monome.org/docs/app:wolves_m4l

    EDIT: And here is a video of it working

  • Just a bump to see if anyone has tried my port and was able to recreate the glitch that I described above. Any ideas why its doing this?

  • @chrlstnptrck I got the glitching here too, but as I'm no experienced user of m4l I can't suggest anything. Thanks for porting it!