which monomeserial apps do you still use?

  • i'm looking to complete the transition of applications from the old monomeserial protocol to serialosc.

    let me know which apps you still use and i will work through them sequentially. i'll continue to update the list here: http://monome.org/community/discussion/15896/list-of-serialosc.maxpat-updated-apps

    hit me!

  • Since I mentioned it in the smallbatch thread, I use this particular version of mlr, aes edit 0.72, 256version. It's the perfect edit of mlr for me (and no disrespect to your mlrv, I'm sure that's the perfect version of mlr for the majority of people)


    If that can be transitioned to serialosc I'd be very very happy.

  • Not high priority, but I always liked wolves and frost.

    wolves - http://monome.org/docs/app:wolves

    frost - http://monome.org/docs/app:frost

  • updated at the link above


  • i must admit ive not had the gumption to port smplr over :] should get on that at some point, i know, i know :]

  • hey galapagoose,

    an updated version of mlr 2.56+ AND 2.51++ would be so awesome!!!

    (i also have a few nice ideas of mlr modifications, but that's not the question, huh? ;D if there's any max-virtuoso out there who's willing to help me with it, please pm me ;D)

    thank you in advance! : )

  • Hi !

    thank you for the upgrade initiative !
    i still use Ricochet and I'd like to be able to use upsize.


  • hello! i'm sorry for what will turn into a lengthy post, but i've been working on this list for a while now. i promised brian i would get it done- i'm kind of embarrassed for how long it is, so i might feel better if i explain myself. i've been around since 2007 and have kept a folder of my favorite apps since then. most of the apps i have used for one performance project or another. as much of my work is visual, i make heavy use of seemingly random apps, sometimes just for how they look in a certain theatrical context.

    the switch to serialosc, while perhaps for the greater good and needed to move the community forward, has been particularly harsh on my live setup. so much so that i have a separate dedicated laptop only running monomeserial and last gen grids. please let me say though that i appreciate everything everyone has done for this community and my work has certainly been built upon the generosity of others to freely share what they have created. what i mean is that i do not feel entitled to these gifts, but rather that i would like to point out how much they mean to me!

    most of the apps i list here fall under the heading of your original post, and simply need to be updated to the new protocol if possible. since i have been compiling, editing, and otherwise testing out my work apps, i found a few other issues along the way and decided to list them here as well just in case they are easy fixes. for sure lots of it has to do with my own (lack of) knowledge of how things work and the setup i'm on. i am using a macbook air, osx 10.7.5 and have done a clean install of the latest monome protocol as listed on the website. i'm not set up to have external apps in pages, so haven't gone down that particular serialosc route yet.

    i face a small variety of connectivity issues- from straightforward old monomeserial apps, to serialosc apps which won't connect (probably because they have used an older version or the signal pathways of stuff inside my machine isn't aligned?), to serialosc apps which will connect but won't or can't update the prefix. there were many apps i still use in my work which i can't find on the website anymore anywhere. i'm not sure the best way to go about this… if i should try to attach the patches here, or if there's a more clever way to get them updated and available again? perhaps its best if we privately email each other, and then somehow they can be made public? but i'll put the whole list here publicly anyway, just in case its relevant to the community somehow.

  • the list:

    - bit rain, will not open with or without the serialosc max patch in its folder, this patch doesn't seem to be on the site anymore

    - bloon, might just need serialosc'd http://monome.org/docs/app:bloon

    - bounds, M4L, i can't get it to connect in live. that being said, i can't get most M4L apps to connect in live. i'm using live version 9.1. this app also doesn't seem to be on the site.

    - inkblot, this app needs serial'd but also when i monomebridge it i can't get any sound out of it. so hoping if it just natively connects it will be fine. http://monome.org/docs/app:inkblot

    - release, this is a chuck patch, i can't get anything chuck running on my machine now with serialosc… oh well, just thought i would throw this one out there in case anyone has a working version now. though it also seems to have disappeared from the site.

    - pitches, another M4L which won't connect inside ableton. not here on the site.

    - pluck, not sure if this was ever fully developed as a patch, but it was some examples of nice max coding and features. can't connect to osc. not on the site.

    - polygome, the new version connects just fine to serialosc… except almost everything with tilt that worked in monomeserial now doesn't work for me in serialosc. for example, the tilt in polygome no longer works. any ideas? http://monome.org/docs/app:polygome

    - press cafe, same as polygome, no tilt. http://monome.org/docs/app:press_cafe

    - straw, i have a serialosc version of straw that i can connect to but its not available on the documents page, as well the prefix cannot be updated in the app or on connection which means that when it connects it still won't function or then you break out monomeserialbridge every time to change/guess the correct prefix, also no tilt working here either http://monome.org/docs/app:straw

    - xor, seems to connect in serialosc fine, but can't get any sound out of it no matter what. was working well before the new serialosc protocol. not sure how that could have affected the sound output. again, probably something going on inside my setup here, but no idea what! http://monome.org/docs/app:xor

    - flin M4L, how to change cable orientation so i can use my 128 vertically? http://monome.org/docs/app:flin_m4l_beta

    - fourby, won't connect at all. another M4L, its probably all the same thing i'm just not understanding. http://monome.org/docs/app:newapp?s[]=fourby

    - spectral display, can't get it going in ableton. its M4L and can be found as its own download on this page here http://monome.org/docs/app:stretta_monome_suite

    - trails, can connect but can't change the prefix once connected and even trying to change the prefix manually in monomeserialbridge doesn't work on this one. same for the M4L version http://monome.org/docs/app:trails

    - 9gon_monome_video.maxpat, won't connect via serialosc. not here on the website.

    - arpeggiator, one of the coolest UI's ever, but only monomeserial. http://monome.org/docs/app:arpeggiator

    - boiing, the version available for download will not connect directly with my setup. have to remove the serialosc.maxpat from the folder first. a little trick brian showed me, but not sure if others know to try that or not for sure http://monome.org/docs/app:booing

    - corners varibright, there is no led feedback once connected. i think it worked when i first downloaded it, but its not going now no matter how hard i try. i couldn't find this version anywhere here anymore either.

    - flin, there is no version of flin for a 64 or 40h here anymore. latest serialosc version you can only have grids of 16 in length, though you can specify widths of 8 or 16. i have a version of flin (2.0) which is specifically for a 8x8 grid but its monomeserial of course. flin is my absolute favorite app, the reason i bought first the 40hSE and then a 256!!

    - kradle, won't connect, needs serialos'd http://monome.org/docs/app:kradle

    - titly magee, needs updating for connectivity, and then i'm guessing also for tilt! though i can't tell because it won't connect for now. i mean, i tried with monomeserialbridge and the tilt certainly didn't work then. i'm most interested in the midi press version also available on this page here http://monome.org/docs/app:tiltymagee

    - mirrome, needs updated to connect http://monome.org/docs/app:mirrome

    - munome_life, needs updated to connect but not here on the site anymore

    - nerd scroll, the version available for download in the docs doesn't connect without removing the serialosc.maxpat from the folder http://monome.org/docs/app:nerd scroll

    - pepito, needs updating http://monome.org/docs/app:pepito

    - plinkonome, needs updating http://monome.org/docs/app:plinkonome

    - portamentos, has serialosc but the wrong kind? won't connect to my setup http://monome.org/docs/app:portamentos

    - quadrants, i know this will probably never happen in a million years, and i know there is pages, but quadrants was one of the most useful, straightforward, and favorite apps of all time! i should just let the dream go, but if quadrants could be updated to serialosc… i could play so many of my old shows without having to carry around 2 laptops and 2 sets of grids!! (i know the old grids will connect to serialosc, and i know it sounds really silly but i have matching led colors for different projects, hence sometimes needing to carry different grids since the new grids won't work without serialosc) http://monome.org/docs/app:quadrants

    - residue, needs updating http://monome.org/docs/app:residue

    - ricochet, needs updating to serialosc but isn't online here that i could find

    - shoal, needs updating http://monome.org/docs/app:shoal

    - spectronome, needs updating http://monome.org/docs/app:spectronome

    - tetris (midi version), needs updating http://monome.org/docs/app:tetris

  • how did i never know about inkblot? amazing list btw

  • yes, and wow, arp! thx.

  • Thanks so much for this great service!

  • woah jay! that's a bigggggg list. i appreciate you putting it together and i'll do my best to work throughout (although i doubt i'll hit it all in a few days >> still working on the smallbatch router!).

    - please post the patches you can't find online to this post (for posterity sake).
    - i'm not going to tackle m4l apps at the moment >> rather working on a new suite of unified m4l apps with @myr

    thanks everyone else for your suggestions — i guess the hard part of such a big list is prioritising the list. please alert me if things are used ALL the time, rather than just once in a while.

  • yeah jay!! thank you! we are going to fix up this boat.

  • Thanks a lot! I would definitely like to see molar and daemon updated. Would also like to see soyuz updated but its not as urgent. Also, most of stretta's apps usually seem to be missing like cygnet which I would like to see come back. Thanks again :)

  • unforunately molar (and other C apps) are out of my realm of knowledge, but should have all of stretta's apps up to the newest date. could anyone provide a list of stretta's apps that haven't been updated (with links to download the files). i know a lot of his stuff was removed a while back, so keen to get a good wrap up of what's going on.

  • i have a backup of most, close to all of the older apps on monomeserial. If theres any dead link on any of those app anyone needing for the conversion, do post here. I will upload all those which i kept as back up

  • @galapagoose - no stress from my side! i totally understand its a stupid lot of work to do, i just wanted to finish the list thoroughly. everything else i found on the currently uploaded list of apps is working on my system (as far as i have been able to test… not all grid sizes have been tried, and i only have an arc2…).

    i will upload the apps here in this thread which i mentioned on my list. while the list is actually all of the apps that i use in my performances (i mean, plus all the ones that already work!), i totally understand the need to prioritize. for me the top 3 would be:

    - bloon
    - inkblot
    - plinkonome

    and of course before any of that would be quadrants but i have a feeling that won't be possible?

    @tehn- while cross referencing my list which was started this summer, i was able to cut it almost in half with current additions and fixes! so the boat is totally holding water!!!

  • amino
    bit rain
    corners (varibright)
    flin (2.0)

  • munomelife was too large to attach here even zipped


    sorry i'm kind of disorganized today, bad hotel internet and not enough time to sort through all my notes. hopefully i'll do a final sweep of everything and see if anything is missing...

  • Here is a working serial osc version of bounce for m4l.
    I added also an extra feature, each ball can have a separate speed.
    Just set it in the top menu of the edit area of the ball.

    please tell me if it works, ill then ad it to the apps site

  • here's an updated version of trails. i couldn't get the record / playback to work on my system. am i missing something?? i tried to look at the recording code but it's super wacky and thought someone might have some insight?

    i've uploaded a new version of inkblot w/ switch for variable brightness (it's pretty!) but it's a crazy cpu hog.

    also soyuz updated.

  • blinken_park and skr are two that i'd really like to see converted.

  • because these versions are hard to find on the forum i thought it would be better to post them here again ^___^
    happy sunday and thank you!!

  • @galapagoose- for some reason the new inkblot won't start on my machine… the app opens and i can connect now with serialosc just fine. i can push the speaker button but then nothing happens. when i open the monomeserial version at the same time and start the dsp running there then both apps turn on and run… including led feedback on the physical grid but no note entry from there or from the serialosc version via the mouse. only note entry via mouse on the monomeserial version.

    also, i experience the same thing as you for trails…

    thanks again and again for all these edits!!!

  • i set the whole thing up to have dynamic re-sizing which, if it's not working, is the only reason i could think for it not responding to the mouse.

    which device are you using with it? if it's an older device, can you try a new one to determine if older devices don't successfully send /sys/size messages.

    additionally, which version of serialosc are you using?

  • @newmodernscience
    those 2 are now updated to the full new spec w/ all the fancy 'redraw' on focus and suchwhat...

  • @jay - could you upload 'pepito' as the link is broken on the wiki? thanks!

  • @galapagoose- can you email me privately? pepito is too large to attach here, even zipped…

    i'm at instantjuggler (at) gmail dot com

    i tried inkblot with the 2013 64 and gs64 (2001), they're the only grids i have with me right now. the version of serialosc i'm using is whatever is listed/linked in the current setup documents on the site… i wiped out everything on my computer and did a clean install from the most current instructions in order to get a sense of what's working/updated.

  • @Galapagoose can you please convert those dual monome MLR's birdster re-posted?

  • @project_one & birdster

    do you guys really need both? what is it that makes them individually useful? couldn't we just roll it into a single version that works?

    i just had a look inside the patches and if what you're missing is the audio input section it's all still hooked up in 2.56, but i just hid it from view because alfred never uses it and he wanted his version cleaned up.

    is there anything else that differentiates them?

  • @galapagoose ...nah, actually you're right....!

    i use version 2.56 for live/performance-fun (because it is tidied up!!) and 2.51+ for working/producing-fun.. a version of 2.56 with an extra window, which can be closed (like the tilt [fx] section) for the audio input section would be awesome! or is it already possible to unhide the audio input section from your cleaned version?? if yes, how? :D

    to make it short: if i had to choose between both versions i'd choose: mlr 2.56 !!!

  • @galapagoose Thanks again for the updates :) Having some problems with soyuz though :/ the app seems to be working fine but when I go to output the midi to ableton it doesn't work. Other max based apps work fine when I hook them up and so does pages so I don't think I'm setting up anything wrong, unless there is something I don't understand with the app. Any ideas?

  • @billyL
    to be honest - i've just been plowing through the conversion process & making sure the button/led feedback is working properly. embarrassingly i haven't had much time to make anything practical as a result.. i'll have a look, but i'm not really sure what to say..

  • @galapagoose
    Alright thanks :) I understand. I know its a lot of work and stuff to look through and we all appreciate what your doing :) I wish I could help but I don't really have the knowledge to unfortunately :/ I know that we would all like to have these apps out and working on serialosc but I would recommend taking your time man. Its a lot of work to translate all of these and also testing them, especially for one person. We've all survived so far using monomeserial apps, so I'm sure we can wait just a little longer because we know they're in the process of getting updated now (I may just be speaking for myself i don't know but I think you should try to pace yourself more). I'm not trying to discourage you from working on them, just trying to relieve some of the panic of trying to get them all done. Thanks again though, I appreciate it, hope it all goes well :)

  • ok - i've checked soyuz and it does indeed work but you have to change some settings in 'note setup' in the bottom left of screen. make sure you've selected the appropriate 'midi out' port to send to your DAW, and set the velocity & 'dur ms' to non-zero values in order to make it send midi.

    more generally though - i'm not really setting out to fix a whole bunch of broken apps. that's specifically why i asked for apps that people actually use presently (ie. presumed to be working). i'm not panicked about getting them done, but it's not exactly the most exhilarating job, so i'm just trying to get it done as quickly as possible. my testing is limited to 'are the buttons & lights working properly' because that's the only part of the patches i'm changing.

    on a more positive note. i've finished 3/4 of all the apps people have requested so far!

  • @galapagoose Thanks, I appreciate it :)

  • hi !
    i'd really like to be able to use Upsize with mlrv

  • @galapagoose
    If it takes aobut 10 minutes to swap a monomeserial patch to support serialosc (I think that's what you said in another thread) can you give me some quick guidelines on how to do it? I just started learning patching in max and instead of asking you to update all the different varieties of mlr that I'm experimenting with, maybe I can do it myself, and also help you take care of the request list? I'm opening up patches to learn and might as well try updating them while I'm in there. It would be a good exercise for me as well.

  • @galapagoose @dr.tung

    I feel the same as dr.tung. Very specific, concise instructions on how to convert a monomeserial patch to serialosc would be really helpful. I have looked on the forum and still have had no luck. I'm new to max and trying to learn more. This would be good practice as well as help take all the brunt off of you galapagoose. Either way thanks for all your hard work, what you are doing is super cool for the community.

  • i've uploaded a version of mlr2.56 now called mlr2.56AUX that uses serialosc. has updated compatibility for new edition monomes and deprecates the need for calibrating the tilt sensor (dynamically adjusts after connection).

    includes the audio recorder that was lost in the previous 2.56 version.
    let me know if you have any issues as i haven't tested it super extensively.

    @Pabs & dr.
    i'll put together a little how-to, but there is already an example in the monome_base collection. it doesn't go super deep into the finer details of doing a 'good job' of the update but gives a start

  • @galapagoose

    awesome! no need for the rowfix button anymore? deprecated as well? mlr_cyst could use updating too if you're up for it.

    edit-…so i spotted the row fix button, i thought it was gone but its just in a different spot.

  • @galapagoose
    first of all thank you very much!!

    but i believe i found something that's not working properly: the tilt/calibration function..
    after a few tries it still looks this way when i press the effect button:

    hope you know what i mean : ) i'm not good in describing such problems....

    happy holidays y'all!

  • rowfix should still be there (sorry i might have moved it to the top-right?)

    perhaps mlr_cyst would be a good thing for someone else to attempt. i've got to do the write-up on how that works.

    that looks like the scaling parameters aren't working correctly. is that a greyscale in the video? i'll test on my 128 here and see if i have any more luck. can you try picking up the device and rotating it both axes to see if that calms it down?

    EDIT: after checking on my gs128 i think this doesn't look totally wrong... the zipping of lights is the 'ball' moving from the old position to the new one (ie. from the LPF location to the Delay location). if it's doing that when you press the same button repeatedly then that is a problem. probably because the flat-on-the-table output is not quite in the middle of the output range.

    the way the calibration works is that it has default values for typical tilt ranges of devices. older devices (like the greyscale) are detected and set their scaling parameters to be more sensitive to changes than newer devices w/ higher resolution tilt sensors. if for some reason your device is putting out a larger range of values than is set by default, tilting it in that direction will set a new maximum/minimum if it surpasses that of the current setting (like how the old calibrate function would work, but always on). if this is a problem for you, i'd suggest connecting to the device with the serialosc patch then tilting your device in every direction quickly before starting to use the app.

  • just found versions of bitrain and mlr_cyst on my hd which I've updated a while ago.
    hope my conversions are ok and complete....just let me know.....
    - bitrain (updated)
    - mlr_cyst (updated to serialosc)

  • thanks for the response, @galapagoose !

    -yeah, it's a greyscale ^_^
    -yeah, it calms down while rotating, but it's a bit annoying when activating the filter it starts from a completely new point..!
    -yeah, it's doing that when i press the same button repeatedly!!
    -it still happens after connecting and tilting it before using : (

  • @ red

    tried out mlr_cyst...works great! Was it hard to do? I would like to try it with my version of cyst and have yours as a reference that was done correctly so I learn how.

  • @PabsArg
    i think if @galapagoose is going to write a little how-to on this, that'll definitely be the best reference and much better than my patching, but i could do a little quickstart if that helps!?

  • @PabsArg
    just made a very quick and dirty guide.....
    hope this helps

  • @red
    Hey great! Let me know where i can check the guide out and thanks brother