"this" scene in aleph140115.zip and other issues

  • Its been a week since receiving aleph, have went through different version of bees and using 3 different SD cards(including the shipped one) to store the required files.

    As there was quite a number of times where aleph hanged when trying to load up "this" scene with different version of bees or when using a grid, i had to unplug the power cord quite a number of times to shut down the whole unit(on/off switch doesnt work when aleph hanged). Iam wondering if the unit be robust enough to withstand frequent happenings of having to power off and on again

    2nd thing is that with different versions of bees right now, theres quite a high rate on flashing the unit with it. Will there be any issues on the frequent flashing?

    3rd, After going through some of the newer version of bees(with all 3 different sd cards), i decided to back track and use only the 140115.zip version. I had all the folders with its content(app, data, mod) copied to all 3 different sd cards(each sd card was reformated as fat/fat32 before copying the files).
    Bees version 0.2.0 was flashed into aleph, load up properly and droning sound can be heard. But the problem comes when i tried to load "this" scene, the whole unit will hang and having to unplug the power cord to shut it down.
    I have tried loading "this" scene using 3 different sd cards with same content copied from the 140115.zip files and all 3 sd cards encounter same issue of hanging aleph when trying to recall "this" scene.

    I have decided to take a break now and see if theres solution on the above and also to rest aleph for a while from the constant powering up/down/flashing moments.

  • hello-- there's no issue with frequent flashing, and i trust you'll need not do so frequently in the future. lots of things are being fixed and added at the moment. also pulling the power on crash is not a problem-- the power switch is soft, so a hard crash will disable the switch.

    when loading "this" was there a grid device plugged in? try it without. it sounds like it's not an sd problem.

  • Thanks tehn, great to hear that.

    Nope, there wasnt any grid connected when it happen. I temporary stop testing with the grid after first few time of playing with aleph as i noticed it tend to hang after numerous press of the grid, usually when pressing it in fast and numberous time.

    i have done more troubleshooting, with bees 0.2.0, seem like the only "this" scene that was able to load up was from the original shipped sd card. Have copied it to the another 2 sd cards and confirmed it

    Next, i update/flash bees 0.3.2 to aleph with no issues. I remember reading in one of the aleph thread that there was "an error parsing hex record" when flashing new version of bees. One thing which i came across while flashing different version of bees, the error parsing happens if the bees file that i used for flashing, is from saving the individual hex file from raw here, https://github.com/tehn/aleph/tree/master/release

    If i were to download the whole repository as zip(on aleph main github page) and copy the latest bees file from the release folder into the sd card, the flashing of aleph will be without the error parsing comment.

    Next, with bees 0.3.2, unversioned waves and lines(from latest github release) and running on the aleph starting without any scene(holding key 2 on powering up), a constant drone was heard, as normal.

    I tried loading "this" scene(copied from shipped sd card) and it just hanged on reading scene on card. Had to unplug the power cord. Have tried with "this" scene from the 140115.zip folder as well from heres, http://monome.org/docs/aleph:bees:sharing:this, across 3 different cards. Still having the hanged thingy when reading scene from the sd card.

    Am wondering if i should skipped the scene part and do other testing/tutorial. It did kinda irked me that theres problem trying to go through tutorial 0 when scene cant load up.

  • "this" scene isn't compatible with 0.3.2, it broke on transition to 3. we're working on a scene refactoring tool to preserve compatibility. at this point i'd suggest continuing on to tutorials with the newest version of bees, and we'll have more example scenes ready soon. i apologize for the trouble.

  • good to confirm the breaking. Was going round thinking that theres some wrong steps on my side.

    Great, will move on to other tutorials then. Thanks tehn!