app : The Party Van

  • Loading it up directly into max (no gridlock or launchpad) with all files crashes the same. If I pull ccccombine both tcg modules work. If I pull the tcg files, cccombine works.

    I have been able to repeat the same behaviour with Gridlock and the Launchpad.

  • I tried the custom wtpa custom file : it works very well! thank you so much !

    EDIT : THE NOTE 61 DOESN'T WORK

    I tried to use midi-learn with my ipad (and ipad dock with midi connection), I'm not able to use midi learn.Maybe I don't understand how it works. It's odd because the midi thing with the wtpa custom is not a problem

  • It should work like this.

    Click MIDI learn, then hover over the thing you want to control AND tweak it with the thing you want to control it with. Those two things should now be paired.

  • It works! The pattern mode remembers the changes too!

    Any convenient way to set that up for the controls that don't have a hoverable spot on the GUI? Specifically I want to control the volumes for each WTPA module, and each MLR channel.

    Also - is the gain and gain volume linked? It would be great if you could turn up the gain for distortion but not have it get crazy loud. Likewise - does the bit module have a master volume?

  • There's already MIDI control over MLR volumes (see the CC list above), but there's no control over wtpa volume at all at the moment (hidden or otherwise).

  • I see "108 - wtpa1 volume; 109 - wtpa2 volume" in your list above. No?

  • Oops, so it is! That must've been a request a while back then.

  • this week end I will try to use gridlock with lemur on ipad to be free of my monome.
    do youthink that it could work?

    they say that they try with all the apps available the 22 january 2014 and it works so it should work with party van http://www.sigabort.co/m4l_lp.html
    http://forum.liine.net/viewtopic.php?f=26&t=3415

  • @starfucker .. I personally tested all the apps for sigabort ..and all the apps works except markeats sequencer ( is not a max app) and ml(ive)r ,it need a gridlock patch that we still didnt post anywhere ...the only one that i still didnt tried is party van ... I will do it this afternoon and i will report to sigabort if there is something to change... There is a new gridlock beta version on forum.sigabort.co that have new features for the lemur layout

  • I'm verrryyy interested in your test! Please let me know if all is working good with party van! Use the ipad instead of monome could REALLY improve my rig! I'm very excited by this! It's an old project that could become work!

  • After all the "fun" I've been having with Gridlock, my Lauchpad, and tpv this week I'm also looking forward to your results!

    (to be fair, I have been having a ton of actual fun with it too!)

  • I played a little yesterday with party van...and i am able to connect it ( i used party van version 1 m using gridlock vserial connection) ...and i didnt saw any problems with it for now...i never tried to play with tpv then i dont really know if there is something wrong...Starfucker know it better then me and he will report us what is wrong..if you use gridlock with lemur..you can add a page and create new knobs, faders & buttons to map what you want in tpv ( using a new osc port connection between lemur & tpv) ...and i think that can be something cool to share..i did the same to use gridlock with livecontrol 2

  • hey all... trying to test this but not having much luck...
    i see alot of errors such as the following - can anyone suggest any workarounds?
    also, on windows 7, whenever I turn on tpv, the CPU core running MAX just sits spinning away but nothing seems to be happening.
    just trying to get the test tone working currently.

    i have installed all the windows externals from the tpv09 zip

    thx

    585 x 917 - 156K
  • Use the beta 1.0 version. The latest version is version 'm':

    http://rodrigoconstanzo.com/party/party1.0m.zip

  • ah, cool, thx

  • I have a problem with gridlock but I can't understand how to solve that

    1024 x 768 - 142K
  • @starfucker i added u on skype..i will guide you to make it work..for what i can see in the pic..u dont have selected the lemur controller.. U have first enable it on the osc menu..then choose it ...but i think that here is not the place to talk about how to set up gridlock..this is the party van page :)

    And rodrigo said to download the last party van m ....u are using i version...http://rodrigoconstanzo.com/party/party1.0m.zip

  • hi peeps - can you keep Gridlock related setup issues to the gridlock forum pls - don't want to fill up tpv related post with gridlock config issues.. thx

  • Ok, some very promising/exciting news. sigabort has found a problem that has been plaguing tpv for a bit (the add/remove combine file thing).

    Turns out there is a function called 'combine' in Max and opening tpv would sometimes (depending on the order of things) load the wrong/right version.

    Here is beta 'n' that should fix all of those problems (and hopefully fix gridlock too, to be seen...)

    http://www.rodrigoconstanzo.com/party/party1.0n.zip

  • I opened the newest version and hitting record in TCG still crashed Max...

    Going to try other options and repeat. Will report!

  • :(

    That bug will be the end of me.... I literally have no idea why that's happening.

  • Tried the full load straight into MAX twice and both times crashed. As James suggested before, removing either CCC or TCG and opening - whichever module is present works. Then closing TPV without closing MAX and reopening the entire patch = both CCC and TCG work without crash. Hope this helps!

  • To be clear, which individual files are you removing in doing this? (and is still the case with the latest beta?)

  • Yes, I downloaded the new version (N) yesterday. I have been pulling cccombine.mapxat, tcg.maxpat, and tcg_abs.maxpat.

  • Hmm. I have no idea why that's happening. The type of bug sigabort found wouldn't happen with those peculiar file names, but I'll try seeing if I can try different stuff.

  • As an update to the other problem I was having with tpv lagging really hard and making me fiddle with a bunch of the audio settings in order to get sound - if I open the audio status.maxpat in max and turn it on before I open tpv it works fine.

    I'm not sure that anyone else was having that issue, but wanted to share in case it helps!

  • Rodrigo, I'm having a problem with the MIDI-assigns file in the last couple versions of the beta. The midi learn function is working, and it creates the file in the folder, but when I close the app, the next time I fire it up, the MIDI-assigns file doesn't load and I have to remap.

  • Ok, try replacing the main file with this one and seeing if it works. (You'll have to remap stuff first). It looks like it wasn't loading OR writing the files. I never use MIDI learn so I hadn't noticed.

  • Yes, that does it. Thanks!

  • Ok, here's a new beta version. This should work with Gridlock (thanks go sigabort for finding the issue!) and the MIDI-learn stuff all works again.

    I think this might be break some stuff for people who were triggering WTPA1 slices with MIDI previously (starfucker?). All of that stuff had to get moved to channel2 (same MIDI numbers though).

    http://rodrigoconstanzo.com/party/party1.0o.zip

  • Dreams do come true! Both problems fixed for me -- Cheers and thanks to you both for your effort!

    Rodrigo - Is the list of MIDI assigns from the last page complete? I'd love to see a full list if there is one -- though maybe you're including it in the user manual update?

  • That list is almost complete. The WTPA1 slices are:

    (Channel 2)
    Midi notes 60-67 = wtpa1 slices 1-8

  • Sorry to be asking the same dumb questions over and over. I'm trying to re setup monome stuff on my system again. Just downloaded the latest beta, where do i put the allen harker externals and sigmund? Thanks!

  • No problem. It should be in: /Max 6.1/Cycling '74/msp-externals/

  • (that's for mac. I don't know if it's different from PC)

  • Thanks! It seems to be working fine.

  • Oh well, spoke too soon. It doesn't like to output sound through my interface (duet firewire). I'm pretty sure it's a max/apple thing, but i think the last version of TPV might have worked for me.
    I can just never get anything monome related to consistantly work for me. Oye. At this point (Mavricks, Max6.1, Duet) I'm not able to run any monome stuff at all.

  • Hmm, nothing has changed that would effect that stuff.

  • Blungo -- I was having intermittent problems with TPV passing audio using my Presonus Firebox. I was having to change dsp settings around a bunch at random in order to "jumpstart" it, but that didn't work every time.

    I have since solved that issue in my setup by opening Max - then opening the Audiostatus.maxpat (from cycling74 > max 6.1 > cycling74 > interfaces) and turning on the audio driver BEFORE loading TPV. Doing that I have had no more problems!

    Hopefully that will also work for you!

  • Thankyou! That sounds like it might work!

  • Yes, yes! It works! Both input and output are working with TPV. I suspect this was my main problem all along.

    Thankyou!

  • I've been so discuraged lately, every new OS seems to break my monome stuff, so happy to have my favorite app working! Cheers!

  • I seem to have run across another bug. Channel of TPV works fine, and i seem to be able to record into looper 2, but when i hit playback on 2, all my playback dies.
    Has anyone else experienced this?

    EDIT: No, i was wrong again. All the playback of TPV seems to have stopped again. Same old problem. I'll try bringing home my RME UFX and see if it works with that. I don't think it's just an Apogee issue as i think i had the same prob with a focusrite interface i had. It must be something about my system. Mavericks possibly? But i had the prob before mavericks too.

  • Weird. I'm on mavericks on all my machines and it plays nice with everything. I also only use MOTU interfaces. Is OS/Max all up to date and all that?

  • I've had consistent audio interface issues on os x which are temporarily fixed by restarting the audio drivers (activity monitor, force quit coreaudiod). I'm in a season of it working at the moment but it's never totally predictable. I detailed them in a support article linked below if you want the gory detail. Blungo - is it an interface issue?

    https://discussions.apple.com/thread/5641340

  • Everything up to date. I used to think it was an interface issue, but my interface works fine with various DAWs. Also had the same problem with a different interface.

    I'll try the forcequit coreaudio thing, thanks!

  • Today it's working for the moment. I guess i just have to resign myself to the fact that monome stuff on my current system is going to be intermittent, unreliable and janky. I guess i should just enjoy it while/when i can...

  • Ok, here is an updated version trying to solve the oh so mysterious chocolate/combine crashes. I'm trying something altogether new by loading those parts of the patch AFTER everything else. What you see on screen is an illusion at the start and then it loads the appropriate files. Hopefully this works....

    Those of you that have had crashing problems, can you please test this version and let me know if it still crashes for you. (replace all files with this as many files have changed and some new ones added for this to work)

    http://www.rodrigoconstanzo.com/party/party1.0p.zip

  • (just updated the file above as there was a small bug in it, so redownload if you downloaded it immediately when I posted it)