[new patch] quadrants2 for serialosc

  • hello!

    i've been working on a new dynamic router / splitter / spanner for multiple monome grids, and realised along the way that it would be easy to make a simpler version that replicates the behaviour of the old 'quadrants' patch that a lot of people used back in the (monomeserial) day.

    the aim of is to allow a 256 (or 128) to be split up to address a number of apps on the grid simultaneously. press the

    PLEASE NOTE: an experimental version of serialosc.maxpat is included and required for use. please place it in your /max/patches folder (overwrite the current version). no max externals are required for use.

    i've tried to keep it as simple as possible, but there may still be a few bugs hiding in the code. at present it does not support variable brightness, but that will come shortly as i learn more about js and how to handle loooong lists without having to refer to each element directly.

    if you download, make sure you report your experience back here so i can improve it!

  • Galapagoose, this is great! Will definitely try this soon. Can you elaborate if quadrants will work together with the arc at some point? So that each quadrant will have its own grid/arc combination? That'd be awesome.

  • Dude! Looking good. Shame on night shift. Looking forward to trying when home!! Will we need to swop back to the other serialosc.maxpat if not using this quadrants patch? @galapagoose

  • @myecholalia
    this is very much a 'side project' and not the main event in terms of the routing app i'm building. i'm a little at a loss as to how an arc would fit into this arrangement though? quadrants is for taking a large monome and splitting it into smaller virtual ones. i guess the corollary would be having an arc4 and splitting it into 2 arc2s. is that something that people would find useful?

    more likely i'll invest some time into adding arc-based app-switching support to the smallbatch router. let me know your thoughts on how that could work at this thread: http://monome.org/community/discussion/comment/199449

    the serialosc.maxpat is fully backward compatible. this will become the new official version after a few more people give me positive responses about it working well.

  • @galapagoose

    no go my end mate, replaced the serialosc.maxpat and overwrote the previous one in the max folder. When i click load to open a patch all the patches are greyed out and i click and it won't access them?

    max runtime 6.1.4mac osx

  • got it, you don't load from the patch you load from max direct. I split my grid into 2 x 128 but in the drop down i can only select one patch? i have tried to open this up a number of ways but still cannot have two patches going?

    see attachedimage

  • woah!! sorry about size

  • pretty hit and miss here, jams, freezes, will only load one app at a time, polygome is particularly troublesome.

    Some of the max window readout is as follows:
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    bad arguments for message "symbol"
    binding to port 21657
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1

    xgroove~ - can't find buffer 0file
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    xgroove~ - can't find buffer 0file
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    xgroove~ - can't find buffer 0file
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0
    xgroove~ - can't find buffer 0file
    obex_container: sOSC /manager/grid/led/set 1 0 1
    xgroove~ - can't find buffer 0file
    obex_container: sOSC /manager/grid/led/set 1 0 0
    obex_container: sOSC /manager/grid/led/set 1 0 1
    obex_container: sOSC /manager/grid/led/set 1 0 0

  • no joy with mlrv loading? apps seem to want to only load in the top half majority of the time?

  • Progress but I have found that I need to be very systematic in how I open things in what order? Is this right? Polygome and press cafe don't work with it. List isn't populated

  • woah -- this all looks pretty crazy to me?! on my system i can open / close / reload patches in any order. when a patch closes the name 'greys' in quadrants. when you reopen the patch it should alert quadrants an turn back to black & start communicating again.

    i'm not sure what you mean by "you don't load from the patch you load from max direct", as for me i can load patches in any way i want and they work.

    i just checked out that version of polygome you're using and i realise that when i updated the serialosc handling i only did it for the 64 version. as such the 128 version you're using probably won't communicate properly as it thinks it's prefix is '9001' rather than '/gome'. i have a feeling that's what the 'obex_container' error messages are about.

    i'll be sure to fix up that version of polygome sooner rather than later, but perhaps you could try with other apps from here: http://monome.org/community/discussion/15896/list-of-serialosc.maxpat-updated-apps

    if you're still having issues, can you post a screenshot of the max window after loading quadrants (but no other patches)?

  • Roger that will have a play today. Sorry I meant that I was clicking 'load' within quadrants not realising that was reloading any saved presets. And I wasn't open patches by clicking 'open' via the max menu and that would be why titles of max patches were greyed out, as the quadrants patch was looking for a saves preset. Sorry does that make sense?

    At least the polygome question has been answered as it does default to 9001.
    Will report back

  • hahah -- oh i see. yes, the 'load' and 'save' in quadrants is for the setup of quadrants, not a way to load your max patches. load them from finder or the max menu. i should make that clearer in the patch (perhaps this is a common mistake with max patches?)

    just played with mlrv and quadrants wouldn't grab it straight away for some reason. eventually it grabbed on though and everything worked fine. this is in max6 mind you, and i'm quite adamant about mlrv working best in max5 >> on my machine if i open mlrv in max6 the whole computer gets choppy and feels like i'm using windows. something about the 64bit audio engine i assume.

    EDIT: just uploaded a fixed version of polygome 128 & 256 sizes

  • Schoolboy error on my part mate :-) thanks for the speedy upload! Will be updating all my patches via the link you posted when home. I ran into my pages issues when I had max 5 and 6 both installed. I will reinstall though as mlrv is my most used patch. Will see how stable it is later.
    Thanks @galapagoose

  • @galapagoose

    Updated all apps, quadrants is seamless so far mate! thanks, an awesome job sir. One question did you test Soyuz at all, or do you have knowledge of how to access the dac settings? I am unable to get sound. No drama if you can't.

    Thanks mate, your ongoing work is applauded. Enjoy warm xmas (if your in the country), off to the beach myself.


  • re: arc,

    There was talk early on about not just dividing an arc 4 into two arc 2s, but dividing both into arc 1s for a generation of single-knob apps that never really materialized. This is probably less useful on the new (buttonless) hardware, but it's been a long time dream on the first gen.

  • @galapagoose,

    trent, first of all, just a long overdue note of appreciation for porting / developing this splitter, spanner app thing. Definitely reconsidering selling the 128…

    mostly as I'd really like to get tintinabulome paired with rodrigo's party van app as a live setup… ( they're the two apps I seem to be able to coax the most pleasing fun fluid improvised sound forms from )

    is there any way to do this, ( ?... ) doesn't seem like it's viable with what I know just now..
    -don't know the prefix for either and tintin ( sadly ) seems to have settled quietly to rest in the pool of old protocols..

    anyways, I figured maybe polygome and tml / grainstorm might approximate the same approach.. ?
    so I think I'll try that..

    -there used to be an app that would swap prefixes mapped to keys or middi notes, I wonder if something like that could be adapted to work within quadrants..? so you could have say two or four different 64 apps per quadrant that you could select and then tab between on the fly.. , for live use that'd be great especially if you could patch the audio out of one app to the input of another..

    not that you don't already have enough work or anything..

  • I don't see any options for choosing programs to route into quadrants when I have other max patches open. Is there something else I need to change?


  • you'll need to update your serialosc.maxpat for your max patches to register themselves. see here for the newest: http://monome.org/docs/app:serialosc#maxpat

    if that doesn't work, tell me more about your computer / OS / max version. if it's not working it's probably an osc / port issue.

  • I've only had serialosc for a few days so I think it's the most recent. Do i need the zeroconf version or just the normal one?
    15-inch, Mid 2009 / 2.8 GHz Intel Core 2 Duo /8 GB 1067 MHz DDR3 / OS X 10.9.2 (13C1021)

    Max 6.1

  • Alright, so I updated serial osc and tested quadrants with arpeggiator and press cafe and it worked right away. But, I really want to use the party van on half of my 128 but when I start it up the party van doesn't show. Is there something with the ports that I might need to change inside party van to get it to show?

  • I changed out serialosc in the party van and now it shows up but the top row of buttons don't work...any ideas?

  • Everything works but it's a little laggy and sometimes freezes, I guess it's just my old laptop. I'm going to work on getting it to run smoother, thanks for your help though.

  • this last point sounds like a threading / prioritization issue. at some point soon i'll get a standalone version of quadrants built (ie. quadrants will be it's own app - not inside max) which should hopefully solve some of this.

  • Party can has a wierd thing with me that turning overdrive _off_ in max makes it work much better...

  • I was wondering if this app can span 2 256's to create a 512 ?

    I have the DIY 512 and am interested in using it as a complete 512


  • i'm pretty sure all of the 512 apps have provision to connect 2, 256s as even the official 512 is two separate 256 circuits running on a usb hub. best to simply try it out and ask if you can't find a solution.

  • @galapagoose thanks

    I was thinking this app might have been able to give me more access to apps for the 512 for some reason, my bad it's been a long day :)

    I am assuning mlr2.51 512 edition is not serialosc though?


  • @galapagoose

    when switching from another app to quadrants i noticed it isn't redrawing quadrant's leds. is this currently not implemented? i went through all the apps i'm using and added the 'redraw patch state on focus' stuff, so i know that can't be it.

  • oh yeah that's probably not implemented. this patch was just an easy 30minute aside when i was making smallbatch, and i only ever envisaged it being used as the sole distribution app with clients. as such it's highly likely i didn't make quadrants call it's client's refresh flags when it grabbed focus itself. should be a pretty easy update if you're keen.

  • hi galapagoose, any chance you could add varibright support to quadrants2? I started editing the qled-router.js to handle grid/led/level/... messages but can't get it to work properly (especially row and column messages aren't working). Same request for smallbatch by the way ... would use these all the time if varibright were supported ...

  • hello! using the new 128 grid, everything from clean install, most recent versions downloaded from docs…

    trying to use quadrants2 to split the 128 into two 64's. testing with 64 fingers, skr, and flin. i can connect to grid and get response out of each 64 quadrant, but no led feedback on physical 128 grid. any suggestions? thanks for any thoughts to share!

  • tried again tonight…. max 7 installed, latest serialosc, all fresh downloads from the docs. same response- no led feedback on the grid. surfed the forum, tried a few things here and there. can't figure it out. wonder if anyone has the same experience?

  • Hi Jay, are the patches you're trying to run using varibrightness? Quandrants2 doesn't support this in the current version ... Hoping for an update ...

  • hey ithkaa! i was testing quadrants2 with 64 fingers, skr, and flin. i don't need varibrightness functionality at all for those apps… but perhaps that is what is causing there to be no led feedback, not even monobrightness? the setup I'm trying to achieve is left half of the 128 as 64 fingers and the right half as flin or skr, doesn't matter which. i am trying to use the new 128 though… i wonder if that is problem?