Can't Get Monome to Work

  • So I deleted everything and started from scratch.

    I installed everything and put the MAX/PAT file in all of my MAX patch folders.

    Nothing is communicating with the Monome and when I run the "check" I get this message:

    Last login: Sun Mar 16 11:20:01 on ttys000
    /Users/Marko/Desktop/monome-commands/check-monome.command ; exit;
    localhost:~ Marko$ /Users/Marko/Desktop/monome-commands/check-monome.command ; exit;
    FTDI installed: ok
    FTDI running: ok
    SERIALOSC installed: ok
    SERIALOSC running: ok
    ls: /Applications/Max6/patches/serialosc.maxpat: No such file or directory
    /Users/Marko/Desktop/monome-commands/check-monome.command: line 40: [: !=: unary operator expected
    ls: /Applications/Max5/patches/serialosc.maxpat: No such file or directory
    /Users/Marko/Desktop/monome-commands/check-monome.command: line 42: [: !=: unary operator expected
    ls: /Applications/Max6.1/patches/serialosc.maxpat: No such file or directory
    /Users/Marko/Desktop/monome-commands/check-monome.command: line 44: [: !=: unary operator expected
    MAXPAT installed: NOT OK -- copy serialosc.maxpat to /Applications/Max6/patches (correct for your version)
    logout

    [Process completed]


    Any help would be appreciated.

  • Hi, do a total fresh reinstall as it lists in the set up pages. A search of this forum will also yield answers. I don't understand by "put the maxpat in all of my max folders"
    Have you done as the test result shows and just put the serialosc.maxpat in the max 5 and 6 folder? Each patch has a serialosc, there is no need to put copies of it in every patches folder

  • hi marko,

    run monome_test and post a screenshot of what's not working.

    what hardware are you using?

  • is that Darwin? what version of OSX are you using? I upgraded to mavericks 10.9.2 and found i had to re-install serialosc. follow fluxta's advice as well and see if just doing a fresh install is working.

    also check under settings-users-login items and make sure serialosc is running on startup - it should be but never hurts to check.

  • Hey all thanks for the feedback.

    I am using a Mac OSX 10.6.8 - Monome 256

    My monome was not working. So before I posted. I deleted all my apps and reinstalled everything from scratch. So that doesn't seem to be the problem.

    I couldn't find "setting-users-login" Help?

    Attached is a screenshot of the "check"

    THANKS!

  • run monome_test and post a screenshot of that window.

  • which ftdi driver did you install?

    maybe use something like app cleaner and remove the ftdi driver and then re-install? I'm not sure, but i'll check the ftdi website too and see if there's any info.

    "I installed everything and put the MAX/PAT file in all of my MAX patch folders."

    thats just the one folder you installed it in right?

    should be right there in the screen shot. All patches reference that one patch as what's called a 'bpatcher' - so you only need one copy and every dev doesn't need to include it with their patches.

  • also what version of osx are you running? i don't see the notifications icon in the menu bar, but i'm aware that many people use terminal or onyx to turn it off - so yeah, would love to know.

    I love your wallpaper. cat AND a piano? win.

  • Hey all thanks for all the help. After a lot of trouble shooting it seems like my monome apps are defaulting to something called "Amplify Panoramic" I have no idea what this is, do I want it for any monome apps?

    Sound I delete it? If I want to keep it is there a way to change monome apps to open with Max as a default?

    Thanks again for all the help so happy to have my monome back!!!!!

    And thanks misk. Cats and pianos keep me going!

  • i have no idea what that is. it'd still be very helpful for me to see your monome_test screenshot!

  • i've never heard of "Amplify Panoramic" but i think there's an easy fix for this.....
    select any .maxpat file on your fie system and hit "cmd + i". navigate to the "open with" tab within the information window, select your appropriate max/max runtime version and hit "Change all" afterwards. Now all your max patches should open with the selected max version by default again.
    hint: you may have to repeat this steps if you're uing older .mxb patch files beside .maxpat files with max.

  • This has happened to me several times with Max/MSP. As a matter of fact, right this very moment all of my .maxpat files want to default to some app I installed recently called "ESE Alpha160214".

    I don't know how this hiccup occurs, but the solution @red mentions above should take care of it.

  • @tehn I am still planning on getting you the monome_test. I upgraded my OS and it destroyed my old computer. So I am waiting for my new computer to arrive.