bees 0.5.2

  • see to get the new version!

    video coming later tonight. lots of new stuff. lots of bug fixes. we're still adding to the documentation, will have it wrapped up soon!

  • Huurraaah!

  • alt+scroll for fast scrolling in list nav and output routing.

  • crickets!? bring the outdoors in.

  • I probably didn't do things right, but when i boot up with the new system it doesn't offer me the choice of selecting different versions of Bees. I seem to be stuck on the Apllication screen and can switch to Modules with encoder 2.

  • mode+power

  • I did, (or at least i thought i idid)i think it's working this time.

  • third times the charm. ;)

    All scenes are loading fine. got a lot of fuzz hi-freq noise starting out a few of the waves scenes...once loaded it is gone. But the grid has a few stuck notes at the bottom portion of the 8x8. I'll wait for the notes on those scenes.

    skitter and space are really fun on guitar!

  • Everything seems to be working fine here as well. Crickets seems to have a bit lower output than the other scenes.

    Yes, skitter+guitar=fun!

  • Yay! CV scenes. Time to pull them apart and figure them out...

  • @c1t1zen I had those stuck notes too when i first loaded the stepwaves scene, but when i cleared/reloaded and then put the step operator into a blank scene it worked fine :)

  • I think that scene is monophonic?
    I had too many notes on each step and probably freaked it out. Of course a reboot and ot cleared. A 256 version would be killer.

  • Nice. One of my favorite little demos!
    How do the notes work at the bottom of the sequencer is it adding the column?
    It's duophonic.

  • oh dang...MIDI CC op?!

  • each column (4 cells) is a bitmap, 16 possible values. most signficant bit is at the bottom.

  • i have aleph hooked up to the computer as a usb device, trying to send MIDI CC to computer by am not seeing aleph. anyone tried this yet?

    also is there a a 'serial OP' or some higher resolution 'arbritary' serial data to computer via USB device thingy in the works?

  • midi cc operator is for getting midi input to aleph from a controller.

    i added a note out operator, but results are not totally consistent with all receiving devices, maybe? could use more feedback. if the midi driver is considered solid, it's very easy to add all the other command types in both directions.

    yeah, aleph serial device still in the works. i mean, sending with serial ports works fine, we use it to print debug messages, and its easily hackable. there just isn't a serial protocol in place for aleph/bees, as such.

  • holy crap, @tehn, that new video is awesome. now we're talking. will update to 0.5.2 in a split second. what's the scene you're playing there?

  • Any chance we get can some summary teaser descriptions of new ops that are missing from docs? Particularly step & mout_note.

  • mout_note sends midi notes to an attached midi device if there is one.

    step is a step sequencer for monome grids. it has 2 output that share 1 set of values but have independent positions. values are edited as bitfields with 4 bits.

  • ha! much as I'm in awe of and in love with all the work you've done @zebra... that description (while wholly accurate) is so totally opaque for non-techies .. i actually laughed out loud when I read it, a sort of defensive mechanism laugh as my brain melted.. bitfields indeed! :)

    @emergencyofstate I've just added STEP to the operators pages based on what I understand (though of course I didn't make it) @zebra @tehn have I got it right? I've tried to make the explanation clear for dummies like me, there doesn't seem to be an established format for Grid information on the operators page so I just made one up :)

  • @duncan_speakman (I always think of Dr. Spaceman from 30 Rock when I read your name btw)

    Cool. I'll check it out. I also added 'List 16' to the ops page.

  • I agree I'm not sure I fully understand the bitmap part...can someone explain the pattern? note one is bottom light, one not up is...
    I thought it was binary like the original 40h default lights idea.

  • Seems the grid needs to be replugged to start sometimes. But loving the step scenes.

  • ah, i'll get the ops page updated! sorry!

  • completely accurate description, duncan, thank you!

    i'll get the midi cc ops added.

  • ok, i'll hold off on converting all the input value displays to hexadecimal then, even though its way more readable


    (not really)

    ... for the record, that was brian's decision to make it a bitwise interface! not that i don't approve.

  • hmm..okay midi note operator seems like a good entry hack. been so darn busy..but really curious to learn how to work with the op code..must set aside time.

    thanks for the info zebra!

  • My Aleph refused to update from the new files. It would display them but write did nothing. I'm on windows 8.1. The trick to getting it to work was to highlight the folders after pasting them to the sdcard and select properties and check archive. After that it worked. Windows must be doing something to the files when it unzips them.

  • no luck updating here yet. three attempts to format card MS-DOS (FAT) and copy three root directories. no display of files on aleph after powerup/mode held, just "applications", a horizontal grey bar, and "write". getting the 2011 mbp/10.9.2 to see the sd card after trying to load is inconsistent, either internal or external reader. second card, a kingston 8GB (first card physically broke on hamfisted "seating" early on). wondering what i might be missing/doing wrong/if i should get another card.

  • @goiks ah, sorry to hear this-- we've been trying to tune the alignment of the card slot, though you got one of the first units so it might be a little more fiddly. i can send you another pre-loaded card, and in the meantime yes i'd try a third card. it seems the files aren't being seen. be sure to empty the trash prior to ejection on the mac.

  • Has something changed in the shutdown procedure in 0.5.2? Didn't it used to automatically. save what you were currently working on as the default scene? It's not doing that anymore, let me know if this is unexpected and I'll try to trace what's causing it. :)

  • also i'd really like to be able to help with the debug stuff, so two quick questions -
    - where can i find the debug version of 0.5.2 ? can't see it on github
    - in the debug instructions it says we should reflash and note the terminal output. Does this mean after it crashes? should we also look at the terminal output when recreating the crash condition? (sorry if this is a dumb question, i'm not sure when it spits out what :)

  • hi duncan
    i believe the 'save on shutdown' feature is working currently (will check now!). when you power down do you see "powering down, writing default scene" and it takes a ~5seconds to turn off? note that if you've removed the SD card during operation i think it will fail to write to the card (i think!?)

    debug version is included in the main release zip at:
    in the bootloader it's called "aleph-bees-0.5.2-dbg.hex"

    to report debug messages, you need to be running the debug version of bees (by bootloading it from the SD card), then be running a serial monitor application on your computer connected to aleph's usb DEVICE port. i've found minicom under ubuntu the easiest to use, but had trouble running it under osx.

    after you have this running, you should then restart aleph, create the crash, and report the debug printout, along with a description of what you did to cause the crash.

    hope that helps!

  • ah, you tricksters! i downloaded that zip last week (aleph-140402) and it wasn't in there then.. i see it's in there now :)
    i'm using goserial on OSX and seems to work fine, expected some 'proper' debug reports from me in future :)

  • (oh, and yes i do see 'writing default scene', but don't get the scene back when i boot up .. will go through in steps)

  • StepwavesCV used without steps.

    Got a Nebulae module recently and wanted to test it out with my newly upgraded bus powered 128 running from an Aleph. The Aleph is also creating the delay!

  • @duncan_speakman i haven't had any trouble with default scene. maybe there is something specific causing it to break. can you send me the .scn file ? ( )

    that is, the default.scn that isn't working