Effortless user friendly Monome setup on Os X 10.7

  • That was a joke by the way...

    Anyone have any ideas why this error keeps coming up after spending hours trying to get a 256 working on 10.7.

    BTW yes I have a Max 6/Patches folder. It just doesn't see it. Thanks.

    Last login: Mon Apr 7 21:20:39 on ttys000
    Lion-iMac:~ 27Pereshaped$ /Users/27Pereshaped/Dropbox/Max\ Third\ Party/MONOME\ CENTRAL/monome-commands/check-monome.command ; exit;
    FTDI installed: ok
    FTDI running: ok
    SERIALOSC installed: ok
    SERIALOSC running: ok
    ls: /Applications/Max6/patches/serialosc.maxpat: No such file or directory
    /Users/27Pereshaped/Dropbox/Max Third Party/MONOME CENTRAL/monome-commands/check-monome.command: line 40: [: !=: unary operator expected
    ls: /Applications/Max5/patches/serialosc.maxpat: No such file or directory
    /Users/27Pereshaped/Dropbox/Max Third Party/MONOME CENTRAL/monome-commands/check-monome.command: line 42: [: !=: unary operator expected
    ls: /Applications/Max6.1/patches/serialosc.maxpat: No such file or directory
    /Users/27Pereshaped/Dropbox/Max Third Party/MONOME CENTRAL/monome-commands/check-monome.command: line 44: [: !=: unary operator expected
    MAXPAT installed: NOT OK -- copy serialosc.maxpat to /Applications/Max6/patches (correct for your version)

  • I had this problem on 10.7 ... Try to see if your max folder is max6.1 ....then just rename it as max6

  • Hi, that was my first deduction too, but no nothing happens.

  • Actually it is not Max6.1 IT IS Max space 6.1 but the command is looking for Max "no space" 6.

    For this kind of price of these units detail like this is a bit worrying!!!! The setup and software process feels like it was built with a "knife and fork"


  • Fixed it?

  • Yes, thank you very much for your input.

  • hey @pereshaped glad you got it working!

  • Not quite yet :-)

    Have to figure how to get data from and to it outside the dev tools.. Tried the Straw, Sugar Synth etc apps but nothing so far works.

    Nice lights though. I needed a new bedroom lamp.

  • @preshaped: I usually physically copy the dev tools patch into a new one as my starting point the modify, add/remove things as needed.

  • Hey emergentstate, thanks for that. I had bought the Monome 256 and arc to interface with my software:


    But from today have serious doubts about the effort needed to just get this thing...just running.

  • I have to say though that I am very impressed by James Waterworth's cunning deconstruction in "Monome Home"... brilliant and really useful. Probaly the most useful app I have seen all day.

  • Pereshaped, I need to spend more time on your site but what you're working on there seems awesome and pretty deep. Are these apps in Max/Msp already? If so, I'd be glad to run the patches and try to help get some grid/arc controls in there to get the ball rolling...

  • Hi E. I am certain I will not develop for the Monome platform. My experience today is of a very niche implemented controller platform. I prefer much more stable, easier to work with devices. This isn't for me. It looks great, but it doesn;t do what it says on the box. It goes up for sale tomorrow with the Arc 4.

    It is possible that this 256 I was sold on this forum might be broken. Is that possible? The person who sold would have known this. There is no way that something behaves as erratic as this. That or it is badly written software that controls these controllers. This is a first.

  • Who did you buy it from? Your site is amazing and this community would certainly benefit from someone with your skill set. I'm positive your issues will be solved. I'm a dummy and have been using the monome for years.

  • @Cropsie. Thank you. Since my last post I have spent the few hours trying to grapple with it. It would seem that the Monome and Arc are working ok. I will do more tests tomorrow. I can get readings and send data using the available max patches. It is a very different, non-direct way of working, so will spend sometime tomorrow investigating. Perhaps it is just that I don't get it.

  • Pereshaped, happy to hear you got the devices working. Had no problems getting my 256 and arc up and running as well, but yes, the renaming of the max folder name is something that should be a bit more prominently mentioned.

    As said by others before, looking at your website only briefly already tells me it would be awesome to have you develop stuff for the monome platform. So, welcome, and hopefully not good bye so soon again :-)

  • Too bad you're having such a hassle. as we all know/learn, monome isn't exactly plug n play.
    for some less than for others. But with a bit of patience, it's a wonderful and open device your work sure could benefit from.

    To be fair, you didn't describe a specific problem. what was/is failing?
    The above script output just indicates that serialosc.maxpat wasn't found at a hardcoded location. it may not even be critical. I agree this might be VERY confusing to beginners and needs to be changed (btw, no need to rename anything, that's potentially more confusing IMO, just check yourself it's there)

    But did you try to run a specific app?

    There is a discussion on monome setup instructions and what to provide as a primer.. Monome is aware this needs improvement. I'm sure the community would benefit from your experience.You may consider dropping a few lines. It would help.


    (I'm not from monome)

  • Hi 100p

    I spent the evening and today trying to figure it out and I think I have it now. I am not sure why it seemed that hard to configure but I eventually found "monome test" and have it running. I have also realised that much of the max patching I created for the Launchpad and griffin Powermate translates directly to the Monome and Arc so it will not be hard to intergrate it fully into the ESE.

    The problem was the "Max6" in the command code. Max sits in the Applications folder as Max "space" 6. But that was

    Thank you all for taking the time to answer my earlier frustration at it lacking. It's a lot of money to invest to be stuck in that way, but all of your positive suggestions encouraged more exploration.

    Many thanks to everyone.

    I hope to have a basic integration with the ESE in the next week.

    all the best, Pere


    looking fwd to this + in anticipation i will go read about development of the ESE