• haven´t touched my monome for a while now.
    _sum is just the bee's knees. it is super inspiring. love it. thanks a ton for everyone involved. tried to record some loops, but for some reason the recorded files are empty, regardless on which format. i´m able to save them, but seems to have no content when trying to play them back....

  • edit:
    record works. haven´t read the manual to be honest. have to press first [filename] and then [record] an not in vice versa. i was doing it the opposite way...

  • anyone gotten this to work on an mk kit?

    i get noises...but
    - no LED feedback at all for flin, corners ,mlr, beams
    - no scrolling bar for the 'step' sequencer, only the on/off lights show up
    - gome seems to work great
    - the top right button does not control the manager bar (perhaps because its 8, not 16?)

    osx 10.7.5, serialosc1.2a, monome mk kit, works with my other apps i swear it's not my mk's fault :(

    word on the street is there's a new mk firmware? is this necessary?

  • edit:
    [relocated in other thread]

  • feels good to be back with the monome. i too took a break b/c for a while i had trouble getting it to work with Mavericks. all is good now, made a monome_sum vid yesterday:

    took a screenshot of the preset b/c i got some amazing deep bass from flin.

    great work everyone, looking fwd to the update this week!

  • that's really cool. almost reminds me of nin ghosts type stuff

  • i understand you can drop your own samples into mlr, but do they have to be at a specific sample rate? I have monome_sum tempo at 125bpm and my loops are at the same tempo, but they are not syncing up in mlr? am i doing something incorrectly? thanks again, having a blast with this app!

  • @bc3 i'm afraid you'll have to stick to 44.1khz.
    a quick google search sent me to several threads where trent mentions that this is a limitation of xgroove~. i'm curious, which samplerate do you use ?

  • Sorry, must have missed that post about sample rate and thanks for clarifying. Yep, looks like my samples were not at 44.1k! Thanks again!

  • Can we midi control monome sum ?

  • I just now got to playing with it, Really smooth setup, absolutely brilliant to contain it all in a multipage app like this...It's cool to try a few new apps to me. It's a great to plug in and have audio sequencing within seconds.

    They said no MIDI because these are simplified versions of existing apps. That being said...As this is all audio apps it would be cool to have a MIDI app collection like sum.

    Also port this all to the Aleph next. ;)
    just kiddin.

  • ok too sad that there is no midi because the monome needs hands to be controlled but midi controls permits that you play monome and other "real" instruments like guitar, synth, piano and keep your hands on it.

    Second question : is there a way to record sound with the mlr section or this is only a sample manipulation ?

  • @Starfucker there's tons of MIDI apps already for the monome! With the full version of MLR, yes you can record.

  • anyone else try this with a kit?

  • i tried it and it's a great tool!!!
    my preferred apps are gome and parc, but monome_sum gives me a lot of ideas for new sounds and tracks.

    i hope in the next version a way to send out just a midi beat clock will be implemented!

  • Is anyone using Sum with two grids? I see a box to connect a second grid (which i don't have right now). Just wondering how the second grid is implemented? Does each grid control different apps?

  • @blungo2
    the second allows 2 smaller grids to function as one larger one, or you can split any 2 applications across so they each take on their own app (eg: step on a 256, beams on a 128). this is all accessed from the routing page in the same was as for a single grid.

  • Very cool, thanks!

  • just got Sum today and went to have a go at it, my GS 64 connects fine as it usually does with any other app but there doesn't seem to be any response when I press any keys. i can set the route key through the advanced settings tab and select the apps using the route key after that but there just doesn't seem to be any response once I let go. theres no LED response from pushing keys aside from the route key/app selecting and there's no audio output either...

    anyone care to shed any light on the matter? i know there's a strong chance i'm missing something completely obvious here but my head is a bit melted from it, other apps work perfectly and rarely give any sort of trouble. thanks in advance!

  • @kevin - sounds like the dsp might be off? go to preferences, audio settings and check?

  • @declutter - not quite sure what the dsp is can you clarify that a bit? everything seems to be normal in the audio settings as far as i can see anyway. i can select apps using the columns with the route button on the monome i just cant get any sort of response from the apps themselves

  • @raja - oh right, i was assuming it was something more complicated than that! nope, audio status is on and i've tried messing with the driver and device dropdowns, nothing. :(

    hahaha thanks man, its been my name on just about everything for as long as i can remember!

  • macbook 2008

    when using sums, do I need to install max, and the SerialDriver, or can I just git r don with serialosc, the app, and nomes?

  • @kevin
    are you running the standalone version, or the max patch? open the max window (under /Window/Max Window) and let us know if there's any red lines (particularly immediately after loading the patch and/or connecting to your grid).

    just download the .app from the github release and you should be able to open and connect directly - no max required. with 10.9.2 you shouldn't need the ftdi driver either, so it's just serialosc & sum and you're set.

  • @galapagoose - loading the full max patch and i've attached what comes up in the max window when i load it, no change when i connect the grid

  • nothing untoward there. perhaps you could try the standalone to see if it's a max issue. also you might need to update max - i think sum requires 6.1.5 or newer.

  • @galapagoose

    thanks for reaching out. it's appreciated. be well

  • macbook 2008
    the drop down menu (smallbatch) for picking size o grid seems to not work. perhaps I'm doing something wrong?

  • ummm there is no dropdown for picking grid size! the little purple graphic to the right of serialosc is just a display of what size grid you have attached (serialosc tells the app what size the grid is) so you have a quick reference if you've got 2 different sized grids attached.

    are you using a kit or other device that's not working across the full space?

  • thanks for reaching out. no kit, just a bit confused on actually getting vitals working...

  • I just had a ahhhh moment.

  • hi !

    may be a dumb question but how to use beams as a stand alone patch ?


  • i built beams specifically for sum, but you could easily add midi output with a little max skill. take a look at beams.maxpat and you should be able to tack on some on ctlout object pretty easily.

  • ok. so that will be my first dive into max :p
    thank u

  • now that monome, and monome_sum are up and running, the next step in the process is to just experiment using the different apps, right? fuck around wit synthesizer, master controls, and step sound editor, right?

  • yes! get to know how the different apps work and then start to experiment with the GUI parameters. there's lots of nice intersections where the apps coalesce to be found...

  • thanks so much! I feel like I've accomplished something, really. good feeling! crawl before I can walk it seems.

  • 10.9.3 os x.
    I wiped and completed a fresh install for the 'puter, which is a good idea, as I accidentally initialized an empty repo for my entire local directory. I should have completed this in the shell: rm -rf git, however, I'm just learning how to think.

    I'm having to reinstall sum, max runtime, and osc.maxpat, but when trying to run the test, I'm getting this error on the attached image.

    mind shedding some lite on my struggles, please?

  • U are opening the monome test using the app on the dock on the left respect max runtime... What u have to do is right click on the monome _test and select open with max_runtime

  • looks like you don't have quicktime and/or java installed – osx (ridiculously) removed the standard java installation in 10.9

  • java -version in the local reads
    java version "1.8.0_05"
    Java(TM) SE Runtime Environment (build 1.8.0_05-b13)
    Java HotSpot(TM) 64-Bit Server VM (build 25.5-b02, mixed mode)

  • ok... firstly i'd try re-installing Max, and also make certain there's no special characters in your filepath (like $/#/%/^ etc) as that could be making max's search engine fail to find the objects.

    in essence, the problem is that Max can't find it's own folder and hence doesn't know how to display the objects in the patch.

  • trent. @logritm

    good look. it's appreciated, really! up and running smoothly. now, to learn how to think.

  • Don't know if this is the right thread for this.
    Just got my new 128 and sum is soooo much more usable with it than my grayscale 64. It was fun with the grayscale, but the varibright takes it to another level. Really well done, thank you!

    One little glitch so far. After a while, the upper right router button quit routing. When i restarted sum it was fine again. I'm on an macbook air running the latest mavericks.

    Very impressed with sums and my new grid.

  • Kudos for this nifty little package!!
    Just a heads up: one thing that I did notice is that when I placed the app itself in my monomer-dedicated folder it prevented the other apps from launching and caused them to crash.
    Now sum is back in the Applications folder and everything seems fine again.

    EDIT: NO... monome patches are off again. When I launch, say, Park, what happens is that Sum launches for an instant and then crashes.
    I'm on OSX 10.8.3 Macbook Pro 13" no updates, no new Max installs or anything. Just fiddeld around w/ Sum for the past week or so.
    ¿ ideas ?

  • this is a problem with max's standalones stealing file preferences.

    easiest thing is to control-click & get info on one of the other patches (eg. parc).
    under 'Open with:' select Max 6 (Runtime if you like).
    then click "Change All..." which will point all max patches back toward the real max.

    alternatively, you can simply drop the patches onto the Max6 app if it's sitting in the dock.

  • @galapagoose - thx v. much. That solved it indeed!

  • Too early to start a feature request list? (aka, thanks for all the hard work guys, now work harder).

    My top requests (in order of total positive karma transferred from me to the implementer):

    -Assignable tilt. Give us GS peeps some love!
    -Midi enabling everything (flin to notes, beams to cc, etc, etc)
    -mlr playlists / sample lists ( I LOVE the simplified 2 channel MLR because it makes a samplehead like me use more than JUST mlr, but a selection of samples without loading them up in a file browser and dragging them each time would be GREAT)

    For people like me who's programming knowledge barely extends to assigning midi controls, monome_sum IS the future of grids.