LED problem on Monome Grid Kit

  • Attached is a picture of my grid after soldering all the leds and diodes. After the startup animation these leds light and stay lit. Pressing keys seems to dim them but with no certain pattern. Any ideas as to what has gone awry?

    (the leds lit in columns of three but I removed two to see if the solder contact was weird)

  • this looks like you've bridged some pc tracks. easiest approach is to remove the culprit leds, clean them up with solder wick, and then place new leds. if you're short on leds you could try just solderwicking either side of the lit leds and hope it pulls the solder bridge out.

  • Okay, so desoldering and resoldering solved that issue, but I've run into another problem.

    Some keys aren't functioning properly. Using only the Monome Test patch I can make all the leds light, but when pressing the keys to light each led some fail to light. I think the problem is with the diodes, as resoldering solved the issue for most keys, but for those that remain I am at a loss.

    3264 x 2448 - 1M
  • have you checked the keypad star pattern? make sure they aren't bridged. we show this in the docs. otherwise it *must* be the diodes. try replacing one.

  • I've been keeping a close eye on the star patterns, and those problems are easy to spot on the Monome Test patch as the key appears pressed from the moment the Monome connects.

    I have been replacing and resoldering diodes and it seems to work (I'm down to 6 from ~20 problems) but I've run out of fresh diodes and the old ones seem to have shorter legs (maybe I broke them off when desoldering?). In any case, when I try to replace or resettle these keys' diodes I get no change.

  • If I need more diodes, which ones should I order?