new monome grid kit

  • @active check to make sure your solders are clean around the area you're seeing light-up. if the blobs are really big there's a chance that the keypad is touching the blob?

  • @galapagoose I WANT both. oh my god i'd be in geek heaven! I'm saving up for a basic modular tho - which is killing me because the closer i get, the more the word "aleph" runs through my head! AHHHH!!

    also - we should get together man. been working pt. time and doing sound design for some peeps in LA, and thus, quite the hermit as of late. this needs to change!

    and now here I am, playing with max 7 when i *should* be in ableton, and I *want* to be ... playing baldurs gate 2 on my ipad :P

  • @tehn checked the link to the kit site, and upon clicking the link for LEDs, i fell down a LONG rabbit hole at digikey. I blame you. :P

  • Wow a 32x8 is a 512 chopped in half

  • Orderer, and really excited!
    Really glad the kit version is available, thanks! ...I just hope my build skills are up to snuff. Hah! I'm in NY state so hopfully it wont have too far to travel! :)
    Thanks monome crew!

  • Kit was delivered yesterday and the LEDs are on their way still. I also picked up a White Whale today, so pretty excited to get the build underway. I do have a question though...I cant seem to identify the correct orientation of the diodes as mine look different than the ones in the assembly photos...and Damn these things are small! Mine say T4 on them and have what looks like a very faint line across the end with the T on it. I'm sort of assuming that this line will go in the same location as the line in the photo you provide, but I want to check before soldering 128 of these incorrectly. Can you confirm please?

  • If you look through the build instructions, just start with one led and you'd be able to confirm the orientation. The datasheet for your LED may also verify the correct orientation.

  • the t is on the side of the line on the diode. so the t is on the left side of the I< diode graphic.

  • Does this kit ship with the circuit board for the DIY ext5v?

  • @polyoptics no ext5v, no LEDs and no USB cable...ohh and no enclosure.

  • the bottom plate and hardware counts as an enclosure. you'll be able to use this thing immediately and it will be robust. if the open sides bug you, cover them with some gaffers tape and the unit will look better than most plastic crap you buy at guitar center.

  • ext5v is open source. order pcbs here for super cheap.

    https://oshpark.com/profiles/monome

    if you do this, please offer the extras (you get 3 pcbs) to others here on the forum.

  • Thanks for the clarification guys. I don't mind to source the materials myself, however i think i can still get one assembled with my WW purchase. I just wanted to confirm.

    Being new here I find it very apparent that digging for general information is the way of the monome. It definitely helps to keep the comunity small, which (good or bad) it seems is no accident. ;)

    I got my shipping confirmation today and couldn't be happier. :)

  • @tehn that was it, thanks a ton!

  • just a quick question re led brightness. the doc says:

    "you'll need to change two resistors (R3 and R4) on the back of the pcb. they are shipped with a value of 2.2k ohms. we recommend 2.2k, 5k, and 10k values as a start. order at least 5 of each."

    does that mean it might be okay to leave the 2.2k ones as it's shipped, or should we be mixing values util we get a result we like?

  • i'd leave the resistors. change them only if your LEDs are too bright.

  • okay will do. asking because i'm considering white

  • i'm thinking of heat-bending a stripe of acrylic to cover the sides. @tehn, don't you have the pcb and faceplate/bottom plate outlines by chance?

  • ordered a kit. very excited.

  • Going to start building mine tonight -- can i solder 1 diode and 1 LED, plug in the usb and see if I did it correctly?

  • @polyoptics
    that'll work fine for the leds. if you solder corner led nearest the USB jack it'll blink when inserting the usb cable if it's correctly oriented.

    regarding the diodes if you want to make sure they're working correctly, install a 2x2 square of them (ie 4 diodes) and then run a testing suite like 'monome_test' and press 2 keys diagonally. if the diodes are incorrectly installed all 4 keys will be registered, rather than just 2.

    but seriously, the diodes shouldn't be any issue. just follow the instructions & the markings on the pcb and you won't have any issues. it's the leds where it's best to check.

  • Thanks @galapagoose
    Damn, this is a lot harder than I thought! -- My old gear is not cutting it. I think I need proper PCB sized equipment if I'm going to do this right! :)

  • I got the kit in working order. I'm running into an issue when I assemble it that the 4x4 grid in the bottom left's buttons are 'sticky'. Like when I press down they don't come up without wiggling them a little bit. Do I need to tighten/loosen the screws in that area?

  • i should mention this in the docs-- the keypads direct from the factory (as you got them) can sometimes be tacky. it's normal practice to tumble them with talcum powder, though it's bad to get that on the conductive pills. so if they're sticky we typically dust a bit of powder on the top plate, work the keys, then spray off the whole thing with compressed air.

  • Completed mine last night and its working great. Thanks for the help here!
    I'm really impressed with the quality, its super solid and feels awesome!

  • well, I completed mine and it works great...except for *one* button that doesn't work. The LED works fine when triggered by software (sum), but button presses don't do anything. I guess I'll be cracking it back open...any idea what I should look for as the culprit?

  • check the diode solder. then check if the keypad star pattern has a solder bridge. we show this in the docs.

  • Thanks Tehn...it was solder on the star pattern. man that gap is small! All good now.

  • Are these bus powered or will I need an external power supply?

  • bus powered!

  • SUPER HARD!

  • i finished my kit and after troubleshooting some issues (mostly solder arcing across the pads) it works great! I have a 2012 128 as well and I was a little concerned at first since the monome_test patch I had already installed wasn't working with the new kit monome but I downloaded the newest installer, ran it, and it worked with monome_sum great!

    @tehn

    I have access to some CNC equipment and I'd like to cut out a bottom for my kit (potentially out of aluminum :-D) that's like the 2012 128 I have. Would you be willing to share the files you use to cut the walnut? It would make the process a lot easier. :-D

  • I was thinking the same thing...that would be amazing.

  • http://instagram.com/p/wD2pmhOpER

    Having vari-bright really opens up White Whale for me.

  • yeah! i spot 2 of the ww's as well.. brian talks about doing that constantly but i've never seen it appear in the rack.. hah

  • Two White Whales is brilliant, four CVs, four trigs, four gates. And when I'm building modules from kits the WW is the best module for setting up a quick CV/Trig test on new builds, That alone has made it a worthy investment but the actual speed of working on modular grooves is priceless.

  • kit arrived and finished. the only problem was one of the hex stands which didn't have threading. and there is some varibright goodness to explore, yay!

  • Mine arrived, will start build today.

    Should have called it the monome air...

    Man, it's crazy thin next to my now repaired 256. Tehn is of course right. It's superbly rugged. Rather than a wooden case a silicon bumper like an iPhone bumper could work, or a 3d printed ring that sits around the underside if you want it enclosed.

    1024 x 575 - 128K
  • any issues with leds being soldered slightly off center and looking strange through the buttons?

  • @ootini, no, the default leds give very even smooth light.

    my soldering went much faster when i realized that i shouldn't add too much solder to led pads (the picture in the build doc has quite a generous amount).

  • The buttons diffuse the light enough to not notice if the LEDs are a little off center. I think it took me two to three hours to fully populate the board. I actually fell in love with SMD about halfway through. Not having to flip the board and lose loose parts is amazing.
    agreed that you only need a little bit of solder per pad. Anyone with a 3D printer that can print a slim bottom with sides?

  • Or laser cut a few bamboo ply boards and stack them.

    Might do that actually.

    http://www.flickr.com/photos/st8/7113224881/

  • All good here, grid kit in, with diy 128 and diy arc4 in orange/yellow.

    You don't need to print a or make a whole new case as the bottom is fine: just make a layer that goes between top and bottom, like a silicon bumper or wooden perimeter and sandwiched between top and base. Loads of materials and methods spring to mind. Just a plank of wood with a shallow bit routed away will do this. A single SVG file Could be made and you could have whatever you wanted done at shapeways or ponoko etc.

    https://www.flickr.com/photos/tanais/15915717496/

  • sloppy sounding i know, but some black gaffers' tape around the edge and it feels almost like a grayscale 128 but way thinner.

  • If anyone has an unfinished grid kit, can you tell me whether monome_sum, for instance, sees the grid even when the board is empty? I've soldered all the diodes and the first few LEDs, but they're not lighting on power-up. I am pretty confident in my soldering, and the LEDs are good; dmesg shows that the FTDI driver sees the device when it's plugged in. The obvious weak link is my soldering or putting the components in the wrong direction, but I *think* I've eliminated those possibilities -- this seems more like the board isn't programmed.

    I have a note out to info@monome.org, but I thought I'd check here in case anyone had any advice or comment.

  • You should see a flash of LEDs near the corner with the jack. I used a USB charger to test those LEDs not the computer...double check your LED and diode directions. I'm sure your board is programmed.

  • Thanks. Yeah, I've been testing with an external charger. The board is getting power -- I measure 5.1V between VCC and GND at the header.

  • Can we get proper specs for size and dimensions for the pcbs and plate pretty please? I'm going to pull the trigger on a kit but really want to build my own case. I have a mate who can cut me a boss sounding plywood one piece base similar to the current one piece 128 body.

    :)

  • does the kit include tilt circuitry like the other grids? and how to fix occasional 4-in-a-row flickering of leds which appears when pressing button "corners"?

  • @oootini I'm thinking the same, i have a nice block of black walnut and access to a CNC...