is it still possible to use monomeserial?

  • trying to get an app (xfer nerve) running using monomeserial on 10.10.1. tried a bunch of stuff, some permissions, no dice. is this possible? is there some kind of bridge? ftdi driver is installed, tried *.16 and *.18. monomeserial says "no devices available"

  • thanks for the info, will try this out!

  • huh.

    i looked in the files and manually ran the commands. stopped FTDI. stopped OSC. started FTDI.

    launched monomeserial. no dice. tried connecting 256 before and after launch.

    any idea?

    2/15/15 11:15:47.000 PM kernel[0]: FTDIUSBSerialDriver: 0 4036001 start - ok

    2/15/15 11:17:57.212 PM ntpd[162]: FREQ state ignoring +0.005204 s
    2/15/15 11:17:59.952 PM sudo[879]: yroc : TTY=ttys000 ; PWD=/Users/yroc ; USER=root ; COMMAND=/sbin/kextunload /System/Library/Extensions/FTDIUSBSerialDriver.kext/
    2/15/15 11:18:04.013 PM sudo[881]: yroc : TTY=ttys000 ; PWD=/Users/yroc ; USER=root ; COMMAND=/sbin/kextload /System/Library/Extensions/FTDIUSBSerialDriver.kext/
    2/15/15 11:18:04.414 PM[20]: kext file:///System/Library/Extensions/FTDIUSBSerialDriver.kext/ is in hash exception list, allowing to load
    2/15/15 11:18:05.000 PM kernel[0]: FTDIUSBSerialDriver: 0 4036001 start - ok

  • (in the meantime, nerve is nice on lemur, maybe will just use it there and stick to other monome apps)

  • pages lets u run monomeserial/serialosc apps simultaneously.

  • unfortunately, monomeserial doesn't support varibright grids (or arcs). you'll have to use serialosc for those devices and then use something like pages for monomeserial OSC protocol compatibility.

  • we created the 'monomebridge' max patch for situations like this.

    it's a tiny piece of middleware to make your serialosc device 'look' like a monomeserial device.

  • wow you guys are the best, thanks for the additional info, will try it out now

  • craziness! monome doesn't show up in monomebridge.
    it shows in monome_sum, and in a test app, and the test script that raja posted above shows all as ok (After manually creating a max6/patches dir). it's also installed in the factory installed Max 6.1\patches dir, and i downloaded the latest serialosc.maxpat.

    also in pages, when i do discover monomes, nothing happens.

    k-monome.command ; exit;
    FTDI installed: ok
    FTDI running: ok
    SERIALOSC installed: ok
    SERIALOSC running: ok
    MAXPAT installed: ok (max 6)

    [Process completed]

  • here's what bridge looks like, grid test thing works just fine. put serialosc.maxpat in just about every directory on my computer

  • this looks like you're using an old version of serialosc.maxpat -> grab the newest here:

    just drop the whole folder in your max folder.

    if you're using Max 7 you can do a search for all copies of the file & delete as it comes included in the Max distro now.

  • (pages picks up the monome now). nevermind, i was doing a different process

  • hmm.. which max folder. i put it in all of them

  • i did open the package in maxforlive, and i told it to include serialosc.maxpat in the parent, and then that version would at least show up with the dropdown, though i couldn't actually select the monome even though it did show up in the list.
    i'm guessing it didn't have access to the .js file, and that when serialosc.maxpat is not included in the parent, there's some kind of path / permission issue when tryin got get to the maxpat or the js.

    no obvious errors in console when i try to do launch it or find the monome.

  • @galapagoose
    i was trying the new js serialosc.maxpat last night and the menu text was white on white background. had some issues getting it to work in maxforlive too. it's like it wasn't loading the js file even though it was in my filepath.

  • ah- is this max6? it was redesigned for use in Max 7 which obviously has different style defaults. i can try forcing the colour defaults so they show up the same on 5/6/7 but embarrasingly hadn't thought to check..