Trouble Re-flashing firmware on 2010 mk

  • Hello wise people of the forum,

    I’m having some trouble re-flashing the firmware on my monome (mk) kit (2010). I’m on OSX 10.9.5. Intel 64bit. I’ve scoured the few relevant posts on the forum but nothing fixed my problem.

    I built the kit several years ago as a 64 and it worked fine in serialosc. I was able to get a second button board and driver a while ago and just recently had the time to put it all together to make a 128.

    I was able, after some fidgeting, to get PirateRename to work and it appears I have successfully changed my serial # from the mkoooxxx designation to the mooooxxx 7 digit one.
    I changed the serial # in the Makefile: SERIAL = /dev/tty.usbserial-m0000158 and there was already a hex file named mk16x8.hex in the folder so I didn’t feel I had to change that.

    I shorted the pins on the logic board to activate the bootloader.

    I have turned the FTDI driver back on and activity monitor shows that serialosc is not running.
    I ran these commands and got these results which seem to look in order to me (I’m no expert in Terminal but it looks like my device is recognized):

    Brad-Conrads-MacBook-Pro:mk-default110224 Administrator$ ls -lrt /dev | grep usbserial
    crw-rw-rw- 1 root wheel 18, 6 22 Mar 18:15 tty.usbserial-m0000158
    crw-rw-rw- 1 root wheel 18, 7 22 Mar 18:15 cu.usbserial-m0000158
    Brad-Conrads-MacBook-Pro:mk-default110224 Administrator$ ps ax | grep serialosc
    687 s000 S+ 0:00.00 grep serialosc

    After I locate the folder in terminal I run “make 16x8” but get a “no rule to make target 16x8” message:

    Brad-Conrads-MacBook-Pro:debug Administrator$ make 16x8
    make: *** No rule to make target `16x8'. Stop.

    I’m wondering if I’m re-flashing the proper firmware for my kit. It’s the “mk-default110224” firmware. Should there be a bootloader folder with the firmware? The contents of the folder I downloaded are “button.c” “button.h” “Makefile” “mk.c” and the various hex files for the various grids.

    I’m no expert in this but I’m fairly sure I’ve followed the instructions to a T. Obviously I’ve missed something here and would appreciate any help. I'd be more than happy to give more details.

    Thanks in advance.

  • After reading scrubberfox's post it looks like I don't have the proper bootloader files. Can't find them either. Could someone point me in the right direction?


    formatting on the wiki isn't great, easy to miss the link. we're redoing the docs presently.

    let me know if you have further trouble.

  • Thanks tehn. I'll let you know how it goes.

  • Problem solved with complete bootloader files.