Molar VSTi (1.0b29 - 21 Nov 2010)

  • so since this is the "final" version we are gonna get for a while I'd love to hear a list of what we consider the known bugs for now, and how maybe to avoid them?

  • Anyone else having trouble getting mlr style inner looping to work? It only works something like one time in twenty on my 40h/xp.

    Damn, will I have to survive without one of my favorite functions for several months :(... good thing I bought a used bcr2000 just the other day to cheer me up.


    Also, I was planning to use one or two instances of Molar for cc automation. Is there any way of getting a sequence to play only once to the end and stop instead of looping? I thought it would be cool to use a 64 step sequence with warp 0.5 for slow automatic fade in and fade out. If it's not possible, consider this a feature suggestion for a future version of Molar... loop on/off option on each pad.

  • > trouble getting mlr style inner looping to work?

    edit the config file near the end
    "[1] No MLR_Style looping on LP1 pads"
    set to 0.

  • >I'd love to hear a list of what we consider the known bugs for now, and how maybe to avoid them?

    If anyone wants to whisper me any confirmable bug they come across, the OS they are using and the Molar they are using and the host they are using I will post them in the first postof the Unofficial Molar VSTI Tips,Tricks,Tutorials and FAQ Collection Bucket..
    Example:

    Windows XP, Molar256, Ableton 7
    Copy/Paste+Pattern is not copying the current pattern and moving to that pattern.
    Workaround: Select next pattern from GUI (I think there is a way to copy/paste on GUI but I need to have Molar in front of me to confirm)
    Once you have created a new pattern you will be able to switch patterns on device

  • >> trouble getting mlr style inner looping to work?

    >edit the config file near the end
    "[1] No MLR_Style looping on LP1 pads"
    set to 0.

    Yes I tried that, but it didn't have any effect since it's SN1 rows I'm having problems with... sorry forgot to mention that.

    It works like it should on LTG rows, except it doesn't seem possible to loop second to third button for some reason. I tried different numbers for LTG deactivate and resync so it's not that either.

  • I was thinking a bit more about this sequence loop off idea. The optimal would be a new pad or row mode perhaps... pads that retrigger like LTG, but stop at the sequence end, and polyphonic like SND.

    That way I could switch to that instance, trigger some sequences, switch back to the first instance and continue to perform. Not having to worry about the second instance since they'll stop automatically.

    ...something for version two? ;)

  • Un-reproducable bad bug..WinXP, Molar 256, Live 7

    A couple of times I have been jamming away and Bam!,Molar playback just stops even though Ableton is still play enabled.
    The playback position indicator stops showing position except the metarecord position indicator still plays merrily along to it's own silent tune....
    Saving an .fxp and reloading it resets Molar and playback resumes.

    I'll try and catch exactly what I am doing the next time it (hopefully doesn't ) happen.

  • all right folks, i'm new to the molar party and, er, well i must be some kind of moron. i'm running it in live 7.0.7 on OSX.4.11, with an original 40h.

    i put the vst files, config files and component files where they're supposed to go. i launch live and create midi track and the molar display pops up like any other plugin. i run monomeserial and set prefix /40h. and nothing happens. none of my button presses do anything.

    i tried running monomeserial, then live, and the other way around. i tried using /box as well. i watched t1mp's tutorial on vimeo.

    any help, pointers, advice would be much appreciated. the old monochrome works fine by the way. thanks.

  • [40h] the prefix, must be 3 chars exactly!
    [8000] port that Molar listens to. default: (8000) 8004 for lemur
    [8080] port that Molar hosts. (8080) 8000 for lemur
    [127] remote ip address, (127)
    [0] ip address, (0)
    [0] ip address (0)
    [1] ip address (1)

    Monomeserial is on 127.0.0.1? Host port 8000, Listen port 8080?

    Your transport is running in the DAW (If not Molar will not respond)? When you start the transport do you see "Molar...." message run across the monome? That would verify communication to the monome.

    You could also try port 8001 or another port instead of port 8000 in case the port was being held by something else.

  • so the au version is toast? vst works fine.

  • Just downloaded the new beta replaced the dll and config files with the new ones.

    I'm getting nothing but clicking, I can see it has some nice new features, like a waveform display and a filter etc, but I can't get it to play waves properly, also the sample browser is full of jargon. I've downloaded it twice and tried installing it twice on two separate computers and still nothing but clicks, can't hear the wave at all:(

  • uhh weird. Just like this guy here: http://post.monome.org/comments.php?DiscussionID=2113

    Maybe there is a problem with the download? I can email it if you want to try that.

  • Sorry gurulogic, I've double posted, I just changed my user name so it looks like there are two of us, I should have deleted ^ this post ^ but I didn't think there was much chance of anyone reading it at the end of such a long thread, my bad.

    The config file is cool, thats been the correct one since from the start.

    I would really appreciate it if you or steve or anyone finds a work around please e-mail me.

    My email is: kill_all_traitors@hotmail.co.uk

    Regards Richie.

  • Not really a confirmable bug because it doesn't happen in a fresh Live set,
    but the rather elaborate template I am using now puts the Molar on device instance select in the wrong order when I add a new instance.Also, if I delete the newly added instance, communication with the original instance is completely lost.
    I'm thinking this might be tied in with the loss of the C/P+PAT function in this latest build (s)

  • i have simliar problems with the latest build. The only solutions is to remove all instances and start from scratch. At the moment Molar wont even open the GUI after this swapping instances bug happend. Even in a fresh setup molar gui stays grey and freezes live. Looks like more than 1 instance and many diffenent row options and routings make the whole setup really unstable. :(

  • hey .. i must be stupid but i can't get LTG rows to stop ... i'm also confused as to the instructions:

    LTG deactivate (default 14) then Pad+1 ...

    what does that mean ??? ... so i press pad 14 and then ??? pad 15 ? the pad to the right of the 1st pd in the row ? .. nothing of this works ... i just get looping and reversing and retriggering ...

  • what discopimp said, I'd love an answer to that as well.

  • pads 14+15 (which is pads 15+16, if you are counting from one like a normal human) should stop a ltg, works fine here.

  • Does anyone know if theres a way to make Molar ignore incoming midi notes?

  • @gurulogic - What host are you running Molar in? I know this may seem obvious but in Ableton I just set MIDI input to "No Input" on the track that Molar is on.

  • I need the mid input for cc60.I sorted it out by pre-routing and filtering my midi signal through bidule vsti .

  • HUGE request for someday....

    if while having [1] one instance active (outputting sound) at a time only, another instance could be capturing audio from the active instance (or other sound sources) with continuous wav capture.When you switched instances, the capture instance should more or less seamlessly continue playing back what was last recorded from the first instance/sound source.
    Then you could proceed to trigger program changes to the first instance Molar/other gear or what-have-you, and make a seamless transition from one song to another with the captured audio playback smoothing/mixing the transition.
    I realize this can be done manually to some degree but it is quite awkward to seamlessly stop playback on one instance and start playback on another instance with recorded material from the first instance.
    This idea also has creative benefits as you can mix down all your elements on the fly onto one Molar track for mangling without any harsh transitions between the two instances (ie:either both instances playing the same thing at the same time and not sounding so good, or else an obtrusive silent gap...)
    Of course, I guess that can be mostly done with just one instance and quick fingers, unless you are wanting to load a saved arrangement.)

    I am still struggling with seamless transitions and I am sure this one thing would would make all the difference in the world!.

    edit:Well, no sooner than I make some big request and I figure out how to more or less accomplish the same thing in Live with my midi controller muting one instance while I switch to the other.
    The only thing being that the second instance cannot be continuously capturing from the first instance which makes the process a bit more effort, and a touch less instantly creative . I would like to see a continuous capture that stopped capturing and kept the current buffer when the instance was made current.

  • clear tracks in molar?

    dull question:
    suppose you've got LGT- and SN1-tracks recorded and edited in molar (using ableton live): how can you clear this stuff that was recorded and edited to be able to restart with a the "blank" preset?

  • >clear tracks in molar?

    LOAD> Init Everything (Or just Init This Row Wav for one row)

  • Hi guys, I have the 128 for some time, but I lost track reading this huuge thread. I am currenty working on a live improv setup with Ableton and Molar and cant cope with one issue. Well, in Molar I want to devote first four rows for launching clips in Ableton via NOTE MODE in Molar. Then I want rows 5 i and 6 for SEQ mode and row 7 for additional controll (Send on, Rec Arm etc.)
    Now I tried the NOte Chroma preset that seems perfect for launching clips and then tried to change the 5 and 6 row for SEQ, but I get some odd stuff going on – The lowest Row stops working and turns into normal NOTE MODE, so I cant perform all the Molar cool feaures and Rows 3 and 4 act as SEQ mode- but they are in Note Mode - any ideas how to set this up?

    Again - my plan:
    ROW 1-4 - controlling clip
    ROW 5-6 - Sequencing loops
    ROW 7 - controlling other stuff

    I would greatly appreciate any advice

    Cheers
    MArty

  • The presets are really more like 'examples', and you can create a hybrid patch like you're attempting once you know the per-pad settings you desire.

    lowest-row pads must be set to Mode: SEQ in order to have them trigger special lowest-row functions. This is non-intuitive, but intentional, in case you want the lowest row (in part or full) to serve as "Normal" MIDI buttons.

    tip: Keep in mind you can use shift-alt to assign an entire row's mode (or SeqLen, or Note#) at once.

  • Thanks Steve - I'll try that. Thanks for a great app - Molar changed my life ;-)
    (by the way - isnt that a great idea for a song chorus? „Molar changed my life aha aha” ;-)

    Peace
    m

  • I am having huge problems with audio capture only working intermittantly.
    I have only confirmed this to be happening in Live sets with more than one instance of Molar 256.I have things set up so that I can capture in a second instance my entire mix so that I can mute all other audio and execute program/control changes while the capture continues playback but more often than not the capture will not work forcing me to fudge the mix transition.
    I also lose the ability to capture on my primary instance.
    There is no workaround I have found.Reloading both instances fixes the problem untill the next time I load the Live set then it is hit or miss.Rescanning the plugins makes no difference either.

    I have also lost all functions of Lowest row after loading saved Live set twice
    and also switching between BP and LP filters a couple of times while adjusting filters and then ended up with a volume type bar on the top level (no functions activated) of the LP1 row and loss of any control on the row.This has also happened twice.

    Live 7/XP/Molar256

  • Does anyone know of a way to automate the changing of molar .fxp files in live? I'd love to be able to control that with a dummy clip, but I just can't figure out how. I figure if there's a way to control it on device, there has to be a way to automate it...

    Thanks!

  • @hypno|sapien

    That should be as easy as creating a dummy midi clip and drawing in a cc 60 value (1-64) for the clip envelope and routing the clip to a virtual midi port that gets routed back to Molar. I haven't used this exact procedure but it should work fine..

  • Ah, yes...the virtual midi port. I always forget about that. Works perfectly now!
    Thanks, guru!

  • hello guys,

    does anybody know a way to draw midi CC/notes on the filtergraph ?
    I want to map each Step in a SN1 row to Aux Sends in Live.
    I know such an app for Lemur calls Macro Modulator.

    perhaps there is another way to do that..

    thanks !

  • hi - looking for broad tips rather than trying to debug - i'm playing an ableton set tomorrow and want to use molar.

    i've introduced it into my session and instantly (before loading parts or setting it running even) the whole session becomes less stable feeling - i'm getting the odd audio stutter/crackle (if i click on the finder for example) and screen redraws are slow, often with a spinning wheel while i wait. the monome stopped all led feedback on one occasion. cpu usage is rarely rising above 50% according to ableton.

    question - is this to be expected or does this suggest any typical setup problem to anyone?

    osx 10.5.5, monome serial 0.18L (downgraded from 2.0 in case that was the problem), ableton 5.2, max/msp runtime 4.6.3, molar 10b6

    cheers
    matt

  • I'm not a Mac guy but the first thing that comes to mind is could you be maxed out on your computer memory?
    The other problem might be Ableton 5.2. I'm not sure Molar was ever tested for full compatibility on older versions of Live.

  • @Matt

    Are you by chance on a G4? I was never able to resolve the loss of led feedback when I was using an iBook G4.

    And ditto on the 5.2 issue. That very well could be the problem. Maybe try increasing your buffer size in live. If that doesn't help, maybe download the 7 demo and give it a try?

  • Hi all,

    Just started to use Molar and would like to use it with my band as a live looping tool, but I am encountering a problem trying to capture sound within Ableton:

    When I put Molar in a midi track, it does not show up in the [Audio to] drop down menu of the audio track. (see picture)

    Does anyone have an idea what might cause this? At first I thought it could be because I am using a trial version of Ableton live, but as Ableton themselves say: 'The Live Demo cannot save, render to disk or resample the Master output, and ReWire use is limited to 30 minutes per launch. Other than that, the Live Demo acts like the full version.'

    my setup:
    monome 40h
    Ableton live 7 trial version
    monome serial 0.18
    OSX 10.4.11
    Powerbook G4

    686 x 710 - 102K
  • @Matt KU, I agree that I'm guessing your RAM is maxed, you can reduce RAM in the molar config file. Also you want Live 6.0.10 or greater for accurate MIDI timestamping from a VST inside Live.

    @dubbele_lucht, try using the VST, not the AU.

  • hello. steve. i'm having a problem. what happens is, in any DAW i try, molar never plays the waves I load. i dont even know if it loads because the little letters saying "no path" or the sample names simply don't appear. any guess?
    thank you!

  • Hi, I'm hoping to use my 256 in conjunction Molar within FL Studio as a peudo midi keyboard for the lower rows and still as a beat slicer for the upper rows. I'm trying to do this within FL by running midi out of molar and in to a second VST such as a synth, can I ask some advice and pointers?

    Firstly I need to disable the midi out of molar for the top 8 rows so they don't trigger the synth whilst beats are being manipulated within them.

    Secondly, the molar docs say that molar can be allow you to a use your Monome like a MIDI keyboard, by this I'm presuming that each note can be set to trigger a single key of a of say a vst piano? How can I do this? And how can I do this with just the lower half of molar?

    Thanks

  • > molar never plays the waves I load..any guess?

    not sure- you might try the config file for a default wav location and/or verifying the config file is located in the right place/being found. You can try setting filetype to "all files" in the load dialog.

    > disable the midi out of molar for the top 8 rows

    you can do this with shift-alt-drag down on the "note out" readout, do this for the first 8 rows (which sets the row). ...save this as a preset.

    >I'm presuming that each note can be set to trigger a single key of a of say a vst piano? How can I do this?

    Check the built-in presets that start with "note" if you want examples...
    You set the pad mode to "normal" instead of "SEQ" for those pads and the desired note number. you have to set each desired pad one-at-a-time (select pad, pick pad mode, repeat) and save this as a preset.

  • @ Steve

    Using the VST instead of AU did the trick.
    Thanx!

  • steve.

    sorry. no progress. i think molar doesn't load wavs at all, because when I try to copy wav to another row, it says there are no files. this happens to me either with molar and monochrome. don't know if anyone has the same problem, but it's really weird.
    i was really needing molar, it would solve a lot of my "problems"...
    hope some help.
    thank you very much

  • by the way. i'm using an intel macbook pro and monome sixty four - with logic or live.

  • verify the config file is in the correct location (library:audio:plug-ins:vst) - you can verify this by changing the default scrolling message on startup.

    you may need to set your language to english.

  • > disable the midi out of molar for the top 8 rows

    you can do this with shift-alt-drag down on the "note out" readout, do this for the first 8 rows (which sets the row). ...save this as a preset.

    No luck I'm afraid, when I shift-alt-drag down on the note out reading it simply scrolls the note down to (0) this is still sending midi, at least all my vst's still perceive this as a midi note which they then proceed to play.

    I really hope this isn't because I'm using an older version of molar to run in FL.

  • In older molar, try dragging to the TOP of "note out:" which hopefully will say "off".

    you can alternatively set the note range on the VSTi in FL to ignore the lowest note, using their little keyboard channel-settings thingy.

  • ahh right, yes I don't get "off" but I get note 128* which doesn't seem to trigger anything (is 128 not actually a note then in midi terms?) I've tested it and it seems to be switching the midi output for that row to off (is this really happening??) I can't believe it this is really great Steve, I don't have to use any max apps or complex midi routing to spit my monome in to quadrants! Thanks mate :)

    >you can alternatively set the note range on the VSTi in FL to ignore the lowest note, using their little keyboard channel-settings thingy.

    Thats what I thought but they're little keyboard with the zone select and route note job doesn't effect midi going in to vst's.

    Midi in FL is weird, you can only route midi in to it if your running it as a vst. Internal FL midi routing is even weirder, where native FL plugs (Sytrus etc) don't have midi ports but none native vst's (molar etc) are given midi ports (in & out infact) . . ?? This means the midi out of molar cant be routed to ANY of FL's plugs, but can be routed to any vst not made by image line ???? I don't get it . .

    Thanks though man, Molar is a great plugin, I hope you can get the FL compatibility problems licked for the next beta;)

  • quick question:

    does the number of output pairs affect the performance/cpuload ?

  • yes, but not in a significant way / that you should notice on a modern computer.

  • Hi is it possible to map Midi to WARP if so what CC's does it use?

    Cheers
    Steve.