New Application - SevenUpLive - Bend Ableton Live to your will

  • @rent - you can ignore the SevenUpLive-v0.2-src.zip as it's just source code. What you want to execute is the SevenUpLive-v0.2.JAR

    @barnone - wow, thanks for digging into this. You're absolutely correct that the application's timing hinges on receiving that stream of MIDI notes on Device 1. As for why no notes are being received I don't have an answer.

    As inspiration for people to help get this running, I recorded a song last night with SevenUpLive showing off some of it's capacity. This is me playing the app live with no post-production and using only the samples I included in the Template Set: http://www.makingthenoise.com/sevenup/makingthenoise-noreasontoleave.mp3

    Can't wait to get this going for people...

  • barnone is right, Java 1.5 is fine, I've updated the documentation accordingly

  • it says I have updated to Java 2 already, on PC, and it automatically sends me to my archive unzipper when I double click the .jar file...very strange.

    I'll give it another go and see what the deuce is up. thanks for your guys' continuing help.

  • already got it open in Java...I must have set .jar files to be opened with an archiver at some point, which makes no sense. but I should be good to go from here. thanks again guys!

  • This app is seriously amazing!! How can I donate for this??

  • nvm...got some sound. this looks like oogles of fun!

    my dear lord...this is amazing.

    like someone said earlier: between this and the dj64 app, I can kiss my school year goodbye.

  • Very excited to get this going although I'm having troubles making anything work. Please excuse my lack of Java knowledge. This is my setup

    Mac OS 10.4.11
    Ableton 7
    Java 5.0 (according to Java preferences. it also gives me the option to switch to 1.4.2)

    Ive set up the IAC buses 1-5 and switched everything in the SevenUpLive-v0.2.JAR. I've switched the 'midi from' within ableton to the iac drivers.

    I've also downloaded mmj and placed the mmj.jar and libmmj into the java extensions folder.

    When I do this and hit play in ableton Im not getting anything. I've attached screenshots of my ableton preferences along with a screenshot of Sevenup open in Live, monomeserial, and the .Jar file open

    Is there something here Im missing? Is there anyways a mac user "getting started" doc could be written up once the mac bugs are fixed.

    Super excited to start messing around with this thing. thanks!

    483 x 597 - 47K
    1226 x 785 - 222K
  • HI, I can`t get it working too.
    I`m using OS x 10.5.4 and i`m sure to have done everything all right.

    I get the led flashing but in a hyper ultra fast tempo... And live did not send anything to monome.

    I`m also using the mandalone java lib. Is it ok?
    I also delete the RxTx extension, because I understand it`s not necessary with sevenup .2 right?

    best
    rcutz

  • @rcutz
    @freshkicks

    Everyone on OS X, read my last post. The OS X java midi driver has issues. It's not a problem with SevenUpLive itself.

    MMJ driver does not resolve the issue, however
    I tried the http://www.mandolane.co.uk/ driver and it's associated test app and am able to get the events on IAC 1. So this implies to me that the driver will work. However it does not work unlicensed since it tried to throw up a dialog which displays blank and freezes SevenUpLive. So, anyway I ordered the $9 license. However, frustratingly, some human issues you the license in the UK, which means I may not get it for a day.

    I think for now (Although unverified) this may be the only OS X solution unless someone else finds different.

  • @barnone,

    thanks for your comitment... I do read all your posts in this page...

    Do you notice I`m allready using the mandolane extension.. I buy it one year ago...

    Notice: if you put the mandolane and the MMJ, togther in the java/extension; it`s crash the app "sevenup"

    So I`m stack without knowing what to fix...

    do you know what I should Do?

    must I att, my pict`s screen here, do you check?

  • New version is up with some small improvements and cleaner code:

    http://www.makingthenoise.com/sevenup/SevenUpLive-v0.3.zip

    I'm sorry to hear that even the licensed plumstone extension didn't solve our issue with MIDI on Mac. I wish I had a Mac to test with... I might be able to switch over to promidi (http://texone.org/promidi/) which from what I understand, works on Mac.

    Gotta keep chuggin....

  • duuuuuuuude, brilliant. We can save patches now!

  • crossing fingers for the Mac issues to be worked out .... : )

  • @rcutz

    If you are already using the Mandolane plugin on the Mac, make sure that the Midi CLock track (Furthest to the left) is sending Midi to IAC 1 when the transport is active. Look at the Plugin (External Instrument) window bottom left in the Live template and change midi out target to IAC 1.

    You might want to verify midi going out on the port by using a Midi monitor.

    I would verify this myself but UI am away from my main machine this week travelling so I was unable to verify that the Mandolane plugin works.

  • Mac is working!

    Ok, I was able to try out the licensed http://www.mandolane.co.uk/ driver on my Mac laptop. Intel OS X 10.5.4.

    It works!

    So I am happily using Seven Up Live v3 on the mac.

    One thing that bit me is to check that in the Live template, the Midi Clock tracks, left and second from left are transmitting to midi out on IAC Bus 1.

    make sure to change the target of the "External Instruments" plugin on those tracks from Midi Yoke 1 to IAC Bus 1.

    When you hit the transport in Live, make sure that the midi level indicator is flashing on that plugin. You may also have to trigger the clip that is placed in the Midi Clock Track.

    The http://www.mandolane.co.uk/ plug costs @$9. Unfortunately it does not work in trail mode with SevenUpLive as the licensing dialog freezes SevenUpLive.

    200 x 256 - 18K
  • nice!! great work barnone. You're absolutely right that my documentation glazes over the importance of those MIDI clock tracks and that they need to send to Device 1, I'll add it shortly.

    I'm in communication right now with the people at mandolane to see if we can work something out. I'll keep everyone posted.

  • This is really a great app. I encourage everyone to try it. I really like the layout of how the different modes work. Its extremely satisfying to play with.

    The idea of the difference between blinking and solid lights is a great idea and is very efficient.

    That's just the beginning. This app is a treasure trove of fun.

    Also the way you can control Live opens up awesome opportunities.

  • hey barnone, thanks for doing the detective work for us mac users.
    would you be willing to write a step-by-step guide to getting sevenup working in osx? i'm sure it would be helpful to a lot of people.
    thanks in advance.

  • Good news for Mac users. I received a version of proMidi that includes the Mandolane code and is free of cost. I'll have to rewrite some of my Midi code but I'll try to get it done in a day or so.

    @mapmap - My original documentation catered towards windows users but once I get this newest version ready I'll make it more OS agnostic and you'll have your step-by-step guide.

  • @makingthenoise - hooray and thanks!

  • would this work with Logic and 256 ? app looks really nice !

  • There's nothing magical about Live, it's just what I'm familiar with. The only real requirements to run this with another DAW are that:

    1. It can accept MIDI input from multiple MIDI devices at once
    2. It can send MIDI output to 1 device
    3. It can accept MIDI control data to change the start offsets of 7 looped samples

    After that, it would just take some basic setup to send the right MIDI notes to SevenUpLive. Once I address the current issues I'll think about posting instructions for other DAWs.

    As a side note, this was originally written for use with Jeskola Buzz but I decided to move on to a more stable environment like Live.

  • Who wants to be a Mac guinea pig?

    I have a new version up that uses a version of the proMidi library that includes the Mandolane code which is supposed to address the Mac+Java+Midi issues. However, I'm not entirely sure if this is going to work out of the box because there is a libProMandoMidiJNILib.jnilib file that was included and I'm not sure what to do with it. I think it might have to go here: /Library/Java/Extensions but I'm not sure.

    Anyway, the new SevenUpLive is here: http://www.makingthenoise.com/sevenup/SevenUpLive-v0.4.zip and there is new documentation in that package that is more geared towards macs.

    Also, Mandolane mentioned you should remove any existing version of their software before using this OEM version. And if it doesn't work the first time, try it along with the MMJ extension as that seems to have helped others (http://www.humatic.de/htools/mmj.htm)

    Can't wait to hear the results....

  • >As a side note, this was originally written for use with Jeskola Buzz but I decided to move on to a more stable environment like Live.

    ... Ahh buzz, I used it exclusively for 5 years. I was thinking of getting it going again because nothing else really seems as flexible for routing or has so many bizarre synths and effects. Sorry for the blatant OT.

  • @makingthenoise: that seems to work, i get sounds and lights for stepper.

    Will have a play around with the rest of the modes :)

  • @pixie - did you have to do anything with the libProMandoMidiJNILib.jnilib file or was that not necessary? I want to make sure my instructions include whether or not Mac users have to put that anywhere

  • Looks like it works fine with it in the same dir as the jar or in /Library/Java/Extensions

  • just a side note:

    the sounds you already have loaded up in here are $...I've made some pretty fun jams with them. :)

    thanks once again for such a fun and useful program, I'll be delving into it indefinitely.

  • totally lost :(

    i got the lights to light up but i get no sound in live.

  • @mapmap:

    Are you on a mac? try this:

    Midi setup:

    Create 5 IAC ports and make sure they are active. (away from my mac so not sure exactly how to do this right now.)

    In SevenUP:

    Midi Input device: IAC1
    Stepper Output Device: IAC2
    Looper Output Device: IAC3
    Melodizer 1 Output Device: IAC4
    Melodizer 2 Output Device: IAC5
    Then click Initialize.

    In live:

    track1 set the external instrument plugin target to IAC1
    track2 set the external instrument plugin target to IAC1
    track3 (stepper) set the midi in to IAC2
    track4 (looper) set the midi in to IAC3
    track5 (melodizer 1) set the midi in to IAC4
    track6 (melodizer 2) set the midi in to IAC5
    Make sure the Number next to the fader for each track is orange, click it if it isnt.

    Hit play.

  • i had a quick play before work this morning and everything seemed to work brilliantly on my mac.

    i'll look forward to having a proper play over the weekend, but this seems like all kinds of cool, muchos gracias mtn!

  • yup. i'm on a mac. set up the IAC busses as you said.
    still can't get any sound out of Live. 7up sure does have pretty lights though
    :(

  • Hi,
    The same for me, I'm on mac with a 128, set up the IAC busses in 7up and live. But no sound out of live.
    However on the 128 the two leds on the right light on.
    And even I press the play button in Live my monome doesn't start flashing rows of light in sync with Ableton Live. No reaction.

  • Hi,
    On mac, same here too.
    It has worked for two days (awesome app...) and now nothing.
    Everything's working on the monome but no sound. I can see sevenup sending midi to live (light top right corner) but not on the IAC bus, weird...
    It's working with standalone synth sending on IAC bus 4&5 for melodizer 1&2. Probably a Live pb ?
    Set up : 64, Macpro, 10.5.4, Live 7.0.7, java 1.6 and libProMandoMidiJNILib.jnilib in java extension folder.

  • Man, I'm lost. Seems to be working for some and not others. rent, golfish & pixie: What version OS's are you using? version of Java? Any suggestions for the people who can't get it running?

  • I feel better now, knowing that I'm not the only one.
    But still pretty bummed out that I can't use this awesome app

  • Is this not a problem with the IAC bus on macs. Try rebooting the computer and try again. I've had this problem routing midi from pd to ableton for ages.

  • OS X people having problems. Try using a midi monitor to see if indeed midi is going to IAC Bus 1 from Live.

    http://www.snoize.com/MIDIMonitor/

    If so, then it is indeed a problem with the java midi native library.

  • Here are my screenshots, I was able to get this going this morning!! Don't know much about java but it was simple following the forum instructions for Java. I also used the Mandolane MIDI SPI. Thanks Mr. Noise, this rocks

    btw I am using it on half of my 128 ( two 40h kits ). I'd assume it works the same for a built 128, just make sure your column/row are set to zero - for the side you set the prefix to box on.

    1920 x 1200 - 213K
    1920 x 1200 - 193K
  • could someone who has this working on a Mac please drop me a line at sstaccato@mac.com or reply here.

  • OSX 10.5.1
    Macbook Pro

    Status: flawless working!!!

    @Making the noise:
    THANK YOU SO MUCH!!! You've unleashed a terribly funky force upon the world. This is exactly what ableton needed to speak to the monome thru. Up until now I was just playing with MIDI mapping to the buttons, which was "aight"

    Since I can't believe how easy this worked for me, and seems others are still having some difficulties with OSX?? I thought I'd at least write up what I did. I don't think pictures are really necessary, I thought everything within this thread thus far and the documentation made making the adjustments self explanatory


    I downloaded the MMJ.zip file as suggested in a previous page, downloaded the 0.4v beta of seven up live, followed the installation instructions for mmj and placed within OSX"s library, copied MMJ with the same directory path I put into OSX's library..i'm not sure why I thought to do this, does it help you might ask...I don't know; but I put it into the sevenuplive folder, and added the IAC buses to OSX.

    Note on IAC bus adding; for me, there was no option in the AUDIO MIDI SETUP application (in OSX utilities) to actually save, which confused me forever, but what works was, clicking into IAC buses, activating the device, remove all ports, adding 5 ports and closing out the window. if you go back into the device you'll notice the 5 ports you added still exist! yay.

    I Opened up 7uplive and followed the directions in the documentation, made the rather apparent changes to the routing (at first I forgot to set midi clock 2 to the IAC bus your stepper is on, this delayed the looper working for me) and started jamming away.

    Even with just playing the demo samples, this patch is amazing. I can't believe how much it really does what's advertised. bending ableton to your monome's will, lol.

    the only problem im having, which I don't think is explained in the guide, is with the looper.

    @ anyone who'se edited the looper samples;
    How do you format your samples for the looper?

    IE: I replaced the sample playing from the demo for loop 7, the guitar, to a simple (I thought) beat I isoalted from a track, when I dropped it into the loop 7 of the drum rack, it would only play a part of the entire loop. I noticed by switching back that the "start" section of the loop for the guitar seems to follow along the path of the "beats", but when I replace it with the beat, the little bar that moves through the sample indicating play position moves through the whole loop, but the audio is only playing some little "chop" of the loop. I tried playing with the length and some other things, messed with the sub menus for that column on the monome and it would only make the "chop" player faster than it already was looping, which sounded bad.

    meaning, when I put a new loop over one of the demo loops, and I play that loop, pressing a button in the loop length column always has the loop start playback from the beginning, how do I tell ableton to chop up the loop?

    I hope that explanation makes sense.

    //funk.ON

  • Reboot my computer, sevenup's working again.
    Pb with IAC bus.
    @Makingthenoise
    Thks again for this amazing app ;)

  • Thanks for making this app, this seems exactly what I was looking for. Today I got it running on mac and everything seems to be working.

    One question though: in stepper mode, the first pattern always plays even when I select another pattern. So if I want to add a second pattern, I can't hear the samples triggering (only the first pattern playing). However, when I switch to sequencer mode everything works normal (I can alternate between them). Am I missing something obvious here?

  • Never mind! I just needed to add the patterns to the sequencer BEFORE editing them to hear my edits (Doh!)

  • YES! finally got it working on my macbook. i don't know what changed but it's working now.

    i guess today is the day for mac users.
    thanks for making this available to everyone.

  • Indeed today is the day for mac users. I get it work on my macpro, and I really don't know why...
    Awesome application! Thanks!

  • I've just returned from a day without internet and was dreading what I'd see here concerning the new update but... horray! looks like things are working for most which means I can concentrate on functional questions rather than technical questions (which is much more fun).

    funkadafi brought up a good one which isn't covered well in the documentation (I'll change that shortly). "How do I import my own loops?". You may have noticed that if you drag your own loop onto the looper drum rack, it may not sound right. This could be for one of two reason:

    1. You dragged the sample onto the drum rack chain itself, thereby replacing the sample AND the MIDI mapping of the chain
    2. You dragged (or hot-swapped) a sample of a different tempo

    Number two is going to be the biggest pain as it should be obvious by now, **the loops must fit your tempo for them to sound right in Looper mode**

    However, this is easy to fix because Live auto-warps your loops for you when they're dragged into an audio track. I've updated the online documentation to address this: http://www.makingthenoise.com/sevenup check out section "4. Looper" for instructions

  • Updated the web documentation to respond to funk's question:

    http://www.makingthenoise.com/sevenup/

    It's in section 4. Looper

  • Hey, I just got this up and running on my 128 but I was wondering if I got this set up right. In the manual it says the "128 and 256 will work only if the starting column and row are changed to create an 8x8 grid." Even though I know its a stupid question I don't know what this means. When I load everything up with the orientation being set to the left in Monomeserial, exactly half of the 128's leds light (the left half), except for the pad in row 8 column 7 which seems to blink in time with the tempo when play is triggered in Live, and the pad to its right in row 8, column 8, which is off. The right half only has to lit pads, one all the way in the bottom right corner and the other to its left which flickers rapidly. Anyone know if this is how its supposed to be, and what the manual is talking about when it says the 128 and 256 will only work if the starting column and row are changed to create an 8x8 grid. Thanks for your time.

  • @producer1620
    It just means that you will only use the first 8x8 grid section (Left half) of the 128.
    What you are seeing sounds correct.