new app: NPC - monome MPC emulator // now v.060

  • peter i want to give you a million hi5's that's how much fun i am having right now.

  • (Edit)

    Samples load, slice, and play back with the latest Max 5 runtime. Lights on the 256 seem to work. Now for the learnin'.


    Anyway, a suggestion.

    Peter mentioned velocity sensitivity in the video, so maybe this is an unimplemented feature. It seems like the grid of large pads on the 256 could actually approximate some kind of velocity input. If you're careful you can hit single buttons within each group, but if you use more of your finger it's easy to hit 3 or more. This is essentially the difference between hitting each "pad" lightly or with more force. Couldn't this data be used to convey a rough velocity value?

    Or did I miss it and this was planned all along?

  • @ mick

    It's awesome that you mention that because it actually just occured to me yesterday. I was thinking about having each button be a different velocity value, but having multiple buttons add up is a great idea. I know it's totally silly but I was also thinking about making a mode that's one step larger so that 4x4 buttons would be one pad.

    @ mapmap

    are you still having trouble? I am going to go through and check the waveform thing and see if I missed anything. are you getting any errors in the display?

    p

  • also at ________________

    I will be implimenting a high 5 function. so get ready.

  • i've already started to prepare for it.

  • peter,
    yeah the wave display is still not working for me in 4.6.3.
    the only errors that i get i think are related to there not being any vsts loaded in my outputs upon opening NPC.
    any thoughts?

    everything seems to be working alright in max 5 though.

  • version 0.52 is up now with a couple subtle improvements. the main thing being init for the box so you don't have to futz with it. The waveform problem might be fixed. along with some other little oddities.

    the permanent home for the npc app is http://flatflat.org/software/npc

    give shout outs about feature stuffs and all that. There's alot more to do!

  • great!!

    How exactly does the "Clock" item work in Options? Is it working?

    I have midi clock signal coming in through midi yoke, and I select external for clock in Options, but NPC doesn't seem to lock on to the tempo.

  • i can get the npc logo on the screen but no audio or wavforms! and the audio button is on the top right corner not left as it says in the instructions.

  • nevermind found the problem! i was using wav files. after loading Aifs everything is good to go. great app! time to integrate dj64 fx into this! anybody ?

  • bummer,
    still no waveforms for me in the new version.
    (and i'm also using aifs)

  • i'm using max 4.6 with a 256 and am getting no LED feedback at all. however, i know the monome is talking with npc because in the options menu the button pressing on the monome corresponds to the monome in the menu. when i load sounds in , i think i am getting an error (see attachments), but nevertheless when i try to generate nothing happens when i push buttons afterwards. hope to get this worked out!

  • forgot to attach..

    393 x 405 - 35K
    384 x 399 - 29K
  • i think it might not like mono samples.

  • also it makes no sense it's not finding the [var] object. reinstall the full version of maxmsp, which includes the runtime.

  • @ eimhim. npc will only sync if you have it playing already, what are you using for midi clock input?

    @ sstaccato - have you changed the prefix in monomeserial to npc? and yes, having var not load will definitely cause the program to malfunction.

    @mapmap - npc should behave well with mono samples. it may be that maxmsp for mac computers is not as polite with wavs as it is with aif files. are you running mac or pc? what's your whole setup? sorry if I've asked you this like 8 times.

  • I couldnt get it running. i am using runtime 5 in OS X.5

    the buttons work and it looks right, but it never makes sound or generates a waveform.

  • go ahead and download the 4.6 runtime. npc is experimental for max 5 at this point. I should have a version up pretty quick that will operate in max 5.

    hey mapmap, I made an app version (if you are running mac) that might work better. it's on the page for the software http://flatflat.org/software/npc

    let me know if that works!

  • @peter

    I'm sending npc midi clock from Ableton live 7.0.3.

    So you mean I should have npc playing, then start playing Live (and send the clock)?

  • ya,

    if you haven't tried it already. give that a shot.

  • 4.6.7

    nothin...i am a sad panda.

  • seems i've solved the [var] problem , as max isnt mentioning that anymore, but what does this mean?

    thx

    370 x 388 - 24K
  • got a real nice jam going last night, sadly I tried to open up a vst and got a crash before I could export it, easy come, easy go though :D

    I already have a [small] stack of feature requests. is now the time for them?

    - midi input, I would like to use my mpd (or any controller with velocity control) to input patterns...
    - live recording... would be really nice to get samples in there on the quick off of records / mp3s / live instruments.

    finally a clarification: do we need to use the pad generator after we have put in a sample? The proceedure that I was attempting to do last night was:
    1) drag sample to sample window.
    2) press pad on monome
    3) press v on keyboard
    4) select sample in drop down

    this did not seem to work consistantly, possibly because I am using max 5, or possibly because I am missing some steps. Could someone help me out here?

    thx much!

  • good questions all around

    4 sst:

    do you have max? if so, put your sound folders in your search path in file preferences under options. if you don't have max, are you using the most recent version of the software? it shouldn't be doing that.

    4 jonbro:

    apologies for the crash. in 4.6 it should be pretty stable... also it might look a little more behaved. i've yet to acclimate to max5s new interface conventions.

    re midi input: it should be operational. if you go to the options window there is a list of all midi ports available. i think it will ignore midi channel at this point, or maybe only operate on 1. but you can use external input to record.

    live recording will be implemented soon! i think i'll have a chunk of time coming up to actually push the software to 1.0

    if you don't want to use the generator:

    1. drag a sample in
    2. select it so that it's waveform comes up
    3. hit add to pad so that that voice is associated with the current pad
    4. select the polyphony type for the pad, and you should be good to go.

    i built the automator given that it's a four step process right now but it should be more streamlined in the future.

    have fun!

  • griotspeak

    so you are using the runtime and a pc? are you getting any connection at all?

  • HOT DIGGITY. Once again, can't wait to get home. This software is hot sauce!

  • FW: With external midi input, it would be awesome if you could trigger playback and record.

  • Macbook Pro
    Mac OS X 10.5
    Runtime 4.6.7

    everything seems fine until i click generate.

  • i am able to load a sample and play it. but when i press the record button i get an error in the post window: 'error: 0mpc_track_record_ctl: no such object' and nothing is recorded when i do a performance with the pads. anyone know why?

    i'm on win xp, max/msp 4.6.3

  • @jah

    You have to select one of the tracks on the monome so it lights up (unmuted), then press the spacebar, and the track is now selected and ready to record.

  • anyone having issues with the 'loop' functionality? for whatever reason w/ loop on i'm not getting continuous loops. the other functions like, pitch, reverse, etc all working fine.

    ps. gratefully donated. i have been bugging peter about this for something like a year. happy to see it come to light. cheers.

  • this is frustrating...

    i've made the adjustments as mentioned, and am still getting the same thing. (see picture1).

    i opened up the npc app, which looks like it still uses max, and i get the same error, even after changing my paths to the folders with the sounds in them. (see picture2)

    i don't understand

  • ah, forgot attachments.

    by picture 1 i mean 7, and by 2 i mean 8

    562 x 427 - 30K
    369 x 387 - 24K
  • also! at no point am i getting LEDs lighting up on my monome

  • gotta hit space left right. it'll give you thirty lives as well as lighting up the monome.

  • ah, thanks. now to fix the problem of sounds not loading?

  • peter posted up a new version that should've fixed the left/right business? have you downloaded that?

  • anyone on the loop issues? even if someone could take a moment and say it's working and not working that would help. i have tried both NPC.app and NPC.mxb and loop doesn't appear to work at is should.

  • actuel,

    have you adjusted the length? in npc once you turn looping on the over all length controls whether you hear a repeat or not... does that make sense? if everything else is working for you it would be really strange if that wasn't... just to be clear: when you select something in a waveform, if it is longer than the length param when you enable loop, you will hear *less* of the sound until you make the length param longer or you make the selection shorter.

  • thx peter for getting back. i see now. i was assuming that 'length' was refering to the length of the sample and not directly related to loop.

  • no probs. just glad the software is behaving! i thought over a couple different approaches to the looping thing and this one seemed the most dynamic although less intutive. the fun starts when you add multiple voices to a pad, pan them hard left and right and give them different loop points. terry riley!

  • ahh, well you've now lured my in with the bait...oh, how i love the me some Rainbow in Curved Air & Persian Surgery...

  • ah, I was baffled by this loop param as well. thx much for clarifying that.

  • ya,

    the documentation is coming along but i figured people could dig around and figure it out. a nice little pdf will be available soon.

  • I've been using the shit out of NPC in max 5 and everything seems to be working perfectly (except for the graphic representation of my 128 in the options window... no big deal)
    the main thing that i've been messing around with is playing samples with my padkontrol and muting/playing the sequences with the 128. it makes it easier to play things like rolls or trickier hi hat patterns.
    i suggest that anyone with some kind of pad controller (trigger finger etc..) give it a shot. very fun.

  • FW:

    It would be really handy if there was a key assigned to tap tempo.

  • i will pop that in the next update no question.

  • ok for a while it was working correctly, now no matter what sample i load, instead of slicing it up when i hit generate, it simply assigns the entire sample to each button on the bottom row of my monome. its actually really frustrating because this app looks amazing and for the 20 minutes it worked, it WAS amazing. help?

  • are you confusing the generate button with the slice button?

    the generate button will generate pads for as many different samples as you want. this is handy if you have 600 random sample archives of super awesome old drum machines already split up in to different samples.

    if you want to take a drum break like amen and chop it up into 128 different pieces on your 256, click the button below that that says slice.

  • i undertand now, i was hitting slice, and then generate (thinking that it didnt assign the slices to a pad automatically) i thought it was necessary to generate after slicing.

    thanks and ill let you know how it goes when i try to drop in a file set (soft instrument)