mlrV::UNLEASHED (rev2)

  • producer1620, I've experienced that problem as well.

  • never mind the volume issue. saw the fix on lighthouse: make sure you've updated to the latest version of max/msp.

    also, loving the slice feature, but i'm noticing an issue with slicing multiple samples within the same group. if you press a button to start a slice in a different sample within the same group while holding down a button on the playing sample, the sample playing will stop and be replaced by the sample you pressed the button with, as normal. however, the second sample will only play for as long as you hold down both buttons; if you try lifting your finger off the first button in the first sample, the second sample will stop playing. not so much an issue, more a request.

  • ive'got the same problem with the slice mode who bug sometimes. Thanks for this amazing new version of our beloved MLR !

    Sometimes, when i'm getting to excited on my monome, MLR V crash :[]

  • Still not getting this to sync tempowise with my Mac using rewire and Live. Any tips?

  • @ i am genko:
    if you save with the presets it should also save wave loop points as well as whatever tempo you have entered in 'next tempo' (see the docs for more detailed explanation).

    current things not saved with presets:
    > group volumes
    > delay send volumes
    > delay settings

    slice mode does indeed need more work.
    both the sample stopping on any release + continuing to play problems have affected me, i just haven't had the time to track down why this is happening.

    just got a new job paying a misely wage so updates may be sparse in the coming weeks. however, every donation i receive is 1 (or a couple) hours i don't need to work and can spend updating and improving the code, and hopefully track down that elusive maxmsp crashing bug.

    donations to:
    trent.gill AT gmail DOT com

    thanks for the kind few of you who have helped support this effort! it is much appreciated.

  • @enjoi

    Saving presets doesn´t even save the waves in the slots. only the library of sounds i used in MLR gets saved here.

    Do you think it is possible to implement some sort of snapshotmode? How long would it take and what amount of donation would be needed for it?

    please let me know.

    thanks, hr

  • @herrreinholt

    dude... actually, it did save the wave selection in the slots for me... the tempo, the selection. the only thing not saved were the group levels and the delay send for each group.

    make sure you get the steps right...

  • @herrreinholt:
    the presets functions *should* save all those things - and has been shown to work on many peoples computers.
    i'm guessing you are forgetting to press 'store' after you have built each preset.
    > you need to save each preset with the 'store' button before you save the whole session with 'save'

    re donations:
    i would prefer people not to think of this as 'payment' for any particular functionality (so long as that functions benefits all), on the contrary i would prefer donations to be to support development more generally.

    thank you all again for your continuing support!

  • Very cool app. Huge props.

    Is there a way to save stuff you record into an input buffer, or into one of the resample buffers, to a .wav file? I've looked around, but can't figure it out, if it's there.

  • @gull>> the answer to your question is in the posts directly before yours..most of the questions asked have already been answered. people need to read the thread

  • Note: please forgive the length of this post. I'm trying to avoid being unclear in my question. The length of the post is just to accommodate my desire to be precise.

    ---

    @devism: I did read most of the thread before I posted my question. I didn't see anything on there that seemed to exactly address my question, and the posts that I assume you are referring to seem a little vague to me.

    Just for the sake of good communication, I'm going to restate my question as explicitly as I can.

    I'm running on WindowsXP Service Pack 2 with Max/Msp Runtime 5.0.4.
    The file I'm running is _mlrV.paxpat -- version 2.

    ---

    When using mlr aes 0.3, I could record something through my laptop's microphone input, into the recording buffer in mlr. It would show up on the waveform display on the bottom right of the window.

    After it was finished recording, I would hit the "write" button, below the waveform display, and a file selection window would come up where I could type in a file name and save a .wav copy of the audio that I had recorded into the buffer.

    ---

    My understanding is this: if the posts directly before mine are answering my question, then they are saying that I should make sure to hit the "store" button for the preset before I hit the "save" button to save the settings and settings_flist files--and that doing this will ALSO save the audio that I have recorded into the input_1 -> input_6 buffers, and the resample buffers, to .wav files.

    I have tried this, and it doesn't seem to have the desired result. What I did was:

    1. Start _mlrV.maxpat
    2. Set the bpm
    3. Record audio into input_1
    4. Click the "store" button
    5. Name the preset in the popup window and hit enter
    6. Click the "save" button
    7. Give the preset file a name
    8. Confirm that preset and preset_flist were created

    9. Close mlrV and open it again
    10. Load the preset file
    11. Hit set to set the bpm

    ...and the settings for my file seem to be loaded, but the audio that I had recorded into input_1 does not appear.

    I did see the comment made earlier on that you could save the audio output by using the audio recorder that sits under the cpu monitor. I'm specifically looking for a way to save the audio data in input_1 at exactly the length that it was recorded at (for example, if I recorded 2 bars at 97 bpm, then I want it to save a .wav file of exactly 2 bars at 97 bpm long)--and, to my understanding, I can't do that with the audio recorder. If I can, please let me know!

    Hopefully that makes things a little clearer.

  • @ gull:
    that functionality is not yet added.
    it is quite a simple addition though so i will get to it asap.

  • @enjoi:

    Groovy. Many thanks for your work.

  • new issue:
    sometimes the volume down gets stuck. as in, when the volume gets turned all the way down (i had all groups turned down, i could do some testing to see if it's any in particular), it stays down: trying to pull it back up only results in it dropping back down. after trying to fix this several times, max/msp promptly crashed (in the middle of a show, no less... but no big deal, my bandmates covered excellently). i restarted it and got it working well, but it ended up crashing again when i got too technical with the recording; i think i started recording into a new buffer while another buffer was loop-recording, which messed things up.

  • So, is it a common problem to have the slice function constantly switching to the regular mode while playing the pads?

  • Hi,

    i finally got my head around mlrv and like it a lot, sadly i can´t get rewire to work, eventhough i follow all stepps neccesary.

    Max runtime 5 says "invalid argument on syn" or something :) when i try to rewire it to Live 7

    any help out there?

    thanks a lot, hr

  • Love the app! I am also having issues with rewire. I get this error:
    object "transport" message "doesn't understand clocksource". This happens when I set the dac to rewire and hit the sync button? Any ideas?

  • yepp, i get exactly the same message like "and"

  • hey - sorry for the absence. the new job is tiring to say the least.

    i thought the 'clocksource' problem was solved with the latest release (rev2) though I could be wrong... i'll check this sometime later in the week.

    have a new revision coming along slowly, but at the moment i'm really just trying to figure out the 'crash-bug'. this means i get to jam in mlr trying to make it crash - subsequently i have been spending a lot more time on real music than software.

  • very niiice - i made a little track with it: http://soundcloud.com/phineus/houston-theres-no-problem-1

  • @ultra

    been trying to listen to your track but... it seems there is a problem... lol.

    it says it can't establish a connection or something...

  • nevermind, it's working

  • Hi there,

    i could solve the rewire problem. I loaded the runtime again and tried to reinstall, the app only installed a 84kb file and suddenly rewire works as expected.

    Just in case other stumble across this problem too.

  • does playing a sample backwards work for anyone else?

    i didnt use mlr much before...but i thought pressing a button and holding while you press a button to the left of it in the same row would play that ppart backwards.

  • actually... i think that only plays the last portion of your sample. playing it backwards works just fine. you have to hit the "+" sign once. it will change into a
    "-" sign. that should work.

  • I've made the "span" backwards thing work but it doesn't do the same thing as in earlier versions of mlr. It seems to only work if you span last button, then 1st (I'm on a 40h) then it seems to step backwards, but only plays the tail of each step, forwards. If I then click on the - sign in the tempo block, then I get backwards-sounding samples for each step. I dunno, playing around with it now, it doesn't seem too predictable but maybe I'm just not getting it.

  • i get error when I try to use outs 5 or 6:
    5[mlr]pl-trig: no such object


    any ideas?

  • #1[mlr]pl-trig is in the pl file for a group..

    that means it's looking for group 5, which, unless things have changed since i last checked, does not exist in mlrv.

  • yeah... i think there was talk of adding groups 5 and 6 for the second version of MLRV. until then, no group 5 or 6.

  • ahh, i figured since it was in the UI it was working.
    I'm having issues with the filter/framework section too, I think it's a path thing in max though... is it working for others?

  • hello guys. Where can i find the reverse option who is present on version 2.27 of mlr. i didn't see it on mlrV :[]

    good holidays :)

  • Click the + to change it to -

  • thank you ! i'm feeling silly right now :]

  • Amazing app. I am having issues when using an external audio interface, most specifically a Focusrite Saffire 10 IO. With the built-in output, my C2D 2.66 iMac is doing just fine with MRLV. Congrats and Happy New Year from Brazil!!!

    Andre

  • thank you very much for putting the hours into this one, been great rebuilding my liveset around mlrV - it allowed me to ditch the rewire route and use max as my only software running during the set. since I play pretty dancey glitched out house and techno the reliability of the timing is pretty important and I've had my run-ins with the live/rewire/mlr4 combo in the past.

    as i've started digging into mlrV (and my max knowledge is very limited) I've added a second midi out port to sync both another guy's laptop running Live and a Machinedrum UW (shooting phrases back and forth between mlrv and the md is a lot of fun). Now, the midi timing did suck before, but now it's always cycling up and down by a bpm or two - every delay goes nuts, which can be nice but not all the time.

    is there anything I can do to try and improve the midi timing, or, as was previously asked, sync it to an external clock? - or is it an problem that requires more fundamental restructuring? just interested to know, cause it impacts the way I can set up my live set.. I'm testdriving this at a new year's eve bash tomorrow, so wish me luck and no loss of sync where not intended ;)

  • Are all Windows users having trouble with the slice fuction switching back into the regular loop mode on its own?

  • @producer1620: i've a mac and i've this problem too, if it can help :]

    could someone explain me how to record a loop in live time with mlrV. i just bought an external soundcard to put my guitar into my macbook, so it would be cool to put some guitar noise into mlr in real time, like in the video showed in the beginning of this topic

  • for some reason the preset features aren't working for me. for example, when pressing "store", a prompt doesn't come up, so i can't save. has anyone else had this problem and am i doing a common mistake? otherwise the program seems to work nicely.

  • @deer

    i dunno about sync as i haven't really used it much with mlrv. please make sure that you file any bugs / suggestions on the tracker, as it helps to keep an official list (edit: already logged here - http://mlrv.lighthouseapp.com/projects/21179-mlrv/tickets/5-no-sync-to-external-source#ticket-5-3)

    @producer1620

    this has happened to me a few times but i haven't nailed down how it occurs. seemed to be after some vigorous button pushing. same for you?

    @alrick

    make sure your inputs are configured correctly (bottom left corner of mlrv). you should see some levels, or can click 'thru' for play-through and confirm that audio input is working. choose 'input_x' (from the row sample selection drop-down) where x is the number of the input you wish to record. i have a 128, so i hit button 9 on the top row to record to input_1. for the 64, you have to click 'rec' i think; don't have one so i'm unfamiliar with the process here. you should see some levels being drawn in the row as it records.

    @spiderman2099

    if you're in fullscreen, the prompt doesn't show up but you can just type and press enter, and it will save. be sure to first store your presets via the 'store' button then save to a file.

  • thanks for the help. the issue still persists, even in window mode. when pressing store, the onclick color flashes, but there's no prompt. an flist is in the directory, but the 0 slot is "empty" and nothing is saved.

    entering the "next tempo" works and the "set" button works.

  • @spiderman2099:
    you have to have your monome type selected in the handy monome chooser (the little rectangles in the bottom right) before presets will work.

    this is required so the presets are setup w/ 8 or 16 steps to avoid having to change the whole set every time you need a new preset.

    an update w/ clock sync is in order but things have been very busy on my side. hopefully within the next 2 weeks.

    t.g

  • oh, shit. thanks.

  • This happens all the time using the slice function, every couple of times I press the pads. It makes the slice function pretty much useless.

  • @producer:
    a solution is near, but it involves completely reworking how the slice mode works which will entail reworking how looping and playback is handled in 2 separate ways... ie. its a pretty big chunk of re-programming and might take a short while til it gets done.
    if it's any consolation it happens to me too and i use slice mode a lot!

    btw - made it to the cycling'74 'interesting work' section.
    see:
    www.cycling74.com

    t.g

  • is there gonna be a 256 version of the GUI? :p the +8 is killin' me hahaha.

    i see progression in this app. making my monome very interesting.

  • Quick question: Is there any way to save the configuration of the outputs? I have everything going into live but i have to set this up everytime i open my file. Also the tempo doest seem to save either.
    Thanks.

  • @dovemouse

    sorry, but no saving of output configuration. but i feel your trouble. there should be a way to do that. oh yeah, and about the tempo, that happens to me too. everything sounds as it should, it's just the number of the tempo that's off. just push "SET" and it should be fine, that is, if you stored the tempo prior to saving.

  • Awesome. Cheers buddy.

  • Hi,

    in the previous mlr version (not the mlrV), it was possible to control volume up and down with a 8wide monome : with the 6&7 button.

    is it already possible with the mlrV ??

    thanks

  • re: 8wide vol ctrl.
    this is possible only if you have a monome with a tilt sensor (64 / 40hse / 40h+accel mod) but not for the original 40h.
    the reason for removing the functionality was to allow tilt control of delay feedback/frequency which to me seemed far more expressive and aimed at live performance.
    t.g