Pages SevenUp Molar setup

  • Hi folks,
    I wasn't sure which existing thread would be best to post this on, so I started a new one since I haven't found anything definitive from my time spent searching the forums and help docs.

    I'm trying to get Molar VST (1.0.b23) and SevenUp (1.3.1) to play in the same sandbox using pages (0.1.38) and ArduinomeSerial (0.20) on a Mac OS 10.4.11 system with Live 8.0.5 as the host.

    I can get each app to work independent of pages, and I can get Molar and SevenUp working if they are the only external app w/in pages, and this is after changing the Molar config file so it's using 5000/5050. When I try to get them all happening at once, I'm getting the beachball as soon as Molar is instantiated.

    Pages is on 7000/7070, 7up is on 8000/8080, and Molar is on 5000/5050

    I've also tried using Monoswitch, but that didn't seem to be the answer.

    Anyone had any luck with this combo of apps?


  • i haven't tried this particular combination but i don't see any reason why it wouldn't work.

    one thing i would try is to just avoid ports 8000/8080 altogether, some apps may be initializing themselves on 8000/8080 by default and then switching over to the configured ports, so this could cause conflicts. you may be able to use netstat to confirm this behavior and contact the dev to get it fixed (hey, it might be me, if so sorry!)

    i know a similar issue was happening with MonomeSerial, you'd set it to 7000/7070 but it would still keep 8000/8080 open. it has since been fixed in MonomeSerial but if ArduinoSerial is based on that original code base then it could also have that same issue. if this is the case then you might just keep arduinoserial on 8000/8080 and set your apps to off ports.

    hope that helps clear it up.

  • 7up is good about only grabbing the ports you specify, however since you specified 8000/8080, it is possible that another app is trying to grab those after 7up has them open. I would try something different 8002/8082 for example.

  • I tried avoiding 8000/8080 altogether and still no joy.

    @phortran, any pointers on using netstat for mac, since I'm not really sure what exactly I'm looking for, and to me the scant documentation feels like trying to read a Latin translation of Naked Lunch! Do I need to set up a timed scan using Terminal?

    BTW, the more time I'm spending in the world of monome, the more I'm amazed and inspired by everyone's contributions. Just thought I'd throw some props out.


  • i think the best way to determine what ports are open is with this netstat command:

    netstat -l -p udp

    this should give you all ports that are open for listening using the UDP protocol (which is what OSC uses).

    when you run arduinoserial, set it to off ports and then run that netstat command and see if it's still bound to 8080. you could then launch programs one at a time and run netstat after each one to see which port each one is binding to. hopefully you're able to find some conflict by doing this and it'll resolve the issue, but ports are just my best guess here.

    let us know what you find!